www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Aus 12V 5V machen


Autor: M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

brauche mal bissel Hilfe, da ich nicht so der Elektroniker bin.

Ich will aus 12VDC v. einem Schaltnetzteil 5V machen für etwas über 3A.
Bei CONRAD hat man mir den LT1084-5 CP empfohlen.
Das ist ein "Positiv-Low-Drop-Festspannungsregler", 5A.
Hab eine kl. Sp-Regler-Bausatzplatine entsprechen bestückt.

Es kommen auch genau 5.00 Volt raus, aber sobald ich die auch nur mit
z.B. 200mA belaste, bricht die Spannung zusammen auf zB. 4.3V.
Dann laufen natürlich meine beiden Festplatten nicht mehr richtig an.
Hab alles nochmal geprüft, finde aber keinen Fehler.
Im Datenlatt (Anhang) steht irgendwas mit 3V Differenz .. aber ich
verstehe das nicht.
Kann jemand helfen ?
Danke,
Marc

Autor: Sebastian K. (basti)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
Wieviel Ampere kann denn dein Schaltnetzteil liefern? Wenn das keine 3A
bringt kannst du die auch nicht auf der 5V Seite entnehmen.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht dein Schaltplan aus insbes. wie gross sind R1 und R2?

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergiss nicht einen dicken Kuehlkoerper anzuschrauben. Bei 12V in und 5V
out macht das bei 3 Ampere fette 21W, die in Waerme verwandelt werden
und entsprechend abgeleitet werden muessen. Der Typ bei Conrad wettet
wohl drauf, dass du bald Ersatz brauchst. Bei solchen Stroemen sind
Schaltregler (gibts auch als fertige Module) effektiver.

Autor: b. Sieber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
post ma bitte den schaltplan von deiner Platine

mfg bs

Autor: André Kronfeldt (freakazoid)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Basti:
Wieso? Der Sinn eines Schaltreglers ist doch unter anderem einen Strom
ungleich dem Eingangsstrom zu entnehmen. Sonst wäre es ja ein
Linearregler. Wenn er 5V braucht bei 3A und einen Schaltregler mit 80%
Wirkungsgrad hat, reichen 1,5625A beim Schaltnetzteil auch aus.

Autor: b. Sieber (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
probiers ma mit sowas (nur ne anregung); des ding ist ein
abwärtsschaltregler; sollte relativ schnell sein.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andre, er hat aber einen Linearregler. Ergo muss das Schaltnetzteil 3A
liefern, wenn er hinterm Linearregler 3A abnimmt.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@b.Sieber
Wo bitte wird in der Schaltung geschaltet ? Das ist ja wohl eher ein
Linearregler mit Leistungsendstufe.

Autor: M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
'tschuldigung, mußte erst scannen .. :-)

Also das Schaltnetzteil kan 12V, 5A. Die 12V werden nur mit ca. 0.75A
belastet. Da müßte doch genug 'Luft' f.d. 5V-Strom sein .. ?

Und hier ist der Schaltplan .. (sorry, nur schnelle Skize).
Geht das so ?

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo, dass muesste reichen. Ungekuehlt schafft der LT1084 aber unter
diesen Bedingungen max. 0,4A bevor er in Rauch aufgeht. Hast du ein
Voltmeter ? Miss mal die 12V Spannung vom Netzteil bei Belastung. Wenn
die stabil bleibt, ist der Wurm in der Reglerschaltung.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... ach so, hatte ich noch nicht gesagt:  Dioden auf 5A-Typen geändert,
dicker Kühlkörper, kl. Lüfter davor ..

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke, dein Problem ist die Tatsache, dass du statt des 7805 einen
LT eingeloetet hast. Der hat eine andere Anschlussbelegung.

Autor: b. Sieber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@The Daz
ist die ausgangsspannung (spannung am -Amp eingang des OPs) kleiner als
die eingestellte Spannung (spannung am +Amp eingang des OPs) so ist der
OP-Ausgang positiv => transistor öffnet => der kondensator am ausgang
läd sich; ist die ausgangsspannung größer oder gleich als die
eingestellte spannung am wird der OP-Ausgang auf masse gesezt =>
transistor sperrt => kondensator entläd sich über die angeschlossene
Last; nach dem ersten aufladen des kondensators beginnt (wenn man am
ausgang Strom zieht) die ganze schaltung, durch das oben dargestellte
prinzip, das schwingen (bzw. schalten); da der strom der in die
schaltung hineinfließt immer ein und ausgeschalten wird ist der
effektivwert des eingangsstromes natürlich niedriger als sein
spitzenwert

mfg bs

PS: ich weiß das es komisch ausschaut, aber man kann schaltnetzteile
nicht nur mit spulen, sondern auch mit kondensatorn aufbauen!!!!

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, gemessen: die 12V bleiben stabil

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Daz:  ja, andere Reihenfolge der Beinchen, habe ich berücksichtigt und
geändert !

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Marc
der LT ist nicht ein einfacher Ersatztyp fuer einen 7805. Er braucht
ein  Widerstaende zur Einstellung der Ausgangsspannung. Schau dir mal
das Datenblatt an. Wenn du den adjust-Pin auf GND ziehst, dann
schaltest du den Regler ab.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@b. Sieber
Ja, sowas habe ich mir nach meinem post dann auch gedacht. Damit wird
aber kein echter Schaltregler realisiert, weil der Transistor nicht nur
im auf/zu Betrieb benutzt wird und damit faellt eben wieder eine recht
hohe Verlustleistung an. Zugegeben: besser als ein Linearregler. Der
Nachteil ist ein brummende Ausgangsspannung.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
--->  DANKE  , das muß es sein !  Der liegt ja auf Masse !
Aber was für einen Widerstand muß ich da nehmen ?
Kann ich ein Poti nehmen ? und welche Wattzahl ?

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poti geht. Wattzahl ist egal, der Steuerstrom ist 50uA.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Schaltbeispiel v. D'Blatt sind einmal 121 Ohm fest gegen Plus
und 36 hm variabel gegen Masse - müssen diese Werte so sein .. ?

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke ein 500Ohm oder 1K Poti sollte auch funktionieren.

Autor: b. Sieber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Daz
ich hab ein regelbares netzteil mit diesem prinzip aufgebaut
(schaltplan etwas erweitert, das man es auch linear betreiben kann)
welches im schaltbetrieb bei ener eingangsspannung von 48V und einer
ausgangsspannung von 5V 7,5A (=> 37,5W) einen eingangsstrom von nur
0, 84A zieht (=> 40,32W) => ein verlust von nur 2,82W => da wird nix
warm!!! (rechnung wenn man den spannungsfall von 0.7V am transistor
auser acht lässt welcher nichtmal ein watt ausmacht)

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ The Daz:  DANKE nochmal !  Werd ich heute abend umlöten :))
Dank auch euch anderen ! :))

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Prinzip kannst du das auch mit Festwiderstaenden machen. Fuer 5V muss
R2 = 3 x R1 sein. Je hoeher die Widerstandswerte sind, desto mehr faellt
der Steuerstrom von 50uA ins Gewicht. Der Fehler betraegt immer 50uA*R2.
Solange du im kleinen kOhm Bereich bleibst, ist das vernachlaessigbar.

Autor: Ernst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@b.sieber & @the Daz:

Das ist ein einwandfreier Linearregler, da wird (ausser vielleicht beim
Einschwingen) nichts geschaltet.

Der OpAmp wird den Ausgangsstrom immer so regeln, dass seine zwei
Eingangsspannungen gleich sind, die Differenz zw. 12 und 5 V wird
komplett im Transistor verbraten.

Ist nunmal kein digitales Bauteil, so ein OpAmp

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

falsches Datenblatt!

es handelt sich um einen LT1084-5CP, richtig?
Dieser hat KEINEN Adj-Pin!
1 = GND    ===|    |   \
2 = V_out  ===|    | o |
3 = V_in   ===|____|___/

das richtige Datenblatt:
http://www.alldatasheet.com/datasheet-pdf/pdf/7029...

Gruß
AxelR.
DG1RTO

DL1RON silent key RIM

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@b.Sieber

Interessant. Kannst du sagen, wie hoch der Brumm ist und welche
Frequenz er hat ? 2N3055 habe ich naemlich noch massig rumliegen und
wenn die Randbedingungen stimmen ist das mal ne echte Alternative.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Axel:  ... äh .. Im Conrad-Katalog heißt der LT1084CP-5 ...!

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Axel
das ist allerdings ein wahres Wort. Habs Datenblatt vom Conrad gezogen,
und das ist das gleiche, wie das, auf das dein link verweist.

Marc, welche Bestellnummer hatte dein Regler ? Muesste auf der Rechnung
stehen.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Axel:  das hieße ja, daß ich den DOCH so schalten kann !
Also KEINE Widerstände zum Einstellen ?  Was ist dann falsch, verflixt
... ?

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Conrad hat der die Nummer 14 82 10 - 27 (die 27 ist glaub ich
unwichtig, nur Merketing-Kennzeichen )

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann hat Axel recht. Nix Widerstaende. Der Wurm muss also auf deiner
Platine sitzen.

Autor: b. Sieber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Daz
brum is in abhängigkeit vom kondensator wenn du einen richtig großen
kondensator (mein netzteil hat 4x 10000µF) nimmst kriegst du ihn je
nach last kleiner 0,05V; Frequenz is abhängig vom ausgangsstrom, wenn
du zwischen OP -ausgang und masse noch einen Kondensator zur dämfung
reinstrickst kannst du das ganze als linearregler bnutzen!!

mfg bs

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... aaarghh !  Mistwurm!  Bei so wenig Bauelementen kann man doch keine
Fehler machen .. dachte ich !

Können die Freilaufdioden damit was zu un haben ?
Oder ist einfach Verhältnis Ein- /Ausgggs-Spg. zu groß und zuviel
Verlustleistung ? Wie gesgat, im LEERLAUF funktioniert alles bestens :(

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab grade mal die 12V direkt auf den Eingang des LT gelegt: dasselbe
Problem. Sobald kleine Last da ist, sackt die Spannung ab, je mehr
Last, desto weiter.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marc,
bei zuviel Verlustleistung muesste der LT sehr heiss werden. Er stirbt
bei 125 Grad. Hast du ihn schon gegrillt ? Wenn du nur 0,75A brauchst,
warum schmeisst du soviel Geld fuer nen LT1084 aus dem Fenster ? Ein
billiger 78S05 bringt 2A und kostet nur nen Euro (nur am Rande falls
dein LT im Eimer ist). Freilaufdioden kann ich in deinem Plan nicht
sehen. Der Gleichrichter am Eingang ist ueberfluessig, du betreibst das
Ding ja am Schaltnetzteil und nicht hinter nem Trafo. Testweise
koenntest du den LT mal freiverdrahtet ohne Platine (aber mit
Kuehlkoerper) betreiben. Die Kondensatoren sind fuer so einen simplen
Test nicht noetig. Wenn er dann noch immer muckt ist er im Eimer.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uberbruecke mal D4 und D1 und schmeiss D2 und D3 raus.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Daz, die 0.75A ziehe ich 12V-seitig. 5V-seitig brau che ich etwas über
3A. der LT wird mit Kühlkörper nur lauwarm.
(Freilaufdioden sind über Relais-Spulen-Hälften)

Hab gerade entdeckt, daß zu Anfang zu HD's wegen zuwenig Spg. nur
'tickern' - und dann laufen sie plötzlich im ..x-ten Versuch an. Spg.
liegt ist offensichtlich langsam um 0.2V gestiegne --> nun bei 4.6V was
offensichtlich f.d. HD's reicht ..

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moeglicherweise fixt das Entfernen der Gleichrichter-Dioden das Problem.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Direktverbindung steht, aber es hat sich nix geändert :((

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auch die GND Leitung direkt verbunden ?

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja !

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm. Klingt wirklich nach nem kaputten Regler oder zu duenne Zu- und
Ableitungen.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zu dünne Leitungen ??? Welche meinst Du denn ..? Nur die zum Regler ?
Oder auch alle anderen ?

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum und vom Regler. Wie breit sind denn die Platinen-Leiterbahnen ?

Autor: M. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Standardbreite sieh mal das Layout (Anhang)
Die Beinkreuzung habe ich gelöst. indem ich das OUT-Bein v. unten
angelötet habe (Regler 'liegt quasi quer ab v.d. Platine).

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst du mal die Spannung direkt zwischen Out- und GND-Pin des Reglers
messen ? Wenn da 5V anliegen sind die Platine oder deine weitere
Verdrahtung Schuld. Wenn dort auch nur 4,6V sind ist der Regler im
Eimer.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
.. da messe ich die reduzierte Spannung von im Moment 4.8Volt

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Not kannst du mit einem Widerstand zwischen GND pin und GND die
Ausgangsspannung leicht anheben. Ein 500 oder 1k Ohm Poti sollte
reichen.

Autor: The Daz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0,2 Volt Abweichung bei Zimmertemperatur sind zuviel. Ich glaube der LT
hat nen Schaden.

Autor: M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das probier' ich mal ....  Okay, geht nur jetzt nicht sofort, muß
erstmal raus. Danke soweit, ich werd's schon noch finden ... ;-)
tschö !
Marc

Autor: Rahul (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da hat dann wohl gerade jemand 13 Euro geschrottet...

Autor: Arno H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Wie gross ist denn der Elko am Ausgang?
das Datenblatt schreibt mindestens 150µF AL oder 22µF Ta-Elko vor, um
die Schwingneigung zu unterdrücken.
Hast Du die Ausgangsspannung schon mal mit nem Oszi überprüft, ob das
Teil schwingt?

@daz und b. Sieber:
mit 12V Eingang und 5V Ausgangsspannung kriegt der 2N3055 knapp 1,5mA
Basisstrom. Da muss ein wenig nachdimensioniert werden..
Eine ähnliche Schaltung mit FET war in der Elrad 12/87 S.32
"Kurz und klein gehackt"
Ausserdem sind im Datenblatt des LM317 von NatSemi (Sept 2001) auf
Seite 15 zwei Beispiele für ein Schaltnetzteil enthalten.
Arno

Autor: Die Waldfee (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LM 1084 IT5,0 = Festspannungsregler 5V 5A
Bei Reichelt 1,55 Euro. Soviel zum Thema Conrad.

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das war wohl schon immer so und Conrad verdient ja daran wie man sieht
nicht schlecht. Bei reichelt kannste gleich nuch restteile + versand
dazu nehmen und is billiger als der regler allein beim C

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.