www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bascom RC5 senden/empfangen


Autor: Christian Kreuzer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

nachdem ich im Forum leider keine passende Antwort für meine Frage
gefunden hab, stell ich sie mal und hoffe, da mir jemand von euch
helfen kann.
Ich muß zugeben, daß das mein ersten richtiges Projekt mit einem
Mikrocontroller und mit Bascom ist.

Ich versuche mit einer lernbaren Fernbedienung 4 verschiedene Signale
im RC5 Code bei einem Tastendruck zu senden und wenn sie empfangen
werden, je nach Code einen der 4 Ausgänge zu schalten (an denen hängt
später ein Funksender).
Der Empfang der Daten und die Auswertung funktioniert so wie ich es mir
vorstelle, leider komme ich mit dem Senden der Daten nicht klar.
Am Oszi sehe ich zwar, daß über die IR Diode (die lernbare
Fernbedienung akzeptiert das Signal auch beim Einlernen) Daten sendet,
allerdings wenn das aufgezeichnete Signal wieder gesendet wird, erkennt
es der Controller nicht.
Die Sendediode ist wie in der Bascom Beschreibung angeschlossen.
Kann es sein, daß ich das Signal invertieren muß?

Vielen Dank,
Christian

Autor: Christian Kreuzer (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier noch der Schaltplan, zum besseren Verständniss.
An K3 hängt der IR Empfänger.

Autor: maenae (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bin zufällig draufgestossen :-)

http://www.do2sha.de/RC5.html

Autor: Christian Kreuzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

danke, aber das war nicht ganz das was mir gefehlt hat.
Wie gesagt, der Empfang und die Auswertung von einer normalen Philips
Fernbedienung funktionieren, allerdings wird beim Tasterdruck nicht das
selbe Signal an eine lernbare Fernbedienung gesendet.
Hab heute mal versucht das Signal an der IR Diode zu invertieren,
leider auch ohne Erfolg.
Hat keiner eine Idee oder einen Verbesserungsvorschlag?

Danke,
Christian

Autor: Christian Kreuzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mir ist gestern noch etwas eigenrtiges aufgefallen.
Ich hab das Programm unverändert gelassen und nochmals in die Philips
Pronto die Signale eingelernt, als ich die mit der Fernbedienung meine
Schaltung steuern wollte, tat sich wieder nichts, allerdings kennt
meine Philips HIFI Anlage die Signale ohne Probleme und macht genau das
was sie soll.
Die HIFI-Fernbedienung akzeptiert meine Schaltung aber problemlos.

Hat jemand eine Idee?
Könnte es am Timing liegen (verwende in der Schaltung einen 4MHz RC
Schwinger)?

Vielen Dank,
Christian

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.