www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR Studio / EEPROM Zugriffszeit


Autor: mr.chip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Kann es sein, dass AVR Studio die Zugriffszeit für einen
EEPROM-Schreibzugriff völlig falsch simuliert? Das EEWE-Bit fällt schon
nach wenigen (10-20) Instruktionen wieder auf 0, im Datenblatt des
Atmega8 steht hingegen eine Schreibzugriffszeit von 8.5 ms.

Ich schreibe 256 Bytes in das EEPROM, alle 2 ms wird gecheckt, ob das
EEWE wieder auf 0 ist, um dann gegebenenfalls das nächste Byte zu
schreiben. Danach lese ich mit yaap das EEPROM (zu Debugzwecken) aus.
Seltsamerweise muss ich den Mega8 ca 10 Sekunden laufen lassen, um
etwas anderes als ein EEPROM aus lauter "FF" einlesen zu können.

Irgendwie seltsam das ganze, hat mir den ganzen Abend gekostet.

Gruss

Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.