www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit PonyProg


Autor: David L. (dave86)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi leute!

ich habe ein kleines problem mit ponyprog und hoffe, dass mir jemand
helfen kann.
es bringt mir zwar keinen fehler beim beschreiben oder lesen des
controllers (ATmega128) jedoch lese ich aus dem Programmspeicher immer
den selben mist. (in hex: 00 01 02 03 ... FF)
auch bei den fusebits kann ich auf write drücken, ohne einen fehler,
doch wenn ich sie wieder auslese ist immer noch der selbe zustand wie
vor dem beschreiben.

hat das schon jemand erlebt? also ich bin mit meinem latein am ende,
und hoffe dass ihr mir weiterhelfen könnt

gruß dave

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> (in hex: 00 01 02 03 ... FF)

Sowas liest man aus AVRs aus, deren Lockbits gesetzt sind.

...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.