www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Programmierung geht nicht mehr


Autor: Thomas Leist (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Folgendes Problem:

Ich benutze immer den gleichen Programmierer (ISP Parallel - aus dem
Tutorial) und hatte auch noch nie probleme damit gehabt.
Nun hatte ich eine neue Platine mir gebaut und die wurde auch gleich
erkannt und ich konnte ohne Probleme programmieren.
Doch auf einmal sagte PonyProg, dass er das gerät nicht mehr finden
kann.
Nun gut dachte ich mir, etwas rumprobiert, nach fehlern gesucht, aber
nichts gefunden.
Also habe ich einen neuen Mega8 raufgesetzt. Mit dem ging es dann auch
wieder. Aber auch nicht sehr lange. Danach hatte ich mit dem auch das
gleiche Prob wie mit dem anderen.
der mega8 wurde mit nem externen quarz (16MHZ) angesteuert. Die
Fuse-Bits wurden so gesetzt wie im Tutorial (Definitiv!!!!). Der ISP
war die ganze zeit immer angeschlossen. Der Reset pin wird beim
Programmieren auf masse gezogen.Der ISP war die ganze zeit
angeschlossen.

Hat jemand eine Idee woran das liegen kann?

Ich vermute das es irgendwie an dem Programmer liegt da dieser ziemlich
lange angeschlossen war (2 stunden). komisch ist halt nur, dass es
vorher nie passiert ist. erst mit dieser Platine.


Danke schon mal
Ich hoffe ich habe nichts vergessen.

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der ISP mit einem neuen Kontroller wieder funktioniert wird der
Fehler wohl an deiner neuen Platine liegen. Ist was parallel zum ISP?

Autor: Thomas Leist (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein, nur der isp hängt am parallelport.
Kann natürlich auch sein dass es an der schaltung liegt, komisch finde
ich es halt nur, dass erst mal funktioniert und dann auf einmal nicht
mehr.
wenn man eine Mega8 defekt ist, würde er dann garnichts mehr machen?
Weil das Programm wird noch ausgeführt. Bloß proggen geht nicht.

Danke

Autor: TravelRec. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn das Timing bei Ponyprog nicht stimmt, weil andere Software beim
Proggen dazwischenfunkt, kann´s beim Controller die Fuses verstellen
und dann ist Ende im Gelände. Guck mal, ob Du Dir einen anständigen
ISP-Progger leisen kannst, der auch mit AVR-Studio zusammenarbeitet,
zum Beispiel die originalen ATMEL AVR-ISP oder AVR-ISP mkII.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.