www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Gentoo: crossdev -t avr schlaegt fehl [solved]


Autor: Bjoern M. (salival)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mich grade nochmal an avr-gcc auf Gentoo versucht und mit
folgendem Forenbeitrag endlich den Durchbruch geschafft:
http://forums.gentoo.org/viewtopic-t-329404.html

Konkret muss man folgendes tun:
emerge crossdev
echo "PORTDIR_OVERLAY=\"/usr/local/portage\"" >> /etc/make.conf
crossdev -t avr
emerge cross-avr/gcc
ln /usr/avr/gcc-bin/*/avr-gcc /usr/local/bin/
emerge cross-avr/binutils
emerge cross-avr/avr-libc

gruss, bjoern.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.