www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Programmfehler


Autor: Thorsten (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich versuche gerade eine Lenkradfernbedienung fuer`s Auto zusimulieren. 
Anscheinend ist aber ein Programmfehler bei mir din. Das Protokoll ist 
so auf gebaut. 8 Bit Serial . 9 ms High Level , 4.5 ms low 
level(Initialisierung). Custom Code senden. Befehl senden , invertiert 
senden. Der Wartezyklus muss bei LowPegel 562µs betragen. Bei einem 
HighPegel muss 2 x 562µs gewartet werden. Danach folgt noch ein endbit. 
Ich hab fast das Prg von einem Pic uebernommen. Ich habe auch schonmal 
per Terminal alles mitgeloggt finde aber kein Fehler. Hat jemand von 
euch noch eine Idee ?

Auf meinem Entwicklungsboard schlummert ein 8535 . Als Compiler dient 
Bascom.

Mfg

Thorsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.