www.mikrocontroller.net

Forum: Platinen Massefläche nützlich oder schädlich?


Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab mich jezt shcon ne Zeitlang durch Inet gewühl aber so richtig
klar geworden ist es mir noch nicht, wann sollte/muß/kann man
Masseflächen ausführen, und wann ist dies eher schädlich?

Ich habs bsiher imemr so gehalten, das ich bei größeren überstehenden
Flächen diese mit Masse verbunden habe, fragt sich nur obs was bringt
oder obs eher schadet.

Leider hab ich auch keine verständliche Einführende Seite im Netz
gefunden :(

Mein "Plan" war jezt fast sogar ne zweiseitige Platine und die eine
Seite komplett als GND zu deklarieren, Fragt sich nur ob das wirklich
was bringt, auser mehrkosten für die Platine...

Autor: Tobi A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmmmmmm
masse schadet selten, ausser wenn es um störströme und so geht dann
kann ein sternpunkt sinnvoll sein.
Wenn Du keinen HF Schaltkreis machen willst oder irgendwas
impedanzkontrolliertes machen willst ist die massefläche auf der
unterseite nicht ZWINGEND aber sicherlich hilfreich, sinnvoll.

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schau mal hier:

http://www.8052.com/forum/read.phtml?id=115258

Wenn du den durch hast dann weist du wie es geht.

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tobi: Eben die Seltenen Fälle interesiieren mich im Momment, die
Platine enthält ein Radiomodul, das einen Frequenzausgagn hat, dieser
geht auf einenn Frequenzteiler, das ganze auf einen AVR, ein Stereo und
RDS decoder soll auch noch mit drauf.
Frage ist halt ob meine kleinen Masseflächen zwischen dien
Komponenteneher Schaden als nützen, und eine "große" Massefläche mit
einer doppelseitigen Platine vieleicht es wirklich Wirkungsvoll
abschirmen würde.


@Joe: Naja ein Auto sollte es nicht werden, aber selbst in dem Thread
sind die Leute sich ja Uneins was nun besser ist :)

Autor: Tobi A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
ok wieviel stück willst Du bauen? Willst Du es verkaufen?
Wenns nur 1 ist massefläche drunter und gut ist. lassen sich halt auch
schön impedanzkontrollierte leiterbahnen draufmachen.
Wenns 10000 sind dann kann man überlegen, aber auch dann würd ich für
die Massefläche plädieren.
Masseflächen zwischen den komponeten würde erstmal nicht schaden würd
ich sagen, solltest aber eventuell analog und digitalmasse trennen und
nur am Sternpunkt verbinden.
Masse schadet selten, aber -wie gesagt- pass auf analog und
digitalmasse auf.

Kannst ja mal einen ausschnitt deines schaltplans asl JPG posten dann
kann man mal draufgucken.

Tobi

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
na ja, biste schnell Leser ? folge mal den Links innerhalb des Thread,
dann findest du das

Autor: Joe (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
sowie dieses

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, sorry hatte versucht eine zu große Datei zu übertragen. Also, hab
noch ein sehr umfangreiches Dokument hierzu kann es aber nicht
hochladen, wo solls hin ? Darin ist so gut wie alles erklärt. Diese
Materie ist zu komplex für einen 3 Zeiler. Bei Interesse also bitte
irgendeine ftp Seite angeben und ich sende es dir zu.

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Joe:
wenns weniger als 20mb sind kanst dus an mail@laeubi-soft.de senden,
das wäre nett. :)

@Tobi: Neee also 1000 soltens nicht werden, soll halt nach möglichkeit
relativ leicht nachzubauen sein.
Ich denke ich werds mal riskieren ohne zweilayer, und wenns zu arg
stört dann nochmal überarbeiten, wird warscheinlich eh nicht nur eine
Testplatine bei rumkommen wie ich mich kenne :-\

Achja Layout anbei, betrachten auf eigene Gefahr, ist auch noch nicht
vollständig fertig geroutet!

Autor: Tobi A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm
wenn das die einzige Masse ist würd ich was ändern. Seh zu das die
Masseleitungen dick sind weil Du dir sonst
a) ne induktivität einbaust
b) spannungsabfall auf der Masse bekommst.

ganz nebenbei würd ich unter dem Quarz aufpassen. Wenns doppelseitig
wird die beiden leitungen unten rausführen. Falls einseitig quarz mit
abstand montieren weil Du dir sonst nen Kurzen einbaust.
Falls das 10uF 10nF Konstrukt oben am TDA ist - umdrehen, die 10 nF
näher an denn Chip ran.
Wenn kein Stoplack draufkommt eventuell die massefläche unter dem TDA
ein bisschen kleiner machen. Da hat man sich je nach Erfahrung mal
rick zuck nen kurzen draufgelötet wenn man an den Beinchen rumlötet.

Das sind erstmal die ersten Dinge...

So far..
 Tobi

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also im Datenbalt sthet explizit drinen "The Layout Path pin2 - C2(das
ist der 10µF) - Pin5 must be as short as Possible... deswegen hab ichs
sorum gemacht. Es sollen später noch mehr Masseflächen hinzukommen,
erstmal sehen wo noch Platz ist, ich werd mal morgen alle Verbindungen
wos möglich ist dicker ausführen, aber bei SMD ist das nicht immer so
leicht g

Platine sollte vorerst nach möglichkeit einseitig werden.
Werde jezt aber erstmal ein bischen die Augen ausruhen, danke shconmal
für die Tips

Autor: Joe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi, sende es dir morgen (Samstag).

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@Joe: Danke!

@Tobi: Habe mal das Layout etwas überarbeitet, aber was du jezt mit dem
Quarz meist versteh ich nicht so ganz...
Also alle "roten" Bauteile werden konventionell auf der Platine
Montiert, alle "gelben" werden auf der Kupfer als SMD bestückt.

Autor: Tobi A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi
das mit dem Quarz ist wie folgt gemeint. Wenn Du beim Löten das Quarz
direkt auf das Kupfer setzt baust Du dir mit dem Metallgehäuse der
Quarzen nen kurzen incl. Masseschluss ein.
Deshalb wenn kein Stopplack und einseitige Platine Quarz mit Abstand
monieren. Falls zweiseitig die beiden Leiterbahnen die von den Pins
weggehen nach unten verlegen.

Ach so, denk mal eventuell über themals nach wenn Du was auf Masse
lötest. Ist ja bei radio net sooooooo hochfrequent das das nicht gehen
sollte, aber thermals machen die Sache wesentlich angenehmer zu löten.

Grüsse

  Tobi

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also den Quarz wollte ich auf dei Seite loten wo kein Kupfer ist, wie
gesagt vorerst wollt ichs mal veruschen ob ich mit ner Einseiten
Platine rumkomme.

Was sind "themals"? Konnte dazu leider nix brauchbares in Richtung
Elektronik finden :-\

Autor: Ulli (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
er meinte Thermal Pads. Siehe auch hier

http://www.layoutcad.com/V11/deutsch/help/3_6_4.htm

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> ...Thermal Pads...
Auf deutsch 'Wärmefallen'...

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahhhhh... okay... hab nämlich nur ne Finische Rockband gefunden fg
Erm.. naja mein Lötkolben schafft das eigentlich ganz gut,ist ja nur
Handbestückung, aber danke für den Hinweis.
Hat noch jemand grobe Fehler etndecken können oder "nono"'s?
Werd mich dan mal dranmachen den rest noch zu verkabeln.

Autor: Tobi A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
<Also den Quarz wollte ich auf dei Seite loten wo kein Kupfer ist, wie
<gesagt vorerst wollt ichs mal veruschen ob ich mit ner Einseiten
<Platine rumkomme.

ich Trottel - logisch. Du machst quasi beiseitige Bestückung

Asche auf mein Haupt

Tobi

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nix trottel, ich gebs zu meine Layouts sehen oft etwas wüßt aus :)
Ich war nur verwirrt wie uber den Quarz da was kurzschließen soll ;)

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sooo.... endlich Zeit gefunden das ganze fertig zus stellen, im Okt
bestell ich die fehlenden Bauteile, dann kanns ans testen gehen :)
Vieleicht mag ja nochmal jemand drüberschauen ob sich ein grober
Schnitzer eingeschlichen hat. ;)

Autor: Wolfram (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
kannst du bitte noch den Schaltplan reinstellen?
da sind einige unklarheiten ohne Schaltplan
1.bei PWM, da wo es an Tuning geht soll da ein Tiefpass sein? und was
ist das für eine Transistorschaltung(BC557)?
2. Am Stromeingang kommt als erstes eine Spule?
Eine solche Spule hat einen ohmschen widerstand von wenigen ohm
dahinter kommt ein Kondensator. Beim Anschalten ist dieses Kondensator
entladen d.h. ein Kurzschluss der nur den ESR hat. Damit ergibt sich
kurzzeitig ein sehr hoher Strom der vom Ausgangswiderstand deines
Netzteils+ Ohmscher widerstand Spule + ESR ergibt. Setze einen
Kondensator davor, man muss es nicht drauf anlegen das die Sache
abbrennt.
3. Trenne Analogen und digitalen Masseteil und verbinde sie nur an
einer Stelle, du willst doch nicht den Mikrocontroller hören.
Wenn du es richtig ordentlich machen willst führe die Antenne nicht
nach
unten (in Zeichnung) sondern nach oben raus und lege auch einen
Groundlayer unten hin und verbinde das ganze mit VIAs. Den Abstand
zwischen Antennenleitung und Groundplane solltest du entsprechend dem
Wellenwiderstand der Antenne dimensionieren.
Schau bei analogdevices rein, da findest du die Gleichungen für solche
Sachen neben allgemeinen Layouthinweisen.

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt keine richtigen Schaltplan dazu.

zu 1) Der Tuner benötigt eine Tuning Voltage von 3V - 7V, diese wollte
ich jezt per PWM bereitstellen. Der Transistor ist ein einfach PNP mit
Basis über 2,2k an den AVR-Pin 22k an +9V als Basispannungsteiler.

zu 2) Ja da kommt ne Funetnstördrossel + Kondesator hin, um die
Eingangspannung zu filtern. Also einfach vor die Spule noch einen
Kondensator? WÜrde das den Einschsaltstromstoß nicht noch erhöhen?

zu 3) Das ganze soll einlagig bleiben damits leicht nachzubauen ist.
Analoge und Digitale Masse zu trenne wäre fürchte ich in diesem Fall
nicht realisierbar (soll ja nun auch nicht gleich 3 Eurokarten
verbrauchen), zum testen muss es so gehen wenns garnicht anders geht
muß ich da ggf mir noch was überlegen.

Autor: Ralf P. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Läubi.

Mir sind da noch zwei masseschleifen aufgefallen, die evtl. als
unerwünschte Antenne fungieren können (siehe Anhang).

Gruß Ralf

Autor: Wolfram (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
zu 1. du führst deine PWMleitung durch den gesamten Analogteil über die
Platine , das gibt nette Störungen, ich schätze die PWM liegt im
hörbaren bereich. Mach wenigstens einen Schaltplan für den PWM teil.
Ich vermisse da den Widerstand des Tiefpasses.
zu 2. ja, aber das Netzteil ist auf seinen maximalen Ausgangsstrom
entsprechend dimensioniert. Deinen Spule höchstwahrscheinlich nicht.
zu 3. probier es aus, wenn dir Störungen auffallen, dann weisst du was
du zu tun hast.

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Hinweis!

zu 1) Ich könnte die PWM Leitung als "Drahtbrücke" per Kabel
ausführen wäre das besser? Woanders hinverlegen wir platztechnisch sehr
eng :-\
Hier der Schaltplan (kann sein das da noch was fehlt habe leider bisher
noch nix mit Spannungsregelung per PWM gemacht)

zu 2) Spule ist für 5A ausgelegt. (
http://www.reichelt.de/?ARTIKEL=FED%20100%B5 ) R_DC = 40mOhm,
"Netzteil" Wir warscheinlich ne Autobaterie (12V) werden. Die
Schaltung wird nacher etwa 200-300mA ziehen (geschäzt)

zu 3) Alles klar :)

Autor: Wolfram (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PWM-Leitung als Drahtbrücke in der Nähe von einem Empfänger ist ganz
übel. Die PWM erzeugt aufgrund ihrer steilen Flanken Frequenzen die bis
in den höheren MHz bereich gehen und wenn man in diesem was empfangen
will sollte man nicht gerade neben der Antenne eine Sendestation
haben.
Wo hast du die PWM-Schaltung her? Ich kann deren Funktion nicht
erkennen. Damit kannst du c1 und C2 aufladen aber nicht wieder
entladen.

zu 2. zieh den Elko vor die Spule dahinter den 100nF dann den 7809
 hinter den 7805 setzt du dann einen Elko, die Elkos zur
Spannungsstabilisierung die du über die Platine verteilt hast kannst du
weglassen die sind zu "träge" nimm da 100nF Keramik. (ist schon
vorhanden)

Ich verstehe nicht ganz was du tust, der 7805 gibt dir eine sehr
stabile Spannung raus, der du aber anscheinend überhaupt nicht traust,
so wie du überall noch Spulen in VCC reinziehst. Auf der anderen Seite
bist du nicht bereit, gegen wirklich Störquellen die du durch deine
Leitungsführung verursachst vorzugehen.

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die PWM Schaltung hab ich mir "ausgedacht" ;)
Hab mir halt uberlegt, C wir über den Transistor aufgeladen, und über
den Input am Empfangsmodul entladen, über das "nachladen" stellt sich
ne Spannung ein. Vieleicht etwas Naiv, aber so war mein
"Gedankengang".

Das mit dem Elko werd ich machen sollte das kleinste Problem sein :)

Die LCs hab ich daher eingeplant da in meiner ersten Schaltung dies
sehr gut geholfen hat die dadrin auftretenden Störungen zu beseitigen.
Und das Problem ist ja: ich muß/möchte die Tuning Voltage per AVR
regeln, daher kann ich den PWM Ausgang leider nicht einfach
"wegmachen" :(

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achja vergessen zu erwähnen: die Schaltung hab ich im Auto eingesezt,
und dort hats halt sehr häßliche Störungen allein schon durch
Lima/Blinker und anderes, deswegen hab ich da nicht an LCs gespart, wie
gesagt bei der lezten Konstruktion hat sich das Rauschen dadurch sehr
gut reproduzierbar reduzieren lassen :)

Autor: RDS Fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
der Spannungsbereich für die Sendersuche liegt meiner Ansicht nach
zwischen 1,5 und 7,5Volt. Und das mit dem PWM würde ich mir scharf
überlegen, villeicht abe ich ja auch was falsch gemacht, aber ich habe
jetzt mal ohne transistor, also nur mit ein r-c glied das aufgebaut und
deswegn nur 0-5 volt als tunig verwendet. (der c hatte ca. 20uf)Dem
Lautsprecher konnte ich dabei nur ein nerventötendes Quitschen
entnehmen. Außerdem steigt durch den c die Spnnung verzögert an,
weshalb dein sendersuchlauf an dem sender schon wieder vorbei ist, wenn
das radio ihn spielt. Dazu kommt noch, dass zumindes bei mir der sender
nach fast jedem aussalten weg ist, weshalb ich die spannung neu
feinjustieren muss. Deshalb plane ich das ganze mit dem TDA 1543 und
mit einer neueinstellung nach jedem start (ca.+-5mV) gebaut habe ich
aber noch nichts.
http://www-user.tu-chemnitz.de/~omat/Mikrocontroll...

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich sehe folgendes Problem bei deiner PWM-Schaltung: Der Emitter deines
Transistors liegt an 9V und die Basis maximal an 5V. An R1 liegen 4,3V,
an R2 0,7V. durch R1 fliesst ein Strom von 1,5mA. Durch R2 ca. 32µA.
Also ist der Basisstrom ca. 1,45 mA mit einer Stromverstärkung von 50
ergibt das einen Kollektorstrom von ca. 72.5mA.
Deine PWM wird so nicht funktionieren.

Gruß

Manfred

Autor: RDS Fan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
ich weiß nicht, ob du es sowieso gemacht hättest, aber damit das Radio
nicht rauscht muss man mute off an masse legen

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Manfred: Welche anderen Werte würdest du vorschlagen?

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Läubi,

ich würde den PNP-Transistor über einen NPN-Transistor ein- und
ausschalten.
Wenn die 9V konstant sind, könntest du in Reihe zu R1 eine Z-Diode mit
4V7 schalten. Anode zum AVR, dann R1 und R2 gegebenenfalls anpassen.

Gruß

Manfred

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Manfred,

Das mit der Z-Diode hab ich jezt nicht ganz verstanden, ob das in die
erste Schaltung soll oder in deine Vorschlag mit dem NPN :-\
Hab nochmal ne Schaltung angehangen wie ich mir das jezt aus deiner
Beschreibung heraus vorstelle, könntest du das nochmal gegenchecken?
Transistorschaltungen sind leider immer so ein Problem bei mir :)

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Läubi,

es fehlt noch ein Widerstand zwischen Kollektor von T1 und der Basis
von T2.
Dies Schaltung ist etwas ungewöhnlich gezeichnet paßt aber sonst. Für
die Widerstände R2 und R3 sollten auch 10k passen.
Zu deiner ersten Schaltung: Der Ausgang des AVR liegt auf 5V die
Versorgung hat 9V. Also liegen an R1 und R2 4V. Nach der Rechnung für
einen Spannungsteiler würden an R2 ca. 3,6V liegen. Die BE-Diode
begrenzt die Spannung auf ca. 0,7V und der Transistor leitet. Am
Widerstand R1 liegen nun 3,3V (habe mich bei meinem obigen Beitrag um
1V verhauen). Würdest du nun in Reihe zum R1 eine Z-Diode Schalten, z.
B. 4,7V, dann könnten an der BE-Diode nicht genug Spannung abfallen.
Ist der AVR auf 0V, dann liegen an der Z-Diode 4,7V an der BE-Diode
0,7V und am R1 4,6V.

Gruß

Manfred

Autor: Läubi (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Okay, nächster Versuch uff

Autor: Manfred (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaut gut aus.

Gruß

Manfred

Autor: Läubi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super danke!
Dann kanns ja bald ins Ätzbad gehen ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.