www.mikrocontroller.net

Forum: Offtopic messchaltung


Autor: wotan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich habe ein problem bei folgender anordnung:

drucksensor(ca. 200mV)verbunden mit dem ME RedLab 1008, dies wiederrum

ist über usb mit dem pc verbunden.
nun möchte ich gerne die gewandelten daten mit einem labview programm
auswerten, aber alles was ankommt sind +-2.5V. kann es sein das das
die
versorgungsspannung für den usb anschluss ist?
danke für eure hilfe

wotan

Autor: Drei Newton (3_newton)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Teste Deine Schaltung durch: gibt der Sensor die richtige Spannung?
Verstärkt ein etwaiger Verstärker korrekt? Ändert sich etwas wenn Du
künstlich die Spannung am Eingang des ADC änderst? Je nachdem weisst Du
dann wo der Fehler ist.

3N

Autor: don hendi (dg3hda) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also,

die meisten Drucksensoren (was für einen haste denn da?) Sind
Wheatstone-Brückenschaltungen. Diese haben 2 Ausgänge, die beide gegen
Masse gemessen auf "ungefähr" halber Betriebsspannung legen bzw.
drumherumzappeln. Das Geheimnis ist die Differenz zwischen den beiden
Ausgängen zu messen! Wenn es denn so einer ist.... Mehr Spez. bitte !

Hendrik.

Autor: wotan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,
Der Drucksensor besteht aus einer Mess- Brücke, so weit richtig.
ICh auch habe bereits einen Sensor mit einem Ausgangssignal von 0...5V
angeschlossen. Bei beiden Sensoren (von Firma Sensortechnics und beide
differentiell) haben am Ausgang die gewünschten Spannungswerte laut
Datenblatt. LabView wiederum gibt nur die halbe Betriebsspannung aus,
das hatte ich mir auch schon überlegt.
Vermehrt tritt jedoch die Fehlermeldung auf, dass die Messbox(Firma
Meilhaus, MiniLab 1008) "mit falscher Boardnummer vorliegt oder erst
gar nicht installiert sein" soll, obwohl ich diese im geeigneten
Kalibrierprogramm finde und auf Richtigkeit geprüft habe.
Meiner Ansicht nach, müssten also die Werte irgendwo in der Messbox
"verschwinden".
Auch bei Druckänderung an den Drucksensoren sind keine Änderungen im
Ausgang zu vermerken.
Auch eure Vorschläge der Überprüfung habe ich bereits durchgeführt. Die
Eingangskanäle werden in Differenz gemessen und mittels externer
Spannungsquelle habe ich einen großen Spannungsbereich ausgetestet.
Nix.
Falls ihr noch eine Idee habt, ich freu mich.

wotan

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.