www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik DTMF mit MT8870DE


Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

ich hatte das hier ja vor kurzem schon einmal.
ich hatte eine schaltung aufgebaut, zur DTMF-erkennung.
die hatte am ende mit der hilfe einiger forumsmitgleder dann auch 
funktioniert.

dann ist das unheil passiert. die schaltung ist manchmal ausgefallen. da 
hab ich ein bisschen dran rumgewackelt, dann gings wieder, und 
irgendwann ging garnix mehr.

nun hab ich mich entschlossen, daß ganze noch einmal ganz gewissenhaft 
neu aufzu bauen, mit neuen bauteilen, alles neu halt.

also, ich habe alle bauelemente überprüft. die wiederstände sind 
richtig, die kondensatoren auch, und alle lötstellen leiten, die 
schlatung ist definitiv richtig.

das DTMF-signal kommt definitiv im MT8870 an.
ich habs sogar mit mein kopfhörern abgehört.

einziger output, wo sich etwas tut ist ESt.

ESt
-- >Early Steering (Output). Presents a logic high once the digital 
algorithm has detected a
valid tone pair (signal condition). Any momentary loss of signal 
condition will cause ESt to
return to a logic low.

bei StD tut sich nix, und somit werden auch wohl die 4 Bit für den 
digitalen code der DTMF signale nicht ausgegeben.

StD-->
Delayed Steering (Output).Presents a logic high when a received 
tone-pair has been
registered and the output latch updated; returns to logic low when the 
voltage on St/GT falls
below V TSt.

Ich bin ein bisschen ratlos, ich muss bald nen vortrag darüber halten, 
und bekomm langsam panik.

ich hoffe, einer kann mir helfen.

danke
MfG
Dieter

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bitte leute, hat den keiner eine idee, warum sich bei ESt was tut, und 
bei StD nicht?
wo könnte da die ursache liegen?

das wär wirklich sehr wichtig für mich.

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bitte leute, es muss doch jemanden geben, der wenigstens eine ahnung 
haben könnte.

warum tut sich was bei ESt und bei StD nicht?
an was könnte das liegen?

Autor: Dieter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
uups sorry fürs nochmal posten.
opera hat irgendwie probleme mit diesem forum.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.