www.mikrocontroller.net

Forum: FPGA, VHDL & Co. Signale im Simulator


Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich mache echt Fortschritte mit dem FPGA & VHDL, vergangene Nacht habe
ich das BRAM zum laufen gebracht :-). Mit meinen eigenen Libs klappts
mittlerweile auch super... Als nächstes kommt der DCM dran, da geht
wohl das WE drauf...

Aber mal eine Zwischenfrage zum Simulator, ich finde keine Möglichkeit
Signale direkt im Simulator anzuschauen. Ich kann immer nur ports
anschauen Z.B.:

signal EN: std_logic := '1'; -- Sehe ich im Sim nicht

Das Signal EN würde ich gerne im Simulator anschauen. Ich muss dass
immer so umständlich machen, indem ich das Signal auf einen Port mappe.
Ein Port wird ja automatisch im Simulator abgedatet.

Ihr habt bestimmt eine Idee wie das eleganter funktioniert,
Sebastian

Autor: xXx (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welcher Simulator? Welcher Baustein? Da weiß man ja nicht mit was du
arbeitest.

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich hast du im simulationview nicht die entity ausgewählt in
der dieses Signal vorkommt. Also im Modelsim Hauptfenster gibt es 3(?)
Ansichten, siehe
reiter unterhalb linken teilfenster, dort simulation (?) auswählen.
Dann zeigt er dir die oberen Module, die anklicken und er zeigt er die
SubModule in diesem Module. Im Signalfenster erscheinen dann die
signale im gewählten Modul.

Falls ich sicher weiss, welchen Simulator du meinst, kann ich ja mal
einen Scheibenschuss posten.

Autor: Sebastian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antworten,

@FPGAküchle
mit Deiner Beschreibung bin ich weitergekommen. Im Modelsim kann ich
mir nun alle Signale anschauen :-)

Normal simuliere ich immer nur in der PackageSim.ise. Darin habe ich es
nicht geschafft die Signalzustände anzeigen zu lassen. Vielleicht hat ja
dazu auch noch jemand eine Idee.

Sebastian

Autor: FPGAküchle (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
#Normal simuliere ich immer nur in der PackageSim.ise. Darin habe ich
es
#nicht geschafft die Signalzustände anzeigen zu lassen. Vielleicht hat
ja
#dazu auch noch jemand eine Idee.

Kenn ich nicht, haste mal nen Codeschnipsel?!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.