www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Programmer


Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Ich möchte mir den ISP Programmer bauen, der unter

http://www.atmel.com/dyn/resources/prod_documents/...

beschrieben ist.
Denk dass es kein Problem darstellen sollte.
Nun möchte ich noch wie bei dem STK500 eine STATUS LED einbauen, um zu 
sehen ob gerade programmiert wird, oder ob der MC einwandfrei läuft oder 
eben Fehler.

Status-LED:
-> grün = ok
-> yellow = programmieren
-> rot = Fehler

Nun habe ich dass problem, wie ich den Schaltplan abändern muß, um diese 
LED zu verwirklichen.

Kann jemand helfen?

Martin

Autor: A. Arndt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mach es Dir nicht so kompliziert, schnapp Dir ne LED low current und 
dann einfach an Reset und WICHTIG an die Plus-Leitung, natürlich mit 
Vorwiderstand bei 5V 1,5kOhm, dann leuchtet die LED beim Programmieren, 
Fehler werden auf dem Bildschirm angezeigt.

Gruss
A. Arndt

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok Arndt,

ich könnte es so machen, aber ich würde gerne diese STATUS LED komplett 
verwirklichen.

Noch etwas. Bei 4MHz, wie groß muß ich die 2 Kondensatoren 
dimensionieren?

Autor: A. Arndt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

schau mal nach unter www.AR-Online.de, da habe ich den Grundaufbau mal 
erläutert.

Gruss
A. Arndt

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also noch mal zu diesem von Atmel-ISP Programmer(Link ist weiter oben).

Kann es sein, das der Kondensator (C100) im Schaltplan falsch gepolt 
ist, denn meiner ansicht nach würde so ein Kurzschluß entsteht.

Kann sich jemand dies bitte anschauen und mir sagen wie es aussieht.


Martin

Autor: Günter König (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tach Martin,

ist richtig rum. Spannungspegel bei RS232 = +U , -U und GND.


Gruß,

Günter

Autor: Armin Kniesel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der ist schon richtigrum drin. Da kommen ja auch negative Signale von 
der Schnittstelle.

Armin.

(Die Schaltung tut)

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok  vielen Dank,

Mal schauen ob ich irgendwie noch diese STATUS LED eingebunden bekomme.

Bin über alle Tipps froh.

MfG Martin

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.