www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik GPS?TIM-LP von uBlox?


Autor: Benz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!
hab bitte eine Frage und Zwar:
hab ein Board mit einem gps Emfänger von uBlox, sein Port 1 ist mit der
Serielle Schnittstelle angeschlossen.
Hab eine kleine Applikation in C unter Linux geschrieben, in dem ich
auf die serielle schnittstelle zugreife und einstelle nach Datasheet
von TIM_LP 9600 Baud, 8bits, noparity bit, 1stop bit und bekomme die
ganze Zeit das hier??
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,0,99.99,,,,,,*78
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,00*79
$GPGLL,,,,,,V,N*64
$GPZDA,,,,,00,00*48
$GPRMC,,V,,,,,,,,,,N*53
$GPVTG,,,,,,,,,N*30
$GPGGA,,,,,,0,0,99.99,,,,,,*¾ÿ,¾ÿS
meine Frage an euch, warum bekomme ich keine gültige Daten? heisst das,
dass es an meinem Code liegt oder an der Hardware Konfiguration?
Hat schon mal jemand die Erfahrung erlebt?
Für jede Info oder Hilfe wäre ich sehr dankbar.

Gruß

Benz

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
brauchst Du alle Messages?

Die letzten grumples:
<<$GPGGA,,,,,,0,0,99.99,,,,,,*¾ÿ,¾ÿS>>
lassen auf einen übergelaufenen Puffer schliessen, oder sowas.
Du hast schlicht keinen Empfang. Antene drann und mit Strom versorgt?
Ich würde mir die GGA und die RMC ausgeben lassen. Das reicht idR aus.
Geht mit $UBX irgentwas. Könnte im Datenblatt stehen. Habe ich jetzt
nicht im Kopf, leider.

Schreib mal etwas mehr zu aufbau, Stromversorgung usw.

Autor: Benz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo und danke für die schnelle Antwort!

Nein, brauche eigentlich nur RMC Message davon.
Wenn ich aber so eine Ausgabe bekomme, heisst das, dass mein Hardware
richtig Konfiguriert oder nicht? wenn nicht wo kommen diese Datensätze
Überhaupt hier?
das mit der Antenne habe ich, ist auch angeschlossen und am Fenster???

Zur Stromversorgung habe ich leider keine schaltpläne dabei aber ich
schicke es noch.

Danke

MfG
Benz

Autor: Axel R. (axelr) Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Um näheres schreiben zu können, bräuchte ich die Unterlagen zum Board.
Evtl ist V_ant nicht angeschlossen (Wird idR. mit V_rf über 10Ohm
verbunden).
Der Code hat nichts mit dem Empfang zu tun. Das sollte auch mit jedem
Terminalprogramm funktionieren.

Gruß
AxelR.

Autor: Benz (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo AxelR,

anbei ist wie der TIM-LP implementiert, im Anhang!
hoffe ist liesbar!

Vielen Dank im Voraus.

Gruß
Benz

Autor: AxelR. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, die kleine schrift ist KAUM lesbar, egal...

Was hast Du für eine Antenne?
Wie ist X10 gesteckt?
Ist F1 in Ordnung?
Ist die Betriebsspannung sauber (Rauschen, prasseln etc?)
Ist BT1 voll?

Nur RMC? Schick dem GPS folgendes:
$PUBX,40,RMC,0,1,0,0*46 [Enter] 0D0A?<- oder wars 0A0D, verwechsle ich
immer.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.