www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mega 32 nur Probleme


Autor: Timmey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo
also ich programmieren schon ne ganze weile mit atmel avrs und habe
bisher keine probleme gehabt. Bisher hab ich den mega8 und tiny 26
programmierte und beide laufen ohne Probleme. Jetzt versuch ich gerade
zum zweiten mal eine mega 32 in Betrieb zu nehmen und es gibt nur
Probleme. Das Board auf dem der chip sitzt ist fehlerfrei und der mega
32 läst sich auch problemlos programmieren. Die Software (z.B.
blinkende LED) funktioniert auch anfangs sehr gut und nach einer weile
blinkt auf einmal nix mehr. auch neu programmieren hilft nicht. Wenn
ich den Mega nun für 2-3 Stunden aus lasse und dann wieder einschalte
gehts es wieder paar Minuten. Woran liegt das? Bei den Mega 8
Controllern hatte ich noch nie solche Probleme. Gibts es bei mega 32
was besonderes zu beachten? Der Chip wird aber auch nicht heiß und mega
8 chips laufen in der Schaltung optimal. Bin langsam am verzweifeln.
Danke im Vorraus

Autor: Sascha Pypke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
schau mal am reset Pin oder an den Pins der ISP ob der richtig mit
einem Pullup oder Pulldown abgeschlossen ist.
Bei mir war sogar durch ESD der ganze Chip gelöscht.

Autor: Timmey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Resetpin ist über einen 10K Wiederstand an 5 Volt

Autor: Sascha Pypke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und der Oszilator leuft der noch ?
Ist meist sehr schwierig zu messen !!

Autor: Timmey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab nen 7,372 MHZ Quarz über zwei 22pf Kondensatoren dran. Bin
Hobbybastler und hab leider keine Chanze das großartig zu messen. Ich
denk schon das der noch läuft. Könnte maximal probieren obs mit
internen Takt auch so ist. Das ist schon der zweite Mega 32 und langsam
macht mich das fertig warum das jedes mal nicht geht. Programmieren
lässte er sich trotzdem immer.

Autor: Sascha Pypke (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das kann ich gut verstehen, bin manchmal auch schon fast wahnsinnig
geworden.
Den Quarz bei deiner Frequenz könntest du auch mit einem
Kurzwellenempfänger nachweisen ob er noch schwingt.
Bei einer Oszi Tastspitze hören die meisten eh schon auf zu schwingen.
Schau mal auf die anderen Pins ob da was passiert ?
Einen NMI hat der Controller ja eh nicht !

Autor: Timmey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab auch schon bischen mit den Fusebits rumgespielt aber ist nicht
besser geworden. In Ponyprog haken bei BOOTSZ1, BOOTSZ0, BODEN.
Das komische ist ja auch je länger ich ihn ausgeschaltet lasse desto
länger geht er dann mal kurz. Sehr seltsam. Dachte nicht das solche
modernen Controller noch so empfindlich sind. Hab auch schon
verschiedene Quarze ausprobiert aber erfolglos.

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es liegt auf jeden Fall an dir oder deiner Hard/Software. Ich verbaue
die zu 1000en, da gibts keine Probleme.

Autor: Riley (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zu 1000en? Welche Firma bist Du denn?

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum? Denkst du das ist viel? Damit ist man zwar kein ganz kleiner mehr
, aber immer noch ein kleiner. Pro Quartal werden ca. 1000 verbaut, im
Jahr sind das 4-5000.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.