www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Reset durch Spannungsspitze


Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich habe mir ein Belichtungsgeraet gebaut. Die Belichtungszeit wird 
mittels 3x 7 Segment Einheiten und Avr dargestellt und eingestellt. Mein 
2213 hat noch 40 Byte frei darum war ich froh alles in den µC zurkiegen.
Leider wird mein Controller geresetet, wenn der µC die Leuchstoffroehren 
startet. Ich kann leider nur vermuten das eine Spannungsspitze vom 
mehreren kV im Einschaltmoment entsteht und es ueber den An7805 im 
Netzteil auf meinem Mikrocontroller kommt. Ich habe versucht es durch 
einen 100 nF Kondensator der zwischen +VCC und Ground liegt, leider ohne 
Erfolg. Ich habe schon ein paar Projekte mittels Googgle gefunden, aber 
leider gibt es keine Information zu diesem Problem.

Ich weiss fuer eine Simple Belichtungszeit Anzeige  + Timer haette ein 
Ne555 schon gereicht. Ich wollte aber lieber einen feinen AVR nehmen.


Hat jemand von euch eine Idee was ich machen kann ? oder muss ich mir 
doch ein Vorschaltentstoerer von Conrad kaufen?


Mfg

Dirk

Autor: Jangomat (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie steuerst Du Deine Röhre vom Controller aus an?

Autor: Carsten Sprung (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit was treibst du die Röhren an ?

Gruss Carsten

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich hab es versucht ueber Triacs (von Sharp) und ueber Relais.

Bei beidem tritt leider der Fehler auf :/

Autor: HGSTaBRF (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hast du netzfilter verbaut???

sollte eigentlich mit netzfilter keine probleme bereiten...sonnst 
probier mal mit einem optotriac das ganze zu entkoppeln

73 HG

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ein Netzfilter habe ich leider noch nicht gebaut. Ich hatte gehofft das 
der An7805 zur Gleichspannungsfilterung reicht. Kann mir jemand dann 
Ideen fuer ein Netzfilter geben ? Ich hatte schon versucht ein 12 V 
Schaltnetzteil fuer den Mikrocontroller zunehmen: Das war leider keine 
gute Idee, weil die Leuchstoffroehren ueber die 230 V Leitung das 12 
Volt Schaltnetzteil gestoert hat und das Netzteil dann nicht mir mit 
einer Frequenz von 83kHz lief sondern kurzzeitig mit 200 kHz. Das mochte 
mein 2213 ueberhaupt nicht :/

Ich werde mal ein Optotriac fuer 4 A suchen. Falls jemand sonst noch was 
hat bitte immer her damit....


Mfg Dirk

Autor: Carsten Sprung (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

also ich schalte meinen Belichter mit einem normalen Relais. Aber was 
ich eigentlich meinte mit :

"Mit was treibst du die Röhren an ?"

ist. Nutzt du die klassische Methode mit Drossel und Bimetallstarter 
oder elektronisch wie in den Energiesparlampen. Ich mach letzteres und 
habe damit keine Probleme.

Grüsse

Autor: crazy horse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@dirk
Has du den reset-Eingang des 2313 beschaltet? Ein offener Pin ist sehr 
empfänglich für Störungen. 2k2 gegn Vcc.

Autor: Torben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe natuerlich die klassische Methode zusammengebaut. Hm jetzt muss ich 
ganz ehrlich zugeben. Ich weiss nicht wie eine Energiesparlampe 
elektronisch geschaltet wird. Ich werd mal googlen. Ich hoffe ich finde 
was oder vielleicht ist jemand so net und sagt es mir.

@Crazy horse

Ja ein Pullup Widerstand habe ich eingebaut.

Mfg Dirk

Autor: Carsten Sprung (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Torben

ich habe einfach die Elektronik aus einer Energiesparlampe ausgebaut und 
dann an die UV Röhe angeschlossen. Eine sehr platzsparende Lösung. Das 
sieht dann ungefähr so aus:
http://www.thelastinstance.de/images/p01_elektroni...

Der Startvorgang bei der normalen Leuchstoffröhrenansteuerung ist für 
den µC u.U. etwas stressig. Da ja in der Drossel teilweise mehrmals ein 
Magnetfeld aufgebaut wird und zusammenbricht. Die Störungen aus dem 
Bimetallschalter streuen da auch rein. Wenn das ganze dann noch dicht 
beieinander sitzt.....

Viel Erfolg :-)
Carsten

Autor: Dieter Götz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Dirk,

um Spannungsspitzen von der Röhre vom Netzteil des AVR weg zu bekommen, 
schalte doch einfach eine Transildiode zu dem 100nF Kondensator parallel 
(zwischen Vcc und 0V).
Um eine Störung der Reset-Leitung zu verhindern, hilft ein RC-Glied 
dicht am Reset-Eingang des AVR. Das geht aber nur, falls Du einen 
externe Spannungsüberachung hast. Schalte einfach 600R in die 
Resetleitung und zwischen Widerstand und Reset-Eingang einen 10nF 
Kondensator.

Autor: Dirk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke fuer die Info`s. Ich habe mir heute morgen Optokoppler Triacs mit 
Nulldurchgangpruefung bestellt. Falls es dann immer noch nicht geht 
versuche ich eure beiden Sachen. Ich bedanke mich trotzdem erstmal .

Mfg Dirk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.