www.mikrocontroller.net

Forum: www.mikrocontroller.net Umlaute im Wiki kaputt


Autor: Burkart Lingner (burkart) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Hat hier jemand eine Erklärung für die vielen kaputten Umlaute im 
Wiki/Artikelsammlung? Betroffen sind anscheinend sz und großgeschriebene 
Umlaute, kleingeschriebene jedoch nicht. Anstelle der gewollten Zeichen 
zeigt mir Firefox zwei Fragezeichen an und der Internet Explorer 
irgendein seltsames Zeichen. Wie mir scheint, tritt der Fehler in allen 
Artikeln auf, daß es an einem einzigen Editierer liegt, scheint also 
unwahrscheinlich. Andererseits konnte ich die kaputten Umlaute im 
Artikel NanoVM erfolgreich ausbessern, sodaß auf den ersten Blick auch 
die Wiki-Software unschuldig zu sein scheint. Seltsam.

Bye, Burkart

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hat etwas mit dem heute stattgefundenen Serverwechsel zu tun, bei 
dem Import der Wiki-Daten sind anscheinend ein paar Umlaute verloren 
gegangen. Ich bitte darum die fehlerhaften Umlaute zu korrigieren wenn 
ihr auf sie stoßt, das Ganze noch einmal neu zu machen wäre eine Menge 
Aufwand.

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist das Forum wegen dem Serverwechsel auch so fix. Echt atemberaubend!

Autor: Profi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch, wenn ich im IE  Ansicht | Quelltext  ansehe, sind die Umlaute 
als normale WIN-ANSIs lesbar, also keine html-Codierung ( ä ...).
Liegt also am  charset=utf-8  oder einem .css.

    <link rel="stylesheet" type="text/css" media="screen" 
href*="/stylesheets/screen.css" />
    <link rel="stylesheet" type="text/css" media="screen" 
href*="/wikisoftware/skins/common/common.css" />
     <link rel="stylesheet" type="text/css" media="print" 
href*="/stylesheets/print.css" />
    <style type="text/css">#nav-foren-sub {display: none;} </style>
    <style type="text/css">#nav-tutorial-sub {display: none;} </style>

Andreas, könntest Du bitte nochmal da nachsehen?

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das passt schon, die Texte sind als UTF-8 in der Datenbank und werden 
als UTF-8 ausgegeben. Allerdings scheinen beim Import der Daten in die 
neue Datenbank ein paar Umlaute kaputtgegangen zu sein. Wo genau der 
Fehler lag ist schwierig herauszufinden, und im Nachhinein eigentlich 
auch egal.

Autor: hennin g. (henning)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein grosser teil scheint behoben zu sein (per script?) was noch fehlt 
sind "ß" eigentlich generell als ?? zu erkennen, wenn das nicht so im 
text verwendet wurde.

Autor: D. W. (dave) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier musst du selbst ran Andreas:
http://www.mikrocontroller.net/articles/Hauptseite
-> Umbau Schweißtrafo

Autor: D. W. (dave) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
-> Erledigt

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab eine einfachere Möglichkeit gefunden als alles von Hand zu ändern:
1) "Bearbeiten" anklicken
2) Zeichensatz auf ISO-8859-1 umstellen (Firefox: Menü Ansicht -> 
Zeichenkodierung)
3) Text in Zwischenablage kopieren
4) Zeichensatz auf UTF-8 zurückstellen
5) Text wieder einfügen

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geht auch gut im IE. Die beiden Einstellungen dort sind

Ansicht -> Codierung -> Westeuropäisch (ISO)
Ansicht -> Codierung -> Unicode (UTF-8)

Autor: Stefan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider geht es nicht immer. Watchdog ist so ein problematischer Artikel, 
bei dem es so nicht geht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.