www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik USB - Hub versorgt PC mit Strom ?!?


Autor: Black Friday (black_friday)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
gestern habe ich mir einen aktiven USB - Hub gekauft. Das Teil 
funktioniert soweit ganz gut, allerdings ist mir beim ausschalten des 
PCs aufgefallen, das die "Num" LED am Keyboard noch leuchtete. Nachdem 
ich das Netzteil des Hubs aus der Steckdose gezogen hatte, ging auch die 
LED aus.
Anscheinend ist bei dem Hub das externe Netzteil direkt an die USB - 
Versorgung angeschlossen, wodurch bei ausgeschaltetem PC immer noch 
Strom auf den USB - Geräten ist.
Ist so etwas eigentlich zulässig?
Ich werde auf jeden Fall die +5V Leitung des USB - Anschlusssteckers 
auftrennen, um nicht meinen PC zu killen.

Autor: Hugo Bossard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Etwas ähliches habe ich auch schon erlebt: Der aktive USB-Hub bewirkte, 
dass beim ausgeschalteten PC (Soft-Off) die Power-LED leuchtete. 
Schlimmer noch: Der PC liess sich erst wieder starten, nachdem der 
USB-Hub abgetrennt worden ist (bzw. sein Netzteil).
Seither benütze ich den besagten Hub nur noch ohne Netzteil...

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geb den Schrott zurück, dann hast du die wenigsten Probleme mit.

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte das Problem mit der Num-Led auch schon. Allerdings nur, wenn 
ich meinen Rechner mit Linux startete und davon heruntergefahren habe. 
Mit Windows ging alles Problemlos.
Übrigends hatte ich keinen aktiven USB-Hub angeschlossen.

Ich denke, dass beim Herunterfahren des PCs an die angeschlossenen 
Geräte ein Signal zum ausschalten geschickt wird, und der USB-Hub, aus 
welchem Grund auch immer, dies verhindert.
Auf den USB-Anschlüssen befindet sich nämlich auch ohne UBS-Hub eine 
Spannung (ich lade damit immer mein Handy, auch bei ausgeschaltetem PC).
Allerdings kann man dies meines Wissens im Bios auch deaktivieren. 
Zumindest mein ich so einen Menüeintrag schonmal gesehen zu haben.

Autor: Black Friday (black_friday)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir mal die Platine des Hubs angesehen: Das Netzteil ist direkt 
mit V+ von USB verbunden. Da ich den Hub eh nur aktiv betreiben will, 
habe ich V+ einfach durchgeknipst. Den Hub brauche ich hauptsächlich 
dazu, meinen PC zu schützen, wenn ich selbstgebaute USB - Aplikationen 
ausprobiere.
Btw.: Es ist schon erstaunlich, wie es die Chinesen immer wieder 
fertigbringen, SMD - Bauteile mit unmengen von Anschlüssen auf einer 
einlagigen Hartpapierplatine unterzubringen. Ob der Hub bei diesem 
Aufbau wirklich die USB 2.0 Datenraten problemlos unterstützt, wage ich 
zu bezweifeln.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.