www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem mit ARM9 und USB


Autor: Günther Schmidt (guenther)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

ich habe dieses Linux-Board: 
http://www.conitec.net/english/linuxboard.htm. Um das zu programmieren 
habe ich in meinem WindowsXP eine Virtuelle Maschine mit Ubuntu 6.10 
eingerichtet. Die Pakete usw funktionieren auch.

Eigentlich sollte per USB die ganze Sache programmiert werden. Das 
Problem ist aber, dass schon Windows keinen USB-Treiber findet, ergo den 
ganzen USB-Kram nicht an die Virtuelle Maschine weitergibt.

Laut Tutorial www.lite-c.net/arm_eva/tutorial.pdf wird ein USB-DFU 
Protokoll und das LDBA-Protokoll eingesetzt.

Beide Protokolle sagen mir gar nichts. Hat jemand von euch Erfahrung 
damit? Wie bekomme ich die Bude denn programmiert?

Vielen Dank,

Günther

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest auf die virtuelle Maschine verzichten und Ubuntu "nativ" 
laufen lassen; zwar ist in virtuellen Maschinen das Verwenden von 
USB-Schnittstellen prinzipiell möglich, aber mit doch etlichen Haken 
verbunden.

Du solltest gerade bei solchen Aufgaben die Anzahl der möglichen 
Fehlerquellen reduzieren - also: Ubuntu direkt auf Deinem Rechner laufen 
lassen. Schaff Dir dafür eine zweite Festplatte an (kosten nicht mehr 
die Welt), verwende Wechselrahmen/Schubladen, dann hast Du eine saubere 
Trennung zwischen XP und Linux ...

Autor: Günther Schmidt (guenther)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, ich weiß, dass das sicher einfacher wäre, aber ich habe nur diesen 
einen Rechner und brauche Windows nebenbei auch. Und ein aufwändiges 
hoch- und runterfahren wollte ich wirklich vermeiden.

Es muss doch ne Möglichkeit geben. Was sind denn das für Protokolle? 
Laut Tutorial klingt es, als wären das Standardsachen. Für 
Standardsachen gibt es doch meist einen generischen Treiber.

Danke trotzdem für deine Hilfe.

Günther

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nun, Windows sollte überhaupt keinen Treiber für Dein Gerät brauchen, da 
das bei laufender VM an diese weitergereicht wird. Was für eine Software 
verwendest Du denn für Deine virtuelle Maschine? VMware, Virtual PC oder 
Parallels Desktop? Die unterscheiden sich deutlich in der 
USB-Unterstützung; bei VMware habe ich bei anderen Experimenten am 
meisten Erfolg gehabt.

Autor: Günther Schmidt (guenther)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus T. Firefly wrote:
> Nun, Windows sollte überhaupt keinen Treiber für Dein Gerät brauchen, da
> das bei laufender VM an diese weitergereicht wird.

Hm, das kann ich so nicht bestätigen. Wenn ich mich in der VM befinde, 
dann kommt trotzdem diese Windowsmeldung.

> Was für eine Software
> verwendest Du denn für Deine virtuelle Maschine? VMware, Virtual PC oder
> Parallels Desktop? Die unterscheiden sich deutlich in der
> USB-Unterstützung; bei VMware habe ich bei anderen Experimenten am
> meisten Erfolg gehabt.

Ja, es ist ne VMware. Benutze den kostenlosen Player, die VM habe ich 
mit dem kostenlosen VMXbuilder erstellt.

Hm!

Günther

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Hm, das kann ich so nicht bestätigen. Wenn ich mich in der VM befinde,
> dann kommt trotzdem diese Windowsmeldung.


Dann solltest Du Deine VM so konfigurieren, daß sie angeschlossene 
USB-Geräte übernimmt. Die Meldung von Windows kannst Du getrost 
ignorieren.

Wenn ich mich recht entsinne, musst Du nur bei laufender VM und 
angeschlossenem USB-Gerät VMWare mitteilen, daß das angeschlossene 
USB-Gerät an die VM "durchgereicht" werden soll.

Wobei das laut Dokumentation von VMware 5.5 automatisch geschehen 
müsste, wenn das VMware-Fenster das aktive Fenster ist:

  Autoconnecting USB Devices
  When a virtual machine is running, its window is the active
  window and a USB device is plugged into the host computer,
  the device automatically connects to the guest instead of
  the host. This autoconnect feature can be disabled in the
  USB Controller panel of the virtual machine settings editor
  (VM > Settings). If all of the virtual machine’s USB ports
  are already occupied when it is trying to connect automatically
  to a new device, a dialog box gives you a choice: you can
  either disconnect one of the existing USB devices to free its
  port or ignore the new device, allowing the device to
  connect to the host.

Wenn das nicht automatisch geschieht:

  Connecting USB Devices Manually
  Choose VM > Removable Devices to connect specific USB devices
  to your virtual machine. You can connect up to two USB devices
  at a time. If the physical USB devices are connected to the
  host computer through a hub, the virtual machine sees only the
  USB devices, not the hub.
  There is a menu item for each of the USB ports. Move the
  mouse over one of these items to see a cascading menu of devices
  that are plugged into your host computer and available for use.
  To connect a device to the virtual machine, click its name.
  If a device is already connected to that port, click the name
  of a new device to release the first device and connect the
  new one. To release a connected device, click None on the
  cascading menu for the port to which it is connected.

  If you physically plug a new device into the host computer
  and the autoconnect feature does not connect it to a virtual
  machine, the device is initially connected to the host.
  Its name is also added to the VM > Removable Devices menu so
  you can connect it to the virtual machine manually.

Das sollte das Problem eigentlich lösen.

Autor: Günther Schmidt (guenther)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke nochmal,

Also ich habe beim konfigurieren der VM gesagt, "automatically connect 
devices when guest has focus". Windows meldet mir im Minutentakt "Das 
Gerät "unbekanntes Gerät" kann jetzt entfernt werden".

Eine Einstellung im Player gibt es nicht. Da ist nur ein Knopf "Atmel 
USB-Device", der ist aber nicht gedrückt. Wenn ich ihn drücke, kommt 
wieder die Windowsmeldung und der Knopf wieder raus.

Komisch.

Ich habe zur Sicherheit das alles mal mit der mitgelieferten 
Knoppix-Live-CD probiert. Wenn ich damit richtig boote, ist alles kein 
Problem. Wenn ich das in der VM wiederhole geh es nicht, wie vorhin im 
Ubuntu. Liegt also definitiv an der USB-Verbindung bei der VM.

Noch jemand einen klugen Tipp oder ne andere Idee?

Günther

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mal mit 'nem "richtigen" VMware probiert? Vielleicht ist das ja eine 
Einschränkung oder gar ein Fehler des VMware Players.

Das Verhalten lässt darauf schließen, daß das Gerät zwar der VM 
übergeben wird, die aber nichts damit anfängt und das Gerät daher wieder 
ans Wirts-OS zurückfällt.

Autor: Günther Schmidt (guenther)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
??? "richtiges" VMware? Soweit ich das sehe, ist nur der VMplayer 
kostenfrei. Ich kann natürlich die Workstation 30 Tage lang probieren, 
aber dann stehe ich in 30 Tagen vor dem gleichen Problem. Oder gibt es 
da auch kostenlose Derivate davon?

Günther

[edit] Können denn Player und Workstation nebeneinander installiert sein 
oder schließt sich das aus?

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicht nur der Player, sondern auch dessen ganz großer Bruder, der VMware 
Server ist kostenfrei. Und der lässt sich auch unter Windows XP 
installieren, auch wenn der Name erst mal anderes suggeriert.

http://www.vmware.com/products/server/

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.