www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Mit mysmartusb in AVRStudio Fuse setzen


Autor: Tom66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich bin gerade dabei mich in die AVR-thematik einzuarbeiten.
Nun versuche ich mit Hilfe von Avrstudio und mysmartusb die Fuse-bits 
für einen atmega32 und 16Mhz Quarz (Projekt Webserver) zu setzen, komme 
aber nicht wirklich damit klar. Soll heissen ich weis nicht so recht was 
ich wo einstellen soll. Datenblatt war auch keine Hilfe. Kann mir 
vielleicht bitte jemand weiterhelfen ?

Mit freundlichen Grüßen Tom

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Datenblatt war auch keine Hilfe.

Das glaube ich nicht. Da steht alles exakt drin.

...

Autor: Tom66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja steht drin, nur entspricht nicht den Eingabemöglichkeiten 
AVRstudio/Mysmartusb. Also bitte erst die Anfrage lesen.
Sorry, aber nichtssagende Antworten habe ich selber, da brauch ich nicht 
fragen. Hatte geschrieben das ich Anfänger bin und möchte an der Stelle 
nichts falsch machen.

Danke Tom

Autor: Jonas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du mal versucht die Fusebits mit dem myAVR-Workpad zu setzen? Ich 
habe auch einen mySmartUSB und arbeite mit dem Workpad-plus um die 
Fusebits zu setzen. Das ist angenehmer als mit dem AVRProg im 
AVR-Studio. Ansonsten musst du schon genau sagen ob du nicht weißt wie 
du an die Einstellungen der Fusebits kommst 
(AVR-Studio->Tools->AVRProg->Advanved) oder ob du eine bestimmte 
Einstellung machen willst. Dann solltest du schreiben welche. Ich kenne 
das Projekt Webserver nicht und weiß nicht was du genau einstellen 
willst.

Gruß Jonas

Autor: Tom66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Jonas für Deine Antwort.
Also wie ich an die Fuse-Bits komme weis ich. Ich kann die aktuellen 
Einstellungen auch auslesen. Mir gehts es jetzt darum einzustellen das 
der atmega32 einem externen Quarz mit 16Mhz verwendet. Und hier 
verwirren mich die Einstellmöglichkeiten bei 
"AVR-Studio->Tools->AVRProg->Advanved".
Ich werde mal myavr-Workpad versuchen.

Gruß Tom

Autor: _BT_ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nun lass auch mal höhren ob es jetzt mit dem workpad besser geht!

cu BT

Autor: Tom66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich melde mich wen ich soweit bin. Bin z.Zt. "außerhalb"
( kann mich damit nur am WE beschäftigen)
Gruß Tom

Autor: Tom66 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bin endlich dazugekommen weiterzumachen.
Mit Workpad hat es leider nicht funktioniert. Es wurde zwar der Atmega32 
und auch der Programmer erkannt, aber beim Auslesen der Fusebits kam 
immer eine Fehlermeldung "Keine konfiguratioseinstellungen gefunden. ( 
Bei meheren AVR ).

Habe es aber mittlerweile mit AVRStudio zum laufen bekommen.
Mit diesen Einstellungen geht es : "ExtXTAL,Startup: 30u + 1K CK"
Habe jetzt aber ein anderes Problem : InitError 195 ??
Ich suche mal weiter.

Grüße Tom

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.