www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Batron BT 42008V1SP-04 4x20 Display


Autor: Tomek (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


Beschäftige mich schon seit Stunden mit dem Display aber ohne Erfolg 
langsam bin ich am verzweifeln.

Auf dem Aufkleber steht folgendes:
Batron
BT 42008V1SP-04
BT42008V1SS-YERE-06

Habe mich an das "AVR-Tutorial: LCD" gehalten aber auf dem Display ist 
nichts zu sehen.
Auch wenn ich nur die Versorgungsspannung anschliesse kommt einfach 
nichts aufs Display.

Bin mir auch nicht sicher ob das Datenblatt im Anhang das Richtige ist 
weil die Modelbezeichnung nicht ganz stimmt. Beim meinem Display gibt es 
auch noch zwei Anschlüsse auf der Seite die mit "V0" und "+5V" 
beschriftet sind die fehlen aber im Datenblatt.

Wenn ich das Datenblatt Richtig verstehe dann müsste die V0 Spannung am 
Pin3 negativ sein ca. -2.7V. Kann das stimmen?

MFG
Tomek

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

die Anschlüsse auf der Seite sind vermutlich Hintergrundbeleuchtung, 
also erstmal ohne Bedeutung.

Die Spannung am Pin 3 bestimmt den Kontrast.
Es gibt normale Displays mit Spannung am Pin 3 gegen GND zwischen 0 und 
ca. 2V und Displays mit erweitertem Temperaturbereich, da liegt diese 
Spannung meist zwischen 0 und -7V gegen GND.

Ich "leihe" mir die negative Spannung meist vom MAX232 aus, wenn der 
sowieso drauf ist. Einstellregler 50k zwischen GND und der negativen 
Spannung am MAX (hab den Pin gerade nicht im Kopf...), Schleifer an Pin 
3 Display. Dann sollte sich ein erkennbarer Kontrast einstellen lassen.

Wenn nur die Spannungen am Display anliegen läßt sich mit dem Regler der 
obere Balken gut schwarz einstellen, wenn die Spannung an Pin 3 stimmt.

Bei unbekannten Display halte ich es immer so, daß ich erstmal 0..+5V 
teste, wenn da nichts zu sehen ist, eben 0...-7V an Pin 3.

Das haben sich bisher auch alle Displays gefallen lassen.
Man braucht ja zum Test, ob der Einstellbereich stimmt, nur ein paar 
Sekunden.

Ist aber ohne Garantie, Original-Datenblatt ist die sichere Variante.

Gruß aus Berlin
Michael

Autor: Tomek (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Michael,
Vielen Vielen Dank für die schnele Antwort.

Es funktioniert jetzt :-)))

Der Tipp mit dem max232 war super. Habe vorher zwei Mignon zellen 
genommen ca. -3V aber das war zu wenig. Das Display hat jetzt erst bei 
-4V die beiden Zeilen angezeigt.

viele Grüsse
Tomek

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.