www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik µC Neuling Braucht Hilfe beim Tutorial


Autor: Heinz Rühmann (ben1418)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute,

ich hab mir mal die Schaltung vom Tutorial nachgebaut und habe ein 
Problem.
Ich hab die Schaltung wie beschrieben aufgebaut. Dann hab ich den 
ISP-Programmer mit dran gesteckt und wenn ich dann die 5 Volt anschließe 
passiert nix.

Ich hab dann einfach mal mit dem Multi-Meter geschaut ob überhaupt 5 
Volt dran sind und siehe da....es sind so bald ich die Spannung 
anschließe nur noch um die 0,1 Volt da. Ich vermute mal da die Kabel 
nach ein paar sekunden recht warm wurden dass da ein recht hoher Strom 
fließt.

Irgendwo is der wurm drin!!!

Die Kondensatoren sind OK.

Verkabelt hab ich mich denke ich auch nich....Ich habs schon mehrmals 
neu aufgebaut.

Ich hab auch den Atmega8 ausgewechselt aber da tut sich auch nichts.

Ich weis einfach nicht warum die Spannung zusammen bricht.

Ich hoffe ihr habt irgendeine Idee.

mfg
Ben1418

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Irgendwo is der wurm drin!!!

Ja nun - Kurzschluß! Ich denke, der echte Heinz Rühmann wäre da von 
selbst drauf gekomen.

Tip: Foto von Deinem Kram machen, hier reinstellen!

Autor: Heinz Rühmann (ben1418)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir ist gerade aufgefallen das in der Schaltung beim Tutorial der 
20.Anschluss an der 5V Spannungsquelle angeschlossen ist. Bei dem 
darunter liegenden Foto ist der 20.Pin gar nicht beschalten.

Ist dies den des Rätsels Lösung?

Autor: Heinz Rühmann (ben1418)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann auf dem Photo auch nur einen Kondensator sehen statt zwei.

Autor: Karl heinz Buchegger (kbucheg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Heinz Rühmann wrote:
> Mir ist gerade aufgefallen das in der Schaltung beim Tutorial der
> 20.Anschluss an der 5V Spannungsquelle angeschlossen ist. Bei dem
> darunter liegenden Foto ist der 20.Pin gar nicht beschalten.
>
> Ist dies den des Rätsels Lösung?

Nein.
Der Prozessor auf dem Photo ist kein Mega8. (Es war woh
auf die schnelle kein anderes zur Hand).
Das Schaltbid stimmt aber für einen Mega8. Man muss tatsächlich
die Versorgungsspannung 2 mal anschliessen.

Kondensator: Auch das ist im Schaltbild richtig.
Der 100nF Kondensator hat die Aufgabe, kurze Spannungsspitzen
an der Versorgungsspannung auszugleichen. Der kleinere 47nF
Kondensator kann auch weggelassen werden.

Du hast aber ein anderes Problem. Bei den von dir genannten
Daten, hast du einen kräftigen Kurzschluss in deiner Schaltung.
Such nach Verbindungen, die du gesteckt hast, die aber laut
Schaltbild nicht vorhanden sein dürften.


Autor: Heinz Rühmann (ben1418)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar, ich hab jetzt endlich den Fehler gefunden. Es war ein 
Kurzschluss auf dem b-board.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na bidde - zweimal hingucken hilft.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.