www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Benchscope/Multiscope RS232 Kabel


Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich besitze ein Benchscope und ein Multiscope der Firma Wittig. Ich hab 
jedoch kein RS232 Kabel zur Verbindung mit dem PC.
Da die Geräte auch nicht mehr hergestellt werden, komme ich nicht mehr 
so leicht an solch ein Kabel ran.
Hat hier zufällig jemand sowas und kann mir die Belegung des RJ25 
Steckers schicken?
Das wäre mir eine große Hilfe!

Gruß,
Christoph

Autor: Unfuture (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Cristoph,

meinst Du jetzt das Verbindungskabel für Software-Updates (liegt
jedem Benchscope beim Kauf bei) oder das Verbindungskabel für die
PC-Software? Letzteres kann man meines Wissens nach immer noch
käuflich erwerben. Und ist das beim Benchscope nicht ein RJ12-Stecker?

LG,
Unfuture.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Unfuture,

erstmal herzlichen Dank für die Antwort!
Ich wußte bisher nicht, daß es 2 verschiedene Kabel gibt. Dachte, es 
wäre das Gleiche.
Aber eigentlich bin ich nur an dem Kabel für Software Updates 
interessiert. Dieses besitze ich leider nicht. Habe die Geräte gebraucht 
gekauft, jeweils ohne das Kabel.

Mir würde also schon die Belegung dieses Kabels reichen. Kann sein, daß 
es ein RJ12 ist. Es hat 6 Pins am Multiscope.

Viele Grüße,
Christoph

Autor: Unfuture (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Christoph,

es könnte gut sein, dass die Kabel intern die gleiche Belegung haben.
Das PC-Software-Kabel ist aber galvanisch vom Scope getrennt, von
daher dürfte das Ausmessen dieses Kabels etwas komplizierter werden...

Momentan bin ich leider nicht in der Nähe des Kables, aber gleich
nach Weihnachten kann ich Dir die Pinbelegung des Software-Update-
Kabels ausmessen und dann hier reinstellen, sofern nicht jemand
anderes hier ein solches besitzt und vor mir dazu kommt.

LG,
Unfuture.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Unfuture,

das wäre super!
Ich werd dann hin und wieder die nächsten Tage hier vorbeigucken.

Frohes Fest!

Viele Grüße,
Christoph

Autor: Unfuture (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Christoph,

hier ist die Pin-Belegung von meinem Kabel:

http://img226.imageshack.us/img226/3449/pinbelegun...

Jo, frohes Fest =)))

Viel Erfolg,
Unfuture.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Unfuture,

vielen Dank für die Mühe!
Leider läuft das Kabel noch nicht erfolgreich.
Ich kann zwar hin und wieder eine Verbindung herstellen, jedoch bricht 
sie nach kurzer Zeit wieder ab.
Ein Firmware Update ist auch nicht machbar. Es bricht auch nach kurzer 
Zeit ab.

Jetzt bin ich ratlos...

Bei Wittig antwortet auch niemand auf meine Mails. Auf Support von da 
kann ich wohl nicht mehr hoffen.

Autor: Unfuture (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Christoph,

schwer zu sagen woran es liegt. Werden denn sicher Daten bidirektional
übertragen und kommt der Abbruch dann mitten im Transfer oder bricht
er zu einem Zeitpunkt ab, zu dem du noch nicht sagen kannst ob die
Kommunikation bidirektional stattgefunden haben muss? Dazu könnte ein
Portmonitor hilfreich sein (www.sysinternals.com).
Es könnte auch am Kabel liegen (zu lang, schlecht gecrimpt, miese
Stecker) oder aber auch an der seriellen Schnittstelle in Deinem PC.
Zuletzt kann es natürlich auch am Benchscope liegen. Ich habe mit
einem Asrock-Mainboard ziemliche Probleme mit meinem Funktionsgenerator
gehabt - ständig Timeouts - und fahre meine ganzen Geräte schlussendlich
über diese Standard-USB-Seriell-Schnittstellen (Prolific-Chipsatz).
Damit habe ich keine Probleme mehr, obwohl man diesen Adaptern ja
eher nachsagt, dass sie zu Problemen führen können...

Ich habe das Kabel noch ein zweites Mal durchgemessen, also vermessen
habe ich mich bestimmt nicht, der RJ12-Stecker zeigt im Bild mit der
Nase nach unten, das sieht man eventuell etwas schlecht.

Autor: Christoph (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Unfuture,

Kabel/Stecker hatte ich auch im Verdacht. Aber die Verbindung, Belegung 
und die Leitungswiderstände waren alle in Ordnung.

Ich habe jetzt mal auf einem alten PC Windows 98 installiert. Damit geht 
die Übertragung etwas besser. Zwar hat es auch viele Versuche und 
Abbrüche gebraucht, aber irgendwann lief das Update dann ganz durch. 
Jetzt rühre ich nix mehr an! :)

Ich vermute, daß es irgendwie am Gerät oder an dem PC liegt. Vielleicht 
auch an Störungen, die aufs Kabel wirken. Das werd ich wohl nie 
rausfinden.
Aber Hauptsache, es hat geklappt!

Ich bedanken mich also sehr für Deine Mühe und wünsche Dir alles Gute 
für das kommende Jahr!

Viele Grüße,
Christoph



Autor: Unfuture (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles klar, freut mich das es doch noch geklappt hat.
Ich wünsche Dir ebenfalls einen "guten Rutsch"...

Unfuture.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.