www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Flashen nicht möglich


Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe Probleme mit meinem ersten Schaltungsaufbau. Habe den ISP 
Programmierer einmal nach diesem Vorschlag gebaut 
http://s-huehn.de/elektronik/avr-prog/avr-prog.htm und dann das ganze 
nochmals auf diese Weise: 
http://www.captain.at/electronics/atmel-programmer/

Jeweils ohne Erfolg. PonyProg meint immer, dass kein Gerät verfügbar 
wäre (E24).

Gibt es eine einfache Möglichkeit, dem ATmega zu irgendwie testen, ohne, 
dass ich eine Software draufgespielt habe? So eine Art primitiven 
Funktionstest.

Gruß,
   Michael

Autor: Frank (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese Einfachstadapter sind nicht unbedingt die erste Wahl wenns um 
zuverlässiges Programmieren geht.Schon ein moderner LPT-Port am PC kann 
die Ursache für Nichtfunktion sein. Ich würd einfach etwas mehr 
Bastelarbeit investieren und einen etwas besseren Programmieradapter 
bauen, dann klappt das auch (wenn man denn noch die passenden 
Schnittstellen am Rechner hat).

bye

Frank

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

wenn schon einfach, dann zumindest die Original-STK200-Dongle-Schaltung.

Auf der Ponyprog-Seite sind dazu 2 Schaltungen angegeben, die meiner 
Meinung nach beide so nicht gut sind.

http://www.lancos.com/prog.html

Die obere Schaltung haz zwar den 10pol. ISP-Anschluß in der 
Originalbelegung, den ich auch für günstig zum Basteln halte, weil 
zusätzliche GND-Leitungen zwischen den Datenleitungen liegen.

Die ganze 1k Schutzwiderstände versauen aber die Pegel in vielen Fällen 
bereits zu sehr.

Die untere Schaltung entspricht dem Original STK200, der ISP-Verbinder 
hat aber eine eigenartige Belegung.

Also die untere Schaltung nehmen und den 10pol. ISP-Anschluß wie in der 
oberen beschalten...

Wichtig: den Kram mit dem HC244 direkt in/an den Parallelport-Stecker 
bauen, keine Verlängerungen dort verwenden!

Als ISP Kabel ein Flachbandkabel nehmen, dort hatte ich mit 1m Länge 
noch nie Probleme, auch nicht an 16MHz getakteten Steckbrett-Aufbauten.

Die Varianten nur mit Widerständen sind selbst mir zu unzuverlässig, was 
nicht heißt, daß sie nicht auch funktionieren können.

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.