www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500+Atmega640 -> UART funktioniert nicht


Autor: MaPa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe das Beispiel von Peter Fleury 
(http://homepage.hispeed.ch/peterfleury/) für die UART Schnittstelle 
verwendet.

Folgende Dinge habe ich eingestellt:
Habe beim STK500 eine Brücke von den Pins "RS232 Spare" (RX und TX) zum 
Mikrocontroller Port E (PE0 und PE1) gemacht.

habe beim den Fusebits den internen Oszillator des Atmega640 auf 8Mhz 
gestellt, laut Datenblatt: CKSEL = 0010.

Die Jumper bei XTAL1 und OSCSEL entfernt.

Ich benütze das Hyperterminal zur Ein/Ausgabe mit den Einstellungen: 
9600Baud, 8Datenbits, 1 Stopbit, Parität: keine, Hardwareflusssteuerung: 
kein.

Wenn ich das Beispielprogramm auf den Mikrocontroller schreibe, und den 
PC mit RS232 Spare verbinde bekomme ich keine Signale vom 
Mikrocontroller, kann auch nichts senden!

Habe auch schon RX und TX vertauscht, hat leider nichts geholfen

Was mache ich falsch???

Gruß MaPa

Autor: johnny.m (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kommen an den Ausgängen überhaupt keine Signale raus? Ansonsten: Dass 
der interne RC-Oszillator der AVRs für asynchrone serielle Übertragung 
aufgrund seiner Ungenauigkeit und Temperaturdrift eigentlich ungeeignet 
ist, ist ein Thema, das hier im Forum schon oft genug durchgekaut 
wurde...

Autor: MaPa (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also an den ausgängen bekomm ich keine signale, habe auch schon versucht 
einen externen quarz anzuschließen, problem ist nur dass ich den 
Mikrocontroller danach nicht mehr programmieren kann.

Habe einen 6Mhz Quarz da, kann mir jemand die Fusebits und die 
Einstellungen für das STK500 sagen.

Vielleicht mache ich da was falsch.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.