www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik MOSFET: Kaum Stromfluss


Autor: Bartholomäus Steinmayr (sam_vdp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich bin gerade dabei meinen ersten Boostkonverter zu bauen und will 
dafür einen MOSFET verwenden. Ich habe heute einen 2SK1082 vom 
Schrottplatz geholt :)

Prinzipiell ist die Ansteuerung doch so: Source auf Masse, Gate auf 
einen Portpin und was man schalten will auf Drain, oder?
Es stellt sich mir folgendes Problem: Laut Datenblatt 
(http://www.ortodoxism.ro/datasheets/fuji/2SK1082-01.pdf) sollte sich 
der MOSFET bei 5V GS- und DS-Spannung schön im linearen Bereich befinden 
und der DS-Strom maximal etwa 2A sein.
Wenn ich mit einem Multimeter den DS-Widerstand messe, kommt das auch 
gut hin (3 Ohm), aber wenn ich tatsächlich den Transistor belaste, dann 
fließen gerade einmal 270mA, selbst bei einem "Kurzschluss".

Ist der MOSFET kaputt oder mache ich was falsch?

Besten Dank und vielen Grüße,
Bartl

Autor: roman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bartl,

hast du die "gate threshold voltage" gesehen ??
alles im datenblatt bezieht sich auf Vgs von 10V. Oder die schaltung vor 
dem Transistor kann nicht mehr liefern .. zb. Die spule zu klein 
dimensioniert bzw. der widerstand der spule ist zu gross.

man koennte mehr aus einem schema sagen :)

gruss
roman

Autor: Bartholomäus Steinmayr (sam_vdp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> hast du die "gate threshold voltage" gesehen ??
Schon, die ist in der zweiten Zeile der electrical characteristics mit 
2.5-5.0V angegeben und das erste Diagramm auf der zweiten Seite sagt 
wenn ich das richtig lese auch, dass bei 5V 2A fließen sollten.

> Die spule zu klein dimensioniert bzw. der widerstand der spule ist zu
> gross.
Wie gesagt, selbst wenn ich die Spule komplett weglasse und einfach ein 
Drain auf +5V lege fließen nur die 270mA. Recht viel mehr Schema ist da 
eigentlich nicht.

Beste Grüße,
Bartl

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei 5V Gate-Source solltest du ihm MINDESTENS 15V Drain-Source geben, 
siehe Kurve im Datenblatt. Das Teil scheint für 25V ausgelegt zu sein.

Autor: Bartholomäus Steinmayr (sam_vdp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bei 5V Gate-Source solltest du ihm MINDESTENS 15V Drain-Source geben
Für Sättigung schon, aber das gleiche Diagramm gibt doch auch das 
Verhalten davor an und da sollten doch bei 5V auch schon 2A drin sein.
Aber du hast wohl trotzdem recht, ich hab's gerade mit nem Netzteil 
getestet, bei jeweils 7V geht er schon ab wie Schmitz' Katze, aber das 
hilft mir mit dem Controller natürlich nicht so viel, muss ich mir wohl 
doch nen anderen suchen.

Trotzdem besten Dank nochmal und viele Grüße,
Bartl

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du mal ne Rakete sehen willst, guck mal den IRF 1404 an.
http://www.irf.com/product-info/datasheets/data/irf1404.pdf
Kostet auch nicht viel.
http://www.reichelt.de/?ARTICLE=41598

Soll keine Werbung sein, aber die Daten sind einfach unglaublich.

Gruss - Tom

Autor: ??? (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

welche Spannung willst Du denn schalten? Wenn Du 'nur' 5V auf z.B. 30V 
boosten willst, probier doch mal etwas wie einen irf7403 - sind 
schnucklich klein in SO8, können trotzdem noch gut Strom (5-8A) halten 
noch 30V aus und brauchen nur eine Vgs von min 1V.

>2.5-5.0V angegeben und das erste Diagramm auf der zweiten Seite sagt
>wenn ich das richtig lese auch, dass bei 5V 2A fließen sollten.
ja nach dem Diagramm sollten so ca. 2A fliessen - bei (gemessenen) 3R 
hättest Du dann aber einen Drop von 6V über dem FET -> Vds müsste auch 
entsprechend hoch sein, was wahrscheinlich nicht gilt. Ausserdem steht 
vorne noch Vgs = 2.5-5V @ Vgs=Vds -> entweder hast Du keine entsprechend 
hohe GateSource Spg. angelegt, oder Vds ist nicht hoch genug (bricht die 
vielleicht ein?) beides nicht: wahrscheinlich defekt.

Autor: Bartholomäus Steinmayr (sam_vdp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Tom: Der kann für meine Zwecke zu wenig DS-Spannung ab.

@???
> Wenn Du 'nur' 5V auf z.B. 30V boosten willst
Sollte schon lieber ein bisschen mehr sein, theoretisch soll das ganze 
mal ein Lader für eine Coilgun werden und da möchte ich halt nicht so 
Riesenkondensatoren verwenden müssen.

> entweder hast Du keine entsprechend hohe GateSource Spg. angelegt
Eigentlich schon, halt die 5V vom AtMega-Port

> oder Vds ist nicht hoch genug (bricht die vielleicht ein?)
Das hätte ich mal nachmessen müssen. Das ganze hängt an einem 
PC-Netzteil, sollte also eigentlich kein Problem sein, allerdings mit 
ziemlich langem Kabel, aber ich vermute trotzdem eher, dass er defekt 
war.

Ich hab jetzt noch einen IRF720 gefunden, der kann auch 400V und 
immerhin noch 1A iirc, das sollte fürs erste reichen.

Vielen Dank nochmal für die vielen Vorschläge und beste Grüße,
Bartl

Autor: Sonic (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uiui, Schaltnetzteil und Schaltvorgänge mit hohen Strömen?
Miss mal mit dem Oszi die Spannung, die vom Netzteil kommt, ich schätze 
mal das Teil regelt wie wild 'ruf und 'runter. Bei sowas biste mit 
Trafo, Gleichrichter und dickem Elko viel besser bedient!

Autor: Bartholomäus Steinmayr (sam_vdp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsächlich? Hm, das hab' ich nicht gewusst. Ein Oszi habe ich leider 
nicht, aber ich seh mal was ich an alternativen Energiequellen finden 
kann.

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also mein Test-Netzteil sieht so aus:
AC -> AT-PC-Netzteil(12V/5V) -> Sicherung (für 12/5V) -> kleine Platine 
mit dicken Kondensatoren und Spulen zum entstören -> Ausgänge

@  Sonic
Hatte schon mal ein normalen Travo, die Spannung von dem ist ja immer 
Last abhängig. Aber bei PC-Netzteilen sind große Ausgangskondensatoren 
Pflicht, denn die internen sind nur 2000µF groß.
Ich hab extern nochmal 5000µF jeweils für 5V und für 12V (reicht für je 
5A Last)

@  Bartholomäus Steinmayr
Ich steuere den Mosfet nicht direkt mit dem µC an sondern mit einem 
Treiber (NPN-Transistoren), den Collektor lege ich auf 12V. Dann habe 
ich (12V - 0,7V) an dem Gate zu liegen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.