www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATmega128, prog & verify-Lockbits bei Auslieferung gesetzt


Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat schon mal jemand von Euch das Problem gehabt, ATmega128 (oder andere 
Bausteine) neu geliefert bekommen zu haben, bei denen der Modus
"Further Programming and Verification disabled" gesetzt war?
Ich kann mit meinem AVRISP mkII jetzt nicht mehr viel machen, oder?

Autor: Falk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@sous

>Hat schon mal jemand von Euch das Problem gehabt, ATmega128 (oder andere
>Bausteine) neu geliefert bekommen zu haben, bei denen der Modus
>"Further Programming and Verification disabled" gesetzt war?
>Ich kann mit meinem AVRISP mkII jetzt nicht mehr viel machen, oder?

Einfach Chip erase machen, dann ist alles incl. der Lock Bits gelöscht.

MfG
Falk

Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>> Einfach Chip erase machen, dann ist alles incl. der Lock Bits gelöscht.

Das funktioniert bei mir leider nicht. Wenn ich "erase device" (übrigens 
von AVRStudio V4.13 aus) klicke, sagt er zwar 'OK', die Fusebits sind 
danach jedoch genauso gesetzt, wie zuvor.

Autor: Falk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@sous

>Das funktioniert bei mir leider nicht. Wenn ich "erase device" (übrigens
>von AVRStudio V4.13 aus) klicke, sagt er zwar 'OK', die Fusebits sind
>danach jedoch genauso gesetzt, wie zuvor.

Bitte Fuse Bits und Lock Bis auseinander halten! Erstere stellen diverse 
Takt/EEPROM/Wasweissich Optionen ein, letztere den Schreib/Leseschutz. 
Letztere sind harmlos, da man einen gesicherten IC immer noch löschen 
und wieder programiieren kann. Wenn die Fuses vermurkst sind hilft 
manchmal ne externe Taktquelle.

http://www.mikrocontroller.net/articles/AVR_Fuses

Ich hab es aber auch schon geschafft einen tiny2313 total abzuschiessen, 
indem ich "reserved" Werte in die Taktoptionen geschrieben habe :-(

MfG
Falk

Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Bitte Fuse Bits und Lock Bis auseinander halten!

OK, ich meinte nicht Fuse- sondern Lockbits. Diese sind leider bei mir 
nach dem Erase noch so wie vorher, d.h. der Modus "Further Programming 
and Verification disabled" ist eingestellt.

Autor: Falk (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@sous

>nach dem Erase noch so wie vorher, d.h. der Modus "Further Programming
>and Verification disabled" ist eingestellt.

Und den müsste man eigenlich mit Chip Erase löschen können.

MfG
Falk

Autor: sous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Seufz! Mein AVRISP mkII ist kaputt! Ich habe gerade einen Alten AVRISP 
vervorgeholt, ihn über COM1 an den PC angeschlossen und siehe da: alles 
geht!

Vielen Dank für Eure Hilfe!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.