www.mikrocontroller.net

Forum: PC Hard- und Software XP un xcopy


Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
wegen eines Hardwareschaden mußte ich von Win 2000 auf XP Home 
umsteigen.
unter Win 2000 nutzte ich " xcopy e:\*.* G:\Daten\ /d /e /y " für einen 
schnellen zugriff auf meine Datensicherung (Kopie erstellen von X nach Y 
" 1 zu 1 ")
Unter XP bricht xcopy laufend ab. Kann ich xcopy nicht mehr nutzen oder 
wird dieses anderst gemacht.
Gruß Siegfried

Autor: Knut (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tippe einfach mal "help xcopy" ein, da wird dir geholfen.

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

für d (Datum) alle jüngere Dateien
für e kopiert alle unterverzeichnisse ob leer onder nicht leer
für y unterdrückt eingabebestätigung wenn datei vorhanden

diese 3 Parameter haben immer gereicht
gruß siegfried

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich nutze xcopy auch schon seit Jahren unter den verschiedensten 
NT-Versionen, einen Unterschied zwischen W2K und XP konnte ich nicht 
feststellen.

"bricht ab" ist eine präzise Beschreibung. Gibt es eine Fehlermeldung 
bzw. was steht danach in %errorlevel%?

Alternative Kommandozeilenparameter kreisch + d, also

  xcopy quelle ziel /k /r /e /i /s /c /h /d

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
das " Dos-Fenster " wird ohne Anzeige von Fehlermeldungen geschlossen.
einige Dateien sind auch kopiert worden.
unter W2K funktioniert mein xcopy Befehl
werde mal deine Parameter nutzen.
gruß Siegfried

Autor: Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du kannst ja vorher ein cmd fenster öffnen und xcopy dann starten. dann 
siehst du auch die ausgaben ...

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo @Werner, @Rufos
habe im CMD Fenster eingegeben:
xcopy e:\*.* G:\Daten\ /k /r /e /i /s /c /h /d
jetzt sehe ich eine Fehlermeldung:  nicht genügend Arbeitsspeicher
hatte und w2k 512MB  und habe jetzt unt XP 1024MB
verflixte technik!!!
gruß siegfried

Nachtrag: sollte etwa eine *.pif angelegt werden ?

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hihi das dürfte ein Bug sein :D

Versuch mal die xcopy.exe vom Win2000 zu verwenden.

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
keinen Erfolg. von w2k will er überhaupt nicht.
gruß siegfried

Autor: StinkyWinky (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich mache mit

xcopy e:\*.* G:\Daten\ /s /v /c /i /f /h /k /y

gute Erfahrungen. Wird auch in BfF [1] aus gemacht.


[1] Backup für Faule, c't 11/99

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
ich verstehe mein Computer nicht mehr. Unter w2k habe ich bald 7 Jahre 
den xcopy ohne murren genutzt. Habe mich immer gestreupt, XP zu nutzen. 
Nun habe ich die bescherung.
Alle Infos aus dem Forum und auch meine habe ich durchprobiert. Es 
werden n Dateien kopiert und bricht dann mit der Meldung "nicht genügend 
Arbeisspeicher" ab.
xcopy hatte ich in verschiedene Batch Dateien, um meine Arbeit im 
täglichem Interval zu sichern.
Wenn ganz hart kommt, suche ich mir ein Board mit IDE und SATA, das 
unter w2k funktioniert.
hat damit nicht zu tun "Backup für Faule, c't 11/99", sondern bietet die 
Möglichkeit, Dateien einfach zu sichern.
gruß Siegfried

Autor: Roland Praml (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leere mal die temporären Internetdateien (bzw. das Verz. bei dem xcopy 
abbricht). Meist hat sich da soviel angesammelt, dass xcopy das 
Verzeichnis nicht auf einmal lesen kann und mit "zu wenig speicher" 
abbricht.

Gruß
Roland

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Könnte es sein, daß die Zielfestplatte FAT32 nutzt, aber eine Datei mit 
mehr als 4 GByte kopiert werden soll?

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das wird ein Bug im xcopy oder im Kernel sein, der den Speicher nicht 
mehr freigibt. Beobachte den Task-Manager während xcopy läuft und 
vergleiche mit 2000.

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
alle auf diesem Rechner befindliche Partitionen sind NTFS.
Habe bei meinen kopieraktionen dieses auch im Task-Manager verfolgt.
Wie schon gesagt, wird ein Teil der Dateien/Verzeichnisse kopiert, und 
dann bricht xcopy mit bekannter Fehlermeldung ab.
Vergleich mit w2k kann ich nicht mehr vornehmen.
gruß siegfried

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmm. Das ist sehr merkwürdig. Wieviele Dateien werden/sollen denn 
verarbeitet? Sind die verwendeten Pfade besonders lang?

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
wieviele Dateien das sind, weiß ich nicht. Schätze ca. 150000. Was bis 
jetzt gesehen habe, war ungefähr 70000.  Pfade können unter umstände 
lang sein. Verzeichnisse sind tief verschaltelt.
ABER, UNTER WINDOWS 2000 WAR ALLES IN ORDNUNG !!
gruß Siegfried

Autor: DMS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
darf ich die worte rsync und ct in die Runde werfen?

Autor: Siegfried Saueressig (dieleena)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Verwende jetzt diesen Befehl
-> xcopy e:\eagle\*.* G:\Daten\eagle\ /k /r /e /i /s /c /h /d <-
Glaube das dieses funktioniert.
Habe aber noch ein anderes Problem. Unter Win2000 habe ich den Befehl in 
einer *.bat genutzt. Jetzt bekomme ich aber, daß das System -> xcopy <- 
nicht findet. Muß bei der Auktion etwas verstellt haben.
So ist das, wenn die grauen Zerllen nicht mehr arbeiten möchten.
bis bald Siegfried

Autor: Der Hubert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Benutze selbst seit Jahren

xcopy.exe x:\xxxx\*.* y:\xxxx\*.* /E /V /H /R /D /Y

(x und y durch eigene Parameter ersetzen)

ohne Probleme und unter den unterschiedlichsten WinVersionen.

Ich glaube, ich muste lediglich beim Umstieg von Win9x auf WinXP und Co. 
was ändern oder ergänzen, keine Ahnung ....

In XP ist bei xcopy IMHO kein Bug.

Es gab aber mal Probleme mit Dateien mit Umlauten aber das äusserte sich 
nicht durch Fehlermeldungen, sondern diese dateien wurden schlicht 
ignoriert, sollte inzwischen aber wieder gehen ....

Autor: Der Hubert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei "nicht genügend Arbeitsspeicher" könnte es sein, dass hier zu viele 
Dateien vorab in ner Liste gepuffert werden und DU im Dosfenster 
tatsächlich nicht mehr genügend Speicher hast.

Unter DOS hast Du max. 640KB RAM (!!), der bei dieser Anzahl von Dateien 
wirklich am Ende sein könnte. Das dürfte sich aus Kompatibilitätsgründen 
in der DOS Box auch nicht geändert haben.

Evtl. fehlen Dir auch nur wenige Bytes, die u.U. unter W2K auch bald 
gefehlt hätten.

Tipp: Alten Schei** einfach mal auslagern, wu Du weist, dass Du den eh 
längere Zeit net brauchen wirst.

Tipp2: backup aufsplitten, d.h. Du "xcopyst" 2x hintereinander. Einmal 
die 1. Hälfte, gleich danach die 2. Hälfte und die 2 Befehle in eine 
.BAT ....

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falsch, schon das xcopy auf Win2000 ist ein 32-Bit-Programm.

Autor: yxcv (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Ramie (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi...
Wahrscheinlich (das Problem hatte ich auch) hast Du in dem gesamten Pfad 
inkl. Dateinamen eine mehr als 255 Byte lange Zeichenfolge. Damit kommt 
xcopy nicht klar. Du solltest das Programm robocopy verwenden, ich habe 
es angehängt. Es ist mittlerweile Systembestandteil von Win2003 Server 
und Win Vista.
Verwendung ist sehr einfach. Für einen Spiegel des einen Verzeichnisses 
auf eine andere Platte einfach robocopy <quelle> <ziel> /MIR eingeben, 
das war es schon. Ansonsten roboycopy /? erläutert sämtliche Parameter.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich würde auf robocopy umsteigen, hat etwas mehr möglichkeiten und kommt 
auch mit 1.000.000 Dateien klar. Gibts von MS kostenlos, ist im 
Resourcekit enthalten und findest sich auch auf diversen seiten im Inet.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.