www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit Mosfet Treiber


Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es soll eine 100Watt 12V Halogenbirne gedimmt werden. Dazu wird die 
Wechelspannung eines Trafos gleichgerichtet um "anschließend" von einem 
Powermosfet (IRL 3803) geschaltet zu werden. Dies erfolgt per PWM (ca. 
600Hz) und einem speziellen Mosfet Treiber IC (TC4427).
Das durchschalten der Birne auf 100% stellt kein Porblem dar, sobald 
jedoch die PWM aktiviert wird, löst sich der Chip in Rauch auf (der 
Mosfet ist davon unbetroffen).
Bei der Beschaltung habe ich mich an dem Datenblatt des Chips 
orientiert, dabei aber leider C load vergessen. Könnte dies ein Grund 
für das "Abfackeln" sein?

Gruß
Julius

Autor: Bernhard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit diesem Kameraden hatte ich auch schon viel Kummer.
* Sind die Flanken des Eingangssignals am Treiber steil?
* hast du 100 nF und ca. 2 µF Tantal SEHR nahe am IC?
* ist garantiert immer ein definierter Zustand am Eingang?
* geht die Versorgungsspannung sicher nie über 18 V?

Danach kannst du dem kleinen Kerlchen trauen.

Viele Grüße,
Bernhard

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Hast du zwischen Triueber und Gate einen Widerstand?
Falls nicht können die Umladeströme der Gatekapazitäten durchaus den 
Treiber himmeln. Versuch mal so um die 10-20 Ohm

Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Abstand beträgt max. 4mm.
Die Flanken sollten ansich ok sein (über einen Amtel µC gesteuert).

Was mir Sorgen macht ist die Restwelligkeit. Schließlich kommt am Chip 
nur gleichgerichteter Stronm an (über einen 100µA starken Kondensator 
geglättet). Reicht die Kapazität aus?

Wie verhält es sich mit dem fehlendem C load?

Gruß
Julius

Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Widerstand werde ich versuchen. Aber an sich müsste der doch 
bereits im  Datenblatt eingetragen sein, oder?

Gruß
Julius

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Der C Load ist nur für Messzwecke (Flankensteilheit).
Der Widerstand ist von der Anwendung abhängig. Mit dem IC kannst du 
genausogut einen Schrittmotor ansteuern und da brauchst du keinen 
Widerstand. Die Größe der Gatekapazitäten kannst du bem Datenblatt 
deiner Mosfets entnehmen.

Gruß Spess

Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Na das ist doch schön zu hören, dass es am C load nicht gelegen hat 
(hätte mich auch gewundert) Könnt ihr vielleicht noch genauer auf die 
Frage von 20:18 eingehen?

Gruß
Julius

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Wie immer wäre deine verwendete Schaltung hilfreich.(Glaskugelproplem).

Ansonsten würde ich dir vorschlagen zwischen den gleichgerichteten 12V 
und dem Treiber+Kondensatoren eine Diode (1N4001...1N4005) in 
Flußrichtung zu schalten. Damit entkoppelst du die Stromversorgung des 
Treibers von der Lampe.

MfG Spess

Autor: sonero (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Du solltest wirklich mal Deinen Schaltplan posten. Du hast ja einen 
unbenutzten Eingang, ist der offen oder auf Masse?

Wahrscheinlich ist, daß beim Auschalten des Fet der Trafo 
Spannungsspitzen abfeuert, die den Treiber killen. Deine 100µF bringen 
fast gar nichts, um 2 Größenordnungen zu klein und auch zu langsam. 
Schnelle Spitzen sausen an so einem Elko vorbei.
Häng den Treiber einfach an die 5V und es sollte Ruhe sein.
Der Treiber kann 5V und dem Fet reicht das auch. Um Dir nicht andere 
Störungen auf den 5V einzufangen, einen R von 100 - 270 Ohm in die 
Gateleitung, bei 600Hz schaltet das dann immer noch locker schnell 
genug.

Gruß,
Norbert

Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die Antworten.

@Spess: Hatte leider vergessen zu erwähnen, dass bereits eine Diode nach 
deinen Vorstellungen verbaut ist.

@Norbert: Die Befürchtung mit dem C load war also richtig. Es ist 
übrigens ein 1000µ Kondensator (nicht 100µ) verbaut; werde ihn trotzdem 
durch einen größeren ersetzten.
Auf 5V runterzugehen ist leider nicht möglich, da die minimale 
Betriebsspannung der Treibers bei 6,5V liegt, außerdem soll später ein 
billigeres Mosfet Exemplar zu Einsatz kommen. Den Gate-Widerstand kann 
ich mir wegen der recht störungsresestenen Spannungsversorgung sparen, 
oder?
Bist du sicher, dass Spannungsspitzen nicht durch die kleineren 
Kondesatoren abgefedert werden?
Den zweiten Input Pin des Treibers werde ich auf Masse ziehen.

Im Anhang findet ihr übrigens den Schaltplan.

Gruß
Julius


Autor: Julius Krebs (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
anhang

Autor: tip (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ground any unused driver input.

Autor: sonero (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,


Wie kommst Du auf 6,5V?
http://ww1.microchip.com/downloads/en/DeviceDoc/21422D.pdf
Da steht 4,5V.

Wo kommt die PWM her?
Wenn es ein AVR ist:
Nimm nen anständigen Mosfet und schmeiß dafür den Treiber raus wenn es 
denn auf die letzten 30 Cent ankommt. Die 20mA reichen bei den 
läppischen 600Hz locker. Dann aber bitte wirklich nen Gatewiderstand von 
270 Ohm.

Kein Gatewiderstand und ein offener Eingang, dazu 10A mit 1000µ aus nem 
Trafo schalten, das geht nicht so ohne weiteres.
Wieso soll das später ein günstigerer Mosfet werden? Wenn das ein 
Serienprodukt werden soll, dann lass das bitte jemand auslegen, der 
etwas mehr davon versteht.
Nach dem Brücken-GR 1N4007, dann 1000µ, 4µ7, 100n nur für den Treiber?
Vollkommener Unsinn.

Den Buz11 schlägst Du Dir bitte auch aus dem Kopf oder wo willst Du bei 
8,3A mit den 2,8W Verlustleistung hin? Bei PWM wird das noch mehr.
Der Kühlkörper wird teurer als ein vernünftiger Mosfet.

Gruß,
Norbert

Autor: Buz11 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Den Buz11 schlägst Du Dir bitte auch aus dem Kopf oder wo willst Du bei
>8,3A mit den 2,8W Verlustleistung hin? Bei PWM wird das noch mehr.
>Der Kühlkörper wird teurer als ein vernünftiger Mosfet

Welche alternative siehst du denn für den Buz11? Ich meine einigermaßen 
bezahlbar und auch überall zu bekommen.

Autor: sonero (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Hattest Du doch schon, IRL3803

Gruß,
Norbert

Autor: Julius Krebs (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mich leider im Schaltplan bei den Bauteilen vertan: Im Moment 
im Einsatz: Treiber: MC34151, Mosfet: IRL3803.
Die Ankündigung einen anderen Mosfet zu verwenden verwerft ihr am besten 
fürs erste, denn das eigentliche Problem liegt ja woanders.

>Nimm nen anständigen Mosfet und schmeiß dafür den Treiber raus wenn es
>denn auf die letzten 30 Cent ankommt. Die 20mA reichen bei den
>läppischen 600Hz locker. Dann aber bitte wirklich nen Gatewiderstand von
>270 Ohm.

Ich werde deinem Rat befolgen.
Trotzdem wüsste ich gerne welche Kondensatoren eingesetzt werden 
müssten, um für eine vernünftige Betriebsspannung der Treibers zu 
sorgen.

>Nach dem Brücken-GR 1N4007, dann 1000µ, 4µ7, 100n nur für den Treiber?
>Vollkommener Unsinn.

Wo ist genau der Unsinn? Im Datenblatt des MC34151 werden zwei 
Kondensatoren (4µ7, 100n) schließlich empfohlen. Den 1000µ C durch einen 
10000µ zu ersetzen hatte ich ja bereits angekündigt. Ist das immer noch 
nicht ausreichend?
Wenn ich mir für die maximale Restwelligkeit 0,1V und den Stromverbauch 
bei 100mA ansetze kommt genau der Wert 1000µ dabei heraus. Demnach 
dürfte der Kondesator sogar ausrechen,

((0,1 A) * (0,01 s)) / (0,1 V) = 0,01 farads

Wo ist der Denkfehler?

Gruß
Julius

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Julius

Ganz generell nimmt man pro Ampere 1000µF , zum glätten.

Bei PWM kannst du die 4 x 2500µF von einem Mainboard nehmen :-) Low ESR 
.

Also du kannst 100µF (Elko) + 1µ (Keramik-Vielschicht) für den Treiber 
nehmen, das reicht aus.
Der Kondensator speist du am besten über einen 7812 oder 7815 oder du 
nimmst anstatt dessen nur eine Diode (wenn die Spannung nicht über 20V 
geht)

lg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.