www.mikrocontroller.net

Forum: PC Hard- und Software XP und Netzwerkdrucker


Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
'N Abend zusammen,

ich hoffe, hier hat noch jemand eine Idee zu meinem vertrackten 
XP-und-Netzwerkdrucker-Problem.

Also erstmal: Ich hab inzwischen schon zirka eine Handvoll XP-Rechner in 
unser recht heterogenes Firmennetz eingebunden bekommen und schon 
diverse Spezialprobleme besiegt, aber diesmal komme ich einfach nicht 
weiter.

Ich setze als bekannt voraus, dass ein XP home zwar grundsätzlich auf 
jedem modernen Rechner ungefähr läuft, aber selbst bei gleicher Hardware 
immer noch Unterschiede im Setup heckt. Warum, weiß der Kuckuck.

Und so stehe ich gerade von der Frage, warum eine spezielle 
XP-Installation immer dann, wenn der Standarddrucker ein Netzwerkdrucker 
ist, gleich "Stunden" im LAN verbringt, um den Drucker zu finden.

Ich mein, ich hab dasselbe Netzwerksetup drauf wie bei zwei anderen 
XP-Rechnern, die vorher gesponnen haben und danach zufrieden waren...

Für jeden Hinweis dankbar,
Johannes

Autor: Heiko (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

habe das Problem auch. Es gab bei mir (Printserver) Problem als ich 
nachgefüllte Patronen drin hatte. Der Drucker hatte dann gemeldet, dass 
die Patrone nicht o.k. ist Gewährleistung bla bla. hat wirklich Stunden 
gedauert,
Ich hatte den Drucker dann an die USB angeschlossen und Fehlermeldung 
ausgeschaltet.
Jedesmal wenn der Drucker anfängt zu reden hängt das LAN bei mir.

Vielleicht hilft es ja weiter

Heiko

Autor: Gast aus NL (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Johannes,
welcher Drucker welche Firmware, welche Netzwerkkarte, welcher 
Printserver,welche XP home Version Servicepacks, Hotfixes,welche 
Netzprotokolle, ... welche Menu Settings Netzwerk hast du vielleicht mal 
mehr info.

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

offenbar ist das Problem ziemlich verbreitet, nur betrifft es wohl öfter 
nur bestimmte Anwendungen (z.B. Office) und wird deshalb nicht so 
allgemein als Windows-Problem diskutiert, als welches ich es inzwischen 
sehe.

Das "Jedesmal wenn der Drucker anfängt zu reden..." könnte eventuell ein 
Tip sein. Danke, Heiko.

Ansonsten ist XP bei allen Rechnern voll aktuell (automatisches Update), 
als Netzwerkprotokolle laufen standardmäßig TCP/IP (feste Adresse) und 
NetBIOS over TCP/IP, und bei den beiden Rechnern, die ich schon 
"zugeritten" habe, brachte NETBEUI die entscheidende Wendung. Drucker 
und Printerserver spielen praktisch keine Rolle - bei uns verhalten sich 
beide vorhandenen (ein NRG-Kopierer als Netzdrucker und ein Canon iP4000 
an einem Win98-PC mit shared printer und XP-Setup) identisch, und im 
Internet findet man diverse weitere. Ähnlich frei ist die Auswahl bei 
den NICs, die bei uns ein Realtek 8139, ein SIS 191 und ein VIA Rhine II 
sind.

Ich weiß, das ist alles nicht sehr klar. Aber deshalb frage ich ja :-)

Gruß Johannes

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst ja mal mit Etherreal lauschen, was auf dem Netz so abgeht wenn er 
hängt.

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh, Etherreal zeigt so einiges ;-)

Und speziell immer wieder Traffic-Pausen von 10 bis über 20 Sekunden, 
die sich dann zu den am Client beobachteten Wartezeiten summieren...

Ich bin leider nicht richtig fit im Beurteilung von TCP/IP-Traffic. 
Worauf muss ich da speziell achten, bzw. was kann welche Hinweise zu 
meinem Prob geben?

Gruß Johannes

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probleme gibt es bei gleichzeitiger Verwendung zweier 
Netzwerkprotokolle; wozu braucht man heutzutage noch NETBEUI?

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wozu man NETBEUI noch braucht?

Z.B. um mit StarMoney 5.0 einen NetBIOS-Drucker vernünftig fahren zu 
können....... :-(

Übrigens die besagten Probleme mit diesem speziellen Rechner gibt es 
auch, wenn NETBEUI nicht installiert ist.

Gruß Johannes

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> brachte NETBEUI die entscheidende Wendung

Und Ohne machen diese Rechner auch Pause oder geht dann gar nichts?
Evtl. ist TCP/IP nicht richtig konfiguriert.

Die NT-Netzwerk-PCs bestimmen unter sich einen "Master-Browser", der 
nach Ressourcen gefragt wird. Wenn keine NT-Server-Version im Netz 
vorhanden ist, wird das irgendeiner der Clients. Wird dieser Client 
"gewaltsam" vom Netz getrennt, herrscht unter den anderen PCs erstmal 
munteres Rätselraten.

Auch lustig ist unterschiedliche Subnet-Maske - Internet und Ping 
funktionieren, das Druck- und Dateigeraffel von Windows aber nicht.

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke *.*, jetzt wird mir einiges klar!

Also erstmal zur Frage: NETBEUI brachte die entscheidende Wendung zum 
Guten. Ohne ging es zwar nicht gar nicht, aber die Druckzeiten waren so 
lange, dass mit StarMoney einfach kein vernünftiges Arbeiten möglich 
war.

Was schätzungsweise mit dem Ressourcen-Browser zu tun haben wird, denn 
wir haben tatsächlich keinen NT-Server (mehr) im Netz, und unsere "auf 
NT-Technologie basierten"-Clients spielen wohl immer erstmal ne Runde 
Würfeln oder so, wer denn jetzt für den Drucker zuständig ist ;-)

In dem Kontext ist auch die Sache mit der Subnetzmaske logisch: Weil 
beim Würfeln Broadcasts verwendet werden, dürfen diese natürlich nicht 
ausgefiltert werden, was bei eingeengter Subnetzmaske aber ganz schnell 
passiert. Und NETBEUI funktioniert wohl genau deshalb, weil damit eben 
nicht erst gewürfelt wird...

Ok, damit habe ich ein paar Anhaltspunkte, wo und wie ich weitermachen 
kann.

Und auch gleich noch eine Frage: Ist es irgendwie einfach möglich, 
diesen Master-Browser auf einem bestimmten Client zu forcieren?

Gruß Johannes

Autor: *.* (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich weiß nur, dass mein FLI4L-Router auf Befehl den Masterbrowser 
spielen kann. Sollte also mit Samba irgendwie möglich sein.

Das Ganze taucht auch im Eventlog als Hauptsuchdienst hin und wieder 
auf.

Jetzt fällt mir gerade auf, dass ich schon lange keine dieser Meldungen 
mehr gesehen habe - ob das etwa an diesem Linux-Router liegt? :D

Dann war da noch die Sache mit den Hostnamen in der "hosts"-Datei. Alle 
bekannten IPs/Computernamen da eintragen, schien in gewissen 
Konstellationen das Auffinden von Druckern/Ordnern zu erleichtern.

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jou, damit komm ich weiter. Danke nochmal.

Gruß Johannes

Autor: Johannes A. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur Info für meine Helfer, speziell *.*, und für alle, die vor demselben 
Problem stehen:

Seit heute mittag spielt alles vernünftig - und "natürlich" ganz anders 
als bisher diskutiert. Weil nämlich die Masterbrowser-Methode bei 
näherem Hinsehen ebenso ihren Pferdefuß hatte, konkret in der Form, dass 
in unserem Firmennetz auch immer noch die privaten Rechner der 
Chef-Familie mit drin hängen. Zwar ohne Rechte auf den Firmenservern, 
aber immer noch ohne den (seit Jahr und Tag angemahnten) eigenen 
Router/Switch, nach dem Motto "Wieso was ändern (und womöglich selber 
was tun)? Es geht doch auch so!"... grrr...

Aber lassen wir das und kommen zur Lösung: den NRG-Kopierer (NRG = 
Nashua/Ricoh/Gestettner, ein wirklich feines Teil, und unterm Strich gar 
nicht teuer) habe ich jetzt per XP-Standard-TCP/IP-Druckerport 
angebunden, und den Canon-Drucker über einen DSL-Router mit 
USB-Printerport (billiger als ein dedizierter Printerserver, und zudem 
mit 4-Port-Switch/Hub fürs LAN), dessen mitgelieferter Treiber einen 
extra "lokalen" USB-Printerport für bis zu 8 Drucker einrichtet, und der 
nicht nur für XP taugt, sondern auch für Win98. (Ja, solche Kisten 
laufen bei uns auch noch.)

Und alles ohne weitere Klimmzüge mit WINS, Masterbrowser und NETBEUI, 
und sogar ohne die bestehenden (krausen) XP-Konfigurationen zu stören. 
Ich werde über die nächsten Wochen/Monate auch den Rest der "Mannschaft" 
in derselben Weise umstellen. Das einzig blöde ist, dass ich den 
NRG-Kopierer wohl auf fast jedem einzelnen Rechner komplett neu 
einrichten muss - die "Save Config"-Funktion des XP-Treibers ist nämlich 
flaky und heckt immer Abbrüche, je nach Laune, wegen Zugriffs auf 
wahlweise Adresse 0x00000000 oder 0xFFFFFFFF. Nunja, immer noch besser 
als tagelang völlig im Trüben zu fischen...


Noch einmal Danke für die Hilfe, und mögen andere jetzt weniger Zeit auf 
dieses Problem ver(sch)wenden als ich.

Gruß Johannes

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.