www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MAX3232 - Pegelproblem


Autor: George Müller (george)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich benutze einen MAX3232-Baustein für die RS232-Pegelwandelung und habe 
diesen wie im Datenblatt beschrieben mit 0.1µF-Kondensatoren beschaltet. 
Zur Inbetriebnahme habe ich die TTL-Pegel mit dem Oszi überwacht. Dabei 
habe ich festgestellt, dass wenn die Datenübertragung vom 
PC-->MAX3232-->µC beginnt, die ersten beiden fallenden Flanken (1->0) 
nicht sauber abfallen. Für mich sieht das TTL-Signal wie ein 
Entladevorgang des Kondensators aus. Diesen Signalverlauf sehe ich aber 
nur bei den ersten beiden 1-->0-Übergängen. Nach den ersten beiden 
1-->0-Übergängen sehen die fallenden Flanken ordnungsgemäß aus. Die 
steigenden Übergänge(0-->1-Pegel) sehen von Anfang an sauber aus.
Für mich sieht es so aus, als ob die Kondensatoren des MAX3232 zu groß 
sind und dementsprechend nicht schnell genug entladen werden können.
Da ich nicht der Elektronik-Fachmann bin, wäre es schön, wenn mir jemand 
einen Tipp geben könnte.
Danke

Gruss george

Autor: Severino R. (severino)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Kondensatoren sind Ladungspumpen zum Erzeugen der doppelten Spannung 
(2x5V -> 10V) sowie zum Invertieren der Spannung (-10V).
Diese Signale liegen auf der RS232-Seite, nicht auf der TTL-Seite.

Wie ist denn der Zeitverlauf, also wie lange dauert das Fallen von sagen 
wir mal 4.5V bis 0.5V?
(die ersten Male und auch die weiteren Male)?

Severino

Autor: George Müller (george)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo severino,

ich habe vergessen zu sagen, dass ich den MAX3232 mit 3.3V betreibe.
Das genaue Timing kann ich jetzt nicht sagen, da ich nicht mehr am Oszi 
bin. Auffälig ist aber, dass bei der ersten 1-->0-Flanke der Pegel von 
3.3V bis ca.1.5V fällt. Dann kommt wieder eine 0-->1-Flanke und der 
Spannungspegel liegt wieder bei ca. 3.3V. Bei der nächsten 1-->0-Flanke 
fällt die Spannung sofort von 3.3V auf ca 1.5V und dann ist wieder der 
Entladevorgang von 1.5 bis 0V zu sehen. Bei allen weiteren 1-->0-Flanken 
ist kein weiterer Entladevorgang erkennbar.Das heißt die Flanke fällt 
sofort von 3.3V auf 0V.

Gruss george

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.