www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik verrückte Fehlermeldungen in AVR studio


Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich hatte bereits beruflich mit AVR Studio 4 zu tun. Daher weiß ich, daß 
da so manches nicht ganz koscher ist. Dennoch konnte ich die meiste Zeit 
vernünftig mit dem Tool arbeiten.
Jetzt versuche ich mich in einem privaten Projekt, was mir aber recht 
schwer fällt, da ich ständig verrückte Fehlermeldungen bekomme. Ich 
benutze die Version 4.12 Build 498.
Anfangs konnte ich ein Projekt anlegen, was allerdings beim 
automatischen Öffnen beim Programmstart zu Fehlern führte. Nach 
manuellem Laden war wieder alles ok. Dann gab es aber Probleme beim 
Build. Jetzt ist es mir gar nicht mehr möglich ein Projekt anzulegen. 
Ein paar von den Fehlermeldungen habe ich aufgelistet. Was mich wundert 
ist, daß es Probleme gibt mit dem STK500, obwohl ich gar keins verwenden 
will und als Tool den Simulator eingestellt habe.

Loaded plugin STK500
Loaded plugin AVR GCC
Loaded partfile: C:\Programme\Atmel\AVR Tools\PartDescriptionFiles\
Error in plugin: STK500 when handling event 101
Error in plugin: STK500 when handling event 102
Loaded plugin AVR GCC
Loaded partfile: C:\Programme\Atmel\AVR Tools\PartDescriptionFiles\
Error in plugin: STK500 when handling event 101
gcc plug-in: Project:::usesExtMakefile(): Invalid Configuration
gcc plug-in: Project:::usesExtMakefile(): Invalid Configuration

Kann mir jemand diesbezüglich helfen?

Gruß Matthias

Autor: Walter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das kenn ich auch,
nach Beenden und Neustart von AVRStudio gehts dann evtl. wieder,
ich weiß auch nicht wieso

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gelegentlich (aber eher selten) verhält sich AVR-Studio seltsam, mal 
verschwinden Icons, mal ist der Textcursor weg, mal reagiert es nicht 
mehr auf die Funktionstasten. Dann beende ich alle Anwendungen (meist 
ist noch ein PDF und ein Dateimanager offen), starte den Rechner neu, 
und alles ist wieder ok.

...

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für Eure Meldungen. Ich habe das Projekt komplett gelöscht. Jetzt 
läuft es wieder. Mir ist dabei noch etwas aufgefallen. Es lag noch ein 
anderes Projekt im Hintergrund. Scheinbar kommt es im AVR Studio nicht 
gut, zu einem anderen Projekt zu wechseln indem man das neue öffnet. Man 
sollte immer das aktuelle vorher schließen.

Gruß Matthias

Autor: D. H. (slyd)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
... einmal habe ich AVRStudio offen gehabt, bin weggegangen und ne halbe 
Stunde später wieder gekommen.
Resultat war das das alte Notebook ziemlich heiss geworden ist weil 
AVRStudio meinte konstant 25% Prozessorlast erzeugen zu müssen g
... und ja und es stürzt auch öfters mal ab oder verhält sich extremst 
seltsam...

Autor: Bruce Darnell (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Normalerweise kann das AVR Studio nur ein Projekt auf einmal öffnen...
Falls dann ein anderes geöffnet werden soll, wird das andere erst 
geschlossen und ggf. noch abgespeichert.

Gruß,

Autor: Björn Wieck (bwieck)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik s. Herwald wrote:
> ... einmal habe ich AVRStudio offen gehabt, bin weggegangen und ne halbe
> Stunde später wieder gekommen.
> Resultat war das das alte Notebook ziemlich heiss geworden ist weil
> AVRStudio meinte konstant 25% Prozessorlast erzeugen zu müssen *g*
> ... und ja und es stürzt auch öfters mal ab oder verhält sich extremst
> seltsam...


Bei mir erzeugt AVR-Studio konstant Netzwerklast und das nicht zu knapp.
Allerdings liegen meine Projekte auch auf einem Netzlaufwerk.
Aber komisch ist es schon...

Grüße
Björn

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf meinem alten Pentium-166 Programmierrechner liegt die Prozessorlast 
konstant bei über 75%, was der alten Kiste aber (auf Holz klopf) nichts 
ausmacht. Auf dem PIII-600 sind´s auch immer noch 20%. Für meinen 
Geschmack auch ein wenig zu viel Ressourcenklau...

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Bruce Darnell

Genau davon bin ich ausgegangen. Scheinbar ist es aber für AVR Studio 
doch ein Unterschied, ob ich direkt ein anderes Projekt öffne(wobei das 
aktuelle implizit geschlossen werden sollte) oder ob ich das aktuelle 
vorher schließe.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.