www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ISP Problem: Mega32 läuft, andere nicht


Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

meine etwa 5 Jahre alte parallele ISP Schaltung nach der Ponyprog 
Website mit einem HC244 arbeitet einwandfrei mit meinem ATmega32 
zusammen, verweigert aber bei allen anderen AVRs in meiner Sammlung 
(4433, 2313, mega8, mega88) den Dienste mit der Ponyprog Meldung "Device 
missing or unknown device (-24)". YAAP erkennt auch nur den mega32, alle 
anderen nicht.
Schade, denn ich habe im Moment ein paar Projekte, für die ich die alten 
AVRs endlich mal "verbrauchen" könnte.

Die Signale MOSI, RESET und SCK liegen an den AVRs mit ausreichend hohem 
Pegel an. Trotzdem bleibt die MISO Leitung low. Ein Oszillator mit 
4,096MHz, ein Keramikresonator mit 8MHz und ein Quarz mit 7,...MHz, ein 
10k Pullup am Resetpin und ein Kondensator zwischen GND und VCC sind 
vorhanden - bringt aber nichts.

Wie ist so etwas zu erklären? Ich habe leider keinen LA, aber ich denke 
dass die Signale ok sind weil ja der mega32 damit klarkommt.

Grüße,
Marco

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

welche der Schaltungen? Die mit den 1k Schutzwiderständen?
Wenn ja, schmeiß die Widerstände raus, die versauen die Flanken.

Gruß aus Berlin
Michael

Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

dann bleibt Dein Effekt leider für mich rätselhaft...

Ich benutze sowohl das Original-STK200-Dongle als auch Nachbauten mit 
Deiner Schaltung (ist die originale), geht mit allen AVR mit Pony.

Gruß aus Berlin
Michael

Autor: Marco (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lösung: Nicht immer blind dem Steckbrett trauen und mal nachschauen ob 
manche Kontankt schon so ausgelutscht sind, das kein Kontakt mit IC 
Beinchen zustande kommt...

Na klasse. Das nächste Brett wird besser behandelt :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.