www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Grafik-LCD von Pollin [LCD-NAN-YA-LMAJ6R002A]


Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Ein Freund und ich wir haben uns das Grafikdisplay 
"LCD-NAN-YA-LMAJ6R002AP" von Pollin gekauft. Unter dem Link ist es zu 
finden:

http://www.pollin.de/shop/shop.php?cf=kontakt_service.php

Wir haben auch schon Datenblätter herangezogen. Bei der Verdrahtung sind 
wir nun stehengeblieben. Da steht beispielsweise, dass Pin 4 für die 
"Power Supply for LCD (- V )" genutzt wird. Heißt es, dass wir da 5 V 
anlegen sollen, oder 3 V ? Das heißt wir sind uns unsicher mit der 
Spannung. In einem Datenblatt steht für "Supply Current (LCD)   IEE VDD" 
3.0V, 2.5mA. Hat jemand Erfahrung mit dem Display?

Wenn ja, wäre gut, wenn ihr uns Material geben könntet. Datenblätter 
oder so. Haben zwar schon welche aber sind erst am Einarbeiten.

Danke

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, der Link wurde falsch übernommen.
Also auf der Startseite bitte auf "Bauelemente" klicken, dann auf 
"aktive Bauelemente", dann auf "Displays". Darunter findet ihr es mit 
der Bezeichnung "LCD-NAN-YA-LMAJ6R002A"

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

naja, Datenblatt kann man das nicht so unbedingt nennen...

Vee ist die Spannung für den LCD-Treiber, meist "Kontrastspannung" 
genannt.

Die ist nach dem Zettel maximal 13,8V, normal irgendwo zwischen 19,8 und 
12,5V. Da Vee sich auf Vdd bezieht, also auf die +5V, müssen an Vee ca. 
-7V gegen Vss (GND) liegen. Du brauchst also ca. -7,5V, die an einen 
Einstellregler 10k gegen GND und den Schleifer an Vee. Damit stellst Du 
dann auch den Display-Kontrast ein.

Gruß aus Berlin
Michael

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Danke für die Antwort. Brauch das Display echt mindestens 13,8 V an 
Spannung an dem Pin? Erscheint mir sehr hoch. Dachte, dass die meisten 
Display mit 5 V arbeiten. Hmm ... und die negative Spannung ist nötig? 
Denn muss ich ja eine Art "Vorschaltplatine" bauen, damit ich es in 
betrieb nehmen kann, oder?

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

die Logikspannung ist selbstverständlich 5V oder wohl auch 3,3V (müßte 
man ein komplettes Datenblatt haben).

Die 13V sind die Treiberspannung für den LCD-Kontroller, der leigt aber 
gagen die +5V (bzw. 3,3V). Diese Spannung ist also 11V - 5V = 6V. Der 
Anschluß Vee muß also 6V negatiber sein als GND, also -6V an Vee.

Hab geradde nichts anderes gefunden:

http://www.lcd-module.de/deu/pdf/doma/4_16.pdf

ist zwar ein völlig anderes Display, interessant für Dich ist die 
Schaltung unter Kontrasteinstellung links, das sind auch die 
Spannungsverhältnisse für Dein Display.

Gruß aus Berlin
Michael

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke. Soweit habe ich es verstanden. War bloß erstaunt darüber, dass 
ein Display mehr als 5 V benötigt.
Also bleibt mir nichts anderes übrig, als ein Netzteil zu bauen. Der USB 
Port erlaubt mir ja nur 5 V zu beziehen.

Hat jemand ne Schaltung dafür?

Autor: anonymous (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie wäre es mit einem Spannungswandler? Google sprut + spannungswandler.
2.5mA sind ja wirklich nicht viel, das wird man wohl erzeugen können.

Autor: Ludwig Wagner (lordludwig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kleiner Tipp: Die -10V von einem MAX232 an einem Poti reichen dazu meist 
aus ;)

Eichfach, billig und gut zu bekommen^^

Autor: DerJan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Kontrastspannung die negativ gegenüber GND ist?
Klingt ein bischen sehr exotisch.
Ich würde eher ein 10k poti zwischen Betriebspannung und 0V anraten, 
also 0...5V, bzw. 0...3,3V.
Mit -7.5 volt wirst du wohl nur eine Schutzdiode im innern zum rauchen 
bringen. Wenn die überhaupt vorhanden ist.

LCD Displays brauchen zwei Spannungsquellen. Eine für die interne 
Elektronik und eine für den CCL konverter. Was anderes habe ich noch nie 
gesehen.
Meisst 3.3V bis 5 V für das Display und 5 bis 12 Volt für den CCL.
Der CCL zieht schon 1 bis 2 ampere bei kleinen QVGA/VGA Displays.

Autor: Stefan Wimmer (wswbln)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DerJan wrote:
> Eine Kontrastspannung die negativ gegenüber GND ist?
> Klingt ein bischen sehr exotisch.

Nö, ist ganz normal. Nur weil Du bei Modulen (mit eingebauter 
Elektronik) die ganzen Treiber(hilfs)Spannungen nicht zu Gesicht 
bekommst ist da noch nichts exotisches dran.

> Ich würde eher ein 10k poti zwischen Betriebspannung und 0V anraten,
> also 0...5V, bzw. 0...3,3V.

...kann böse enden, wenn der Treiber eine negative Spannung erwartet!

> Mit -7.5 volt wirst du wohl nur eine Schutzdiode im innern zum rauchen
> bringen. Wenn die überhaupt vorhanden ist.

Wenn eine vorhanden ist, dann ist die bei erwarteter negativer Spannung 
andersrum gepolt und raucht eher so bei positiven Spannungen.

> LCD Displays brauchen zwei Spannungsquellen. Eine für die interne
> Elektronik und eine für den CCL konverter. Was anderes habe ich noch nie
> gesehen.

Ah ja! Und was Du noch nicht gesehen hast, das gibt es natürlich auch 
nicht. Vielleicht solltest du den Blick ab&zu mal von Deinem TFT-Panel 
wenden - die Welt der LCD-technologien ist etwas grösser ;-)

> Meisst 3.3V bis 5 V für das Display und 5 bis 12 Volt für den CCL.
...noch nicht mal das stimmt so allgemeingültig. Speziell größere Panels 
(ab 19" aufwärts) haben auch manchmal Inverter mit 24V Eingangsspannung.

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
Wir haben einen Tip bezüglich der Spannungsversorgung erhalten. Im 
Anhang befindet sich der Schaltplan. Was haltet ihr davon?

Autor: Jörg B. (manos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nett, aber unpraktisch... USB und Batterie...
Vielleicht sollte man dann doch lieber mal schauen ob man da nicht was 
mit einem MAX232 machen kann... oder einen kleinen Schaltregler 
aufbauen.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieso unpraktisch? Hättest du denn eine Schaltung mit einem Schaltregler 
da? Habe da keine Arnung von. Danke

Autor: Christoph Kessler (db1uq) (christoph_kessler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ein Schaltregler mit dem MC34063 ist vermutlich die preiswerteste 
Lösung. Hier auf Seite 8 ist eine Schaltung, die aus +5V -12V erzeugt:

http://www.onsemi.com/pub/Collateral/MC34063A-D.PDF

und hier hats noch mehr Schaltbeispiele dazu:
AN920/D Theory and Applications of the MC34063 and mA78S40 ...
http://www.onsemi.com/pub/Collateral/AN920-D.PDF

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Frage zu dem Anschluss noch:

Benötigen wir eine Temperaturstabilisierung für das Display, oder ist 
diese nur von Nöten, wenn wir das Display in kritischen 
Tenmperaturbereichen betreiben?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche es nun mit einem MAX 232 zu realisieren. Der liegt grad herum.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier einmal die Variante mit dem Max 232. Wir erhalten + 10 V und - 10 
V. Nun haben wir die Möglichkeit unsere Kontrastspannung über ein Poti 
einzustellen. Ist die Schaltung richtig? (siehe Anhang)

Wenn ich nun das Poti dimensiniere auf was muss ich da achten? Zum einen 
auf die eingestellte Kontrastspannung, sprich Gesamtspannung -10 V bis + 
10V = 20V - die Kontrastspannung. Dass ist ja die zu "vernichtende" 
Spannung. Diese muss ich dann durch den fließenden Strom teilen, oder ? 
Ohmsches Gesetz

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier der Anhang. Sorry

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir benötigen ja für die Kontrastspannung ca. 13 V. Nun haben wir uns 
gedacht, dass wir zwischen +10V und - 10V (Differenz von 20 V) ein Poti 
hängen. Zwischen Schleifer und dem Poti In liegen nach Einstellen nun 
unsere gewünschen 13 V, oder? Oder MUSS man die Kontrastspannug auf die 
LCD - Spannung von 5 Volt beziehen?

Kann so nichts kaputt gehen?

Gruß

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe -10V vom MAX232 (sind eigentlich nur -8,5V) direkt als 
Kontrastspannung angeschlossen. Das passte bei meinem supergroßen GLCD 
gerade. Mit 10k-Poti zwischen -8,5V des MAX232 und GND brach die 
Spannung am MAX232 etwas zusammen.

Poti zwischen -10V und +10V ist eigentlich Quatsch, die benötigte 
Spannung liegt unter GND, warum sollte man da auch die Spannung über GND 
am Poti "verheizen"?

...

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieso quatsch? Laut Datenblatt brauchen wir für die Kontrastspannung 
mindestens 11 V , max. 13 V. Deswegen nehmen wir die -10V bis + 10 V und 
regeln die insgesamt 20 V auf die gewünschten 11 V - 13 V, oder ist das 
falsch?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem Poti haben wir ja so etwas in der Art wie einen belasteten 
Spannungsteiler, oder? Also je nach Last (auf wieviel Herz das Display 
grad läuft) ändert sich die Spannung am Poti, oder? Wie soll ich denn da 
ein Pot berechnen? Ich weiß kein Strom. Das Datenblatt von Pollin ist 
sehr schlecht. Will das Display ja nicht grillen :(

Hilfe gesucht

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe nun mal mein Netzgerät genommen. Es auf 12,5 V aufgedreht. Diese 
Spannung zwischen GND und VEE (Kontrastspannung) angelegt. Nichts 
passierte. Es floß jedoch ein Strom größer 3 mA. Im Datenblat steht für 
den Strom der Kontrasspannung aber max. 2,5 mA. Hab ich es gegrillt?

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Folgendes haben wir noch zu dem Display gefunden. Leider erst jetzt.
Kann mir jemand den Transistortyp sagen? Und vor allem, wieso wird der 
Schleifer nicht direkt an VEE gelegt, sondern über Umweg "Transistor"?

Muss laut der Zeichnung also eine "negative" Spannung zwischen GND und 
VEE anliegen?

Habe eine positive angelegt. Bedeutet das nun den Tod des Displays?

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Timo wrote:
> Folgendes haben wir noch zu dem Display gefunden. Leider erst jetzt.
> Kann mir jemand den Transistortyp sagen? Und vor allem, wieso wird der
> Schleifer nicht direkt an VEE gelegt, sondern über Umweg "Transistor"?

Sorry, mein Browser mag kein BMP (ich auch nicht)...

>
> Muss laut der Zeichnung also eine "negative" Spannung zwischen GND und
> VEE anliegen?

Ja aber sicher doch, das wurde Dir doch schon in der ersten Antwort 
ausführlich erklärt:
Beitrag "Re: Grafik-LCD von Pollin [LCD-NAN-YA-LMAJ6R002A]"
Liest Du die Antworten überhaupt???

>
> Habe eine positive angelegt. Bedeutet das nun den Tod des Displays?

Das kann ich Dir erst sagen, wenn Du mir das Display zuschickst. Ob ein 
Display das aushält weiß ich nicht, ich mache mich sachkundig, bevor ich 
Spannung anlege. Das ist auf die Dauer weniger frustrierend.


...

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry für die bmp. Habe voreilig gepostet. Lese die antworten wohl. Ist 
mir jedoch unklar gewesen, was gemeint ist. Bin nicht so ein "genie" wie 
du. Frustrieren tut mich dass auch, ja. Vorallem, weil das ding 15 € 
gekostet hat. Deswegen suche ich ja nach Hilfe. Sachkundig ist so eine 
Sache. das versuche ich doch. Bloß zu dem Display gibt es sowenig daten. 
Pollin ist da sehr sparsam.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich das nun mit dem MAX232 machen, oder nicht? Habe den Plan ja 
gepostet.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe mir jetzt mal das "Datenblatt" angesehen. Aufgrund der 
fehlenden bzw. missverständlichen Informationen hätte ich dieses Teil 
nie gekauft, auch nicht für 3 Euro...

Wenn ich (z.B. bei Pollin) etwas Interessantes finde, dann lade ich mir 
erstmal alle verfügbaren Infos (z.B. Datenblätter, Beispielprogramme) 
herunter und sehe mir diese an. Dann beurteile ich, ob ich mit meinem 
Wissensstand in der Lage bin, mit dem Teil umzugehen. Danach entscheide 
ich, ob ich das Teil haben will oder nicht.

Unterhalb einer gewissen preislichen Schmerzgrenze lasse ich mich auch 
mal auf "Lotto" ein, aber dafür wäre mir dieses LCd viel zu teuer.

Tut mir leid, ich kann Dir nicht helfen. Frag den Pollin-Kundendienst...

...

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke. Jetzt ist dass Teil ja da. Haben einen Fehler mit dem Kauf 
gemacht. Aber hoffen, dass wir es doch irgendwie hinbekommen. Für Tips 
und ein Schaltplan mit dem MAX232 zur Spannungsversorgung dankbar

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Morgen...

Immernoch das selbe Thema. Ich habe dazu noch folgendes gefunden und 
wollt euch nach eurer Meinung fragen.

Zitat:

"Noch was am Rand. Die Negative SPannung darf erst angelegt werden wenn 
die 5V+ einige millisekunden angelegt wurde. Das Display muss schon 
initialisiert haben.
Wird das nicht gemacht, wird das Display über kurz oder lang sterben."

Ist diese Aussage korrekt? Darf ich die negative Spannung erst nach 
erfolgreichem initialisieren anlegen?

mfg

Autor: Michael U. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ziemlich endlose Diskussion hier. ;)

Das xxx002 habe ich bei Nan Ya nicht mehr gefunden, evtl. ist das xx003 
ja ähnlich genug.

Da es FontSelect gibt, sollte auc ein T6963C drauf sein.

Dann kannst Du davon ausgehen, daß die ähnlich genug sind.

Ansonsten ist es so, wie ich es schon ganz oben geschrieben habe.

Logikspannung logischerweise 5V, Kontrastspannung (Vee) irgendwo um -7V 
gegen GND.

Einstellregler 10k zwischen -10V vom MAX und GND, Schleifer an Vee, von 
GND aus hochdrehen, bis die Pixel dunkel werden.

Falls es noch lebt...

Ich wurde zwar auf eine Ausnahme mit einem anderen Controller 
hingewiesen, aber Displays mit T6369C kenne ich nur mit Vee zwischen -5 
und teilweise bis -12V gegen GND (mein 240x128 will rund -11V).

Displays mit Vee höher als die Logikspannung sind mir selbst noch nicht 
begegnet.

Du kannst Dich auch gern durch die NAN Ya-Datenblätter wühlen...
http://www.mark-products.com/products.htm

Gruß aus Berlin
Michael

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Michael. Hast mir sehr geholfen. Es läuft. Also d.h. ich sehe 
"Kontrast" ... zwar sehr wenig, aber dass liegt glaub ich daran, dass 
das Display noch net initialisiert ist und so:) ... es lebt also noch 
...

Nun noch zur Temperaturstabilisierung. MUSS ich zwingend eine haben? 
Betreibe das Display ja nur bei Zimmertemperatur :).

Eine weitere Frage. Wir oben erwähnt fand ich einen Beitrag in dem 
geschrieben wurde, dass man die negative Spannung erst nach dem 
initialisieren anlegen darf, stimmt das?

Wenn ja, dass kann ih doch einfach nen Transistor nehmen, den an einen 
Pin des AVRs setzen und nach dem Initialisierungsvorgang schaltet der 
denn duch. Sprich ich benutze die CE - Strecke als Schalter. Setze nur 
einen Basiswiderstand ein.

Ist das okay?

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ob die Kontrastspannung reicht, wirst Du merken, wenn Du es angesteuert 
bekommst.

Ich habe in meinen Unterlagen bei solchen Displays nichts zur 
Einschaltreihenfolge gefunden, hat mir zumindest auch noch keine 
Probleme bereitet, ich würde da nichts weiter machen.

Temperaturstabilisierung erstmal komplett ignorieren, sich wirklich 
Probleme beim Einsatz ergeben, weil der Kontrast sich ändert und Du 
stänig nachregeln mußt, kannst Du auch da noch drüber nachdenken.

Gruß aus Berlin
Michael

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Wir haben nun eine Schaltung auf eine Platine gebracht. Die Schaltung 
sieht so aus:

Max232 mit VCC (Pin 16) und GND (Pin 15) versorgt. Kondensatoren von 2,2 
uF (zu groß? oder zu klein?) gewählt und angeschloßen. An Pin 2 liegen 
nun gegen GND +10V an und an Pin 6 liegen nun gegen GND -10V an. Wir 
haben wie beschrieben zwischen -10V (Pin 6) und GND (Pin 15) ein 10kOhm 
Poti gesetzt. Am Schleifer nehmen wir VEE ab. Diese Spannung kann man 
nun mit dem Poti zwischen 0V und -10V ideal regeln.

Für das Display benötigen wir:

Pin 1  = FGND (legen wir auf GND)
Pin 2  = GND
Pin 3  = VEE  = laut Datenblat irgendwie zwischen 11V und 13V (siehe 
Seite 4)
Pin 4  = VDD  = Logik 5V

Nun haben wir auf die Platine LEDs gelötet, um zu sehen ob 5V "da sind" 
und ob die "negative Spannung da ist". Wir haben die LEDs mit einem 
Vorwiderstand versehen und paralell zur Spannung, die die anzeigen 
sollen geklemmt.

Die Leds leuchten auch wie gewollt. Messen wir nun auf der Platine die 
Spannungen von -10V und + 10V nach, stellen wir fest, dass diese sich 
bei etwa 3 - 4 V und -3 - -4V bewegen. Und wir ledidlich 3,5 V 
Betriebsspannung am Max232 haben. Dieses kann am Spannungsabfall des 
Entwicklungsboards liegen. Drückt dieses unsere Spannungen so herab? 
Muss der Max 232 UNBEDINGT mit 5 V betrieben werden um die +10 V und 
-10V zu liefern?

Schließen wir das Display an die Platine an, so "bricht die negative 
Spannung quasi zusammen" -> die LED für die negative Spannung geht aus. 
Auf dem Display sehen wir überhaupt keine Veränderung. Kein Kontrast, 
kein gar nichts.

Im Anhang findet ihr zu einem das Datenblatt, zum anderen dem Schaltplan 
der Platine. Wäre nett, wenn Ihr euch die Mühe macht und uns helft. 
Danke

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch einen Nachtrag. Wir messen die negative Spannung. Schließen wir nun 
das Display an und messen dabei parallel die Spannung VEE, so wird diese 
auf einmal positiv ... wieso??? Vorher waren da -7 V ... nun ist das 
Display dran und es werden plötzlich +4 V draus ... magie?

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Achja nochmal was zum Verständnis:

Wenn wir VDD, GND, FGND und VEE beschaltet haben (Softwarseitig noch gar 
nichts gemacht haben, weder initialisiert oder so) sehen wir dann schon 
Kontrast oder irgendetwas?

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hm, jemand sagte doch, der MAX232 liefert max. ca. 10mA. Was denkst du 
wohl, was deine LED mit der Spannung anstellt? Ich würde die erstmal 
rausnehmen. Die Einschaltreihenfolge ist beim Basteln kaum relevant, man 
sollte das Display einfach nicht dauerhaft mit "Kontrastspannung" 
versorgen ohne dass die Logikspannung da ist, da dann die benötigte 
Wechselspannung nicht erzeugt wird und der Kristall langsam aber sicher 
durch Elektrolyse zerstört wird. Aber keine Sorge, so schnell geht das 
eigentlich net...
Am besten wird sein, du versuchst erstmal das Display anzusteuern, mit 
etwas Glück erkennst du dann eher, wie du den Kontrast einstellen musst. 
Vorausgesetzt, die Initialisierung funktioniert...
Ich würde mal überprüfen was da für ein Controller draufsitzt und dann 
ein gescheites Datenblatt suchen. Sollte es der T6963 sein, solltest du 
eigentlich keine Mühe haben, etwas zu finden.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für den Tip mit den 10 mA. Also alles verdrahtet. Sehen nichts. 
Initialisieren nun einmal. Mal sehen ob dann etwas zu sehen ist.

Autor: Ralf W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

>Für das Display benötigen wir:
>
>Pin 1  = FGND (legen wir auf GND)
>Pin 2  = GND
>Pin 3  = VEE  = laut Datenblat irgendwie zwischen 11V und 13V (siehe
>Seite 4)
>Pin 4  = VDD  = Logik 5V

Ich glaub hier ist ein Fehler. Hoffentlich nur im Text. Auf Pin 4 liegt
VEE.
In beiden Datenblättern, dem vom Pollin und dem anderen.

>Und wir ledidlich 3,5 V Betriebsspannung am Max232

Eure 5V Versorgungsspannung darf nicht zusammenbrechen.
Überprüft unbedingt die og. Pins. Habt ihr die wirklich korrekt
angeschlossen und nur im Text den Fehler?
1.Messt die 5V ohne dem Display. Sind da die 5V da ist das schon mal 
gut.
2.Dann messt nochmal die 5V mit Display.

Sollte diese dann zusammenbrechen, kann das folgende Ursachen haben:
- eure Spannungsversorgung für +5V liefert nicht genug Strom,
  deshalb bricht die Spannung zusammen
- das Display ist defekt(Voraussetzung alle Versorgungsspg. korrekt
  angeschlossen)

>Habe nun mal mein Netzgerät genommen. Es auf 12,5 V aufgedreht. Diese
>Spannung zwischen GND und VEE (Kontrastspannung) angelegt.

Nachdem Fehler mit den vertauschten Pins und dem was du da schreibst
ist es sehr wahrscheinlich, das ihr das Display gegrillt habt.
Drücke euch aber trotzdem die Daumen das es nicht so ist(Pins korrekt
anschliessen).

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe es nur im text vertauscht. Soll man denn eigentlich pixel dunkel 
sehen oder erst nach der initialisierung?

Autor: Ralf W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Habe es nur im text vertauscht. Soll man denn eigentlich pixel dunkel
>sehen oder erst nach der initialisierung?

keine Idee.

Habe auch noch mal in deinen Schaltplan geschaut, da steht auch Pin3 
VEE.
Auf deinem Board geht Pin3 auf eine Durchkontaktierung in der Nähe das
Potis (Drahtbrücke um das mal trennen zu können). Pin 4 geht auf VDD.

Entweder ist die Zählreihenfolge an der Stiftleiste vertauscht oder ich
hab grad zu viel Bier.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja die kontaktierung ist umgedreht. liegt am verdrehten kabel. dass hat 
seine richtigkeit. aber mich würd immernoch interessieren, ob man pixel 
sehen müsste?also dunkel

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es läuft. Habe es initialisiert. da lieg der Fehler. Es läuft wunderbar. 
Vielen Vielen Dank an Alle:)

Autor: Ralf W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Euer Display kenne ich leider nicht. Kenne nur die HD44780 Typen.
Ich habe dazu mal einen Guide im Netz gefunden.
HOW TO USE INTELLIGENT L.C.D.s /Everyday Practical Electronics, Februar 
1997
Habe allerdings keinen Link dafür.

Habe mir den aber ausgedruckt und da steht folgendes: (frei übersetzt)

Kurz nachdem das Display mit Spannung versorgt wird können Pixel
sichtbar sein. Sollte das so sein soll man den Kontrast soweit ändern, 
das
man diese Pixel gerade noch sieht.
Das Display initialisiert sich aber in einen Modus in dem auf dem 
Display
nichts angezeigt wird. Auch nicht nachdem man ihm Daten zum Anzeigen 
geschickt
hat. Man muss es erst über ein Kommando anschalten.

Wie schon gesagt, ich kenne euer Display nicht. Ob es sich so verhält
wie die HD44780 Typen weiss ich auch nicht genau.
Es ist aber sehr wahrscheinlich, das es so ist.
Ergo ihr seht erstmal nichts.

Autor: Ralf W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh ihr wart schneller. Viel Spass!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.