www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 AT90S8515 detecting Failed


Autor: Verzweifelt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie unschwer zu erkennen bekomme ich einfach keine Verbindung zum Board. 
Kabel für ISP6Pin steckt auf SPROG3 und RS232 CTRL ist angeschlossen 
(1:1)
Ich verwende AVR Studio 4 oder 3.56 ich komme nicht mehr weiter und bin 
für jede hilfe dankbar!

Autor: Willi Wacker (williwacker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht liegts am PC: Was verwendest Du denn? Eine "richtige" RS232 
oder einen USB-Serial-Adapter oder eine PCMCIA-Karte (oder so ähnlich). 
Vielleicht ein Pegel-Problem? Richtig Konfiguriert, auch im BIOS? 
USB-Serial-Adapter tut?

Ich hatte mit meinem PC (ein in die Jahre gekommenes Notebook ohne 
"richtige" RS232) mehr Probleme als mit dem Board. Ich musste mir 2 
USB-Serial-Adapter kaufen, da der erste nicht "tat" (nicht so schlimm, 
die gibt es auch Online. Bei media markt und konsorten kostete einer 
40EUR, Online habe ich für 20EUR 2 verschiedene bekommen).

Möge es helfen
Willi Wacker

Autor: Verzweifelt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohje war das ein Kampf! Ich bekam einfach keine Verbindung mit meinem 
Board. Nach langem Testen kam ich auf die Idee mal in den Programmier 
modus zu gehen um zu sehen ob er dort erkannt wird - Fehlanzeige!
Nach zwei stunden melssen usw. konnt ich sagen das der verbaute MAX202 
defekt war. Ausgetauscht - Firmware update machen und tada es geht - so 
ein nerv!

Autor: littlecb (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
war dein STK500 neu?
ich habe nämlich ähnliches Problem. Komme aber nicht weiter. Habe mir 
das STK gekauft ausgepackt und wollte loslegen. Aber das AVR-STudio 
kommuniziert nichtmal mit dem Board. Hab schon alles mögliche probiert. 
COM-Port umgestellt hat nichts gebracht. Auch den OSCSEL-JMP hab ich 
umgesteckt .. nix.
Klar ist aber, dass der COM1 funktioniert, weil ich vorher und nach dem 
STK500 nochmal mein Evertool-Light daran betreibe.
Leider habe ich keine Möglichkeit @home die Kommunikation am MAX202 zu 
kontrollieren ob es das gleiche Prob ist wie bei dir.
Mist neu gekauft, voller freude ans werk und gestoppt, noch bevor man 
loslegt. So hab ich mir das nciht vorgestellt.


Achso ... verwenden tu ich:

Notebook mit integrierter COM-Schittstelle
Windows 2000
AVR Studio 3.56
STK wie es aus der Schachtel kam

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im AVR-Studio unter Tools, Program AVR, Connect (oder direkt bein 
Con-icon)
"STK500 or AVRISP" und die  Com-Scnittstelle ausgewählt??
Die Com-Geschwindigkeit darf höchstens 1/4 der Taktrate sein, am besten 
erst mal auf Minimum stellen.

Autor: Willi Wacker (williwacker)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Im Wesentlichen hatte das STK500 bei mir getan. Mein Notebook hat 
allerdings keine "richtige" RS232 mehr, ich habe einen PCMCIA-Adapter, 
damit funktioniert es und 2 (ZWEI) USB-RS232-Adapter, von denen läuft 
nur einer. Aber: Alle laufen mit unterschiedlichen maximalen 
Geschwindigkeiten, die allerdings alle ausreichend hoch sind (>100k oder 
so).

Ansonsten der Große Sonntax-Check:

STK500 hat Spannung (bei mir läuft es mit 11V), beim Einschalten 
leuchtet die rote LED in der Nähe des Spannungsversorgungssteckers und 
eine LED in der Mitte wechselt ihre Farbe (ich glaube von gelb auf grün, 
bin aber nicht so sicher).

Alles richtig verkabelt ?

Pins stimmen (RXD und TXD) ?

Möge es helfen

Ciao
Willi

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS:Um Missverständnisse zu vermeiden, ich habe mich falsch ausgedrückt, 
mit Com-Schnittstelle meinte ich die Verbindung vom STK500 zum AVR-MC , 
die mit maximal 25% des Prozessortakts laufen darf.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.