www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik VS1002&rauschen


Autor: Geppetto (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schönen guten Tag, liebe Forummitglieder.
Ich habe mir in meiner Werkstatt ein kleines MP3-modul geschnitzt, 
mittels einem Atmega32, SD-card , GLCD und einem VS1002.
Funzt auch alles toll. Allerdings gibt der VS1002, ein Rauschen und ein 
leises Pfeiffen von sich, welches am Anfang und Ende eines Liedes hörbar 
wird; oder wenn man die Lautstärke vermindert.

im anhang hab ich mal versucht ein kleines schaltbild aufzustellen.
achso das VS1002-modul ist von Futurelec!!!

vielleicht könnt ihr mir ja helfen.
lieben gruss, Geppetto xD.


Autor: albi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo. Als ich meinen Mp3-Plaver baute hatte ich gie gleichen Probleme - 
auch wenn ich einen VS1003 genommen hab.
Die Probleme habe ich nicht richtig beheben können. Mir half dann die 
Idee, dass ich einen zusätzlichen Kopfhörerverstärer anschließen 
könnte(LM4811), der insich selber eine digital regelbare 
Lautstärkeregelung hat.
Die Lautstärke regelung sah dann so aus, dass ich den VS immer so laut 
wie möglich hatte und den Verstärker geregelt habe - damit war der 
Fremdspannungsabstand angehem klein.

Das Problem des VS-Chips ist, so sagt es der Support, dass das Design 
nicht auf große Dynamik ausgelegt ist.

Ein sehr großen Vorteil hat mir eine Verbesserung der Masse-Versorgung 
gebracht. Ich hatte die Masse Spaßpenhalber mal direkt am VS-Chip 
angelegt und nicht irgendwo auf der PLatine - damit war ein Großteil des 
Digitalen Störens weg.
Außerdem hab ich immer und überall, wos ging SMD-Kondensatoren direkt an 
den Chip rangehauen.

Ich hab jetzt einen zufriedenstellenden Klang.

MFG

PS: Vom Supprt kam noch der Hinweis, dass man den Aufnahme-ADC 
abstellen sollte, wenn  er nicht benötiogt wird. Das spart nicht nur 
Strom, sondern auch Störsignale, da dann nix von außen einstreut.
Die GIO-Pins sollten alle auf Masse liegen.
Es findet sich so manche gute Idee in den ApplicationNotes, die VS zur 
verfügung stellt.

Autor: Geppetto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

@albi: deinen thread kenne ich und der iss schon nen bissl älter.
       das du die probleme nit wirklichin den griff bekommen hast,
       ermutigt mich ja nit gerade!

versuche gerade das platinen-layout von futurelec(VS1002) zu ändern. 
habe nun alle massen getrennt und ne 2te versorgungsspannung für den 
analog teil reingepuzzelt. ein paar kondensatoren a 100nF ebenfalls.

mir ist aufgefallen, das nun das rauschen und pfeiffen ein bissl stärker 
geworden ist, durch zuschalten der 2ten versorgung. hmmmmmmm
kanns vielleicht auch an der versorgung liegen das ich da nen paar 
spülchen noch reinkloppen sollte, und oder tiefpässe in NF-ausgang, 
sowie versorgungspannung-eingang??????

gruss und thx im voraus an alle,

Autor: Geppetto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
keiner ne idee woran es liegen könnte oder verbesserungsvorschläge zur 
schaltung???

gruss

Autor: Rooney Bob (rooney)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte nie Probleme... das liegt wohl an meinem perfekten Layout 
hehe
Ich weiß du verwendest ein Modul, da kannst nachträglich nicht viel 
ändern, aber vielleicht entwickelst du mal selbst eines, dann würde ich 
auf folgendes achten:

Massen müssen natürlich getrennt geführt werden und dürfen nur an einer 
Stelle miteinander verbunden werden. Am besten wäre das direkt unterm 
Chip.

Achte darauf dass du keine Masseschleifen hast.

Digitale Leitungen nie durch den analogen Sektor routen.

Stützkondensatoren an JEDEM Versorgungspin. So nah wie möglich am Pin 
versteht sich ohnehin von selbst... An AVDD ist kein Stützkondensator, 
sowas würd ich mich nicht verkaufen trauen.

Verwende separate Linearregler für digitale und analoge Versorgung. Bei 
der digitalen Versorgung würd ich vor und nach dem Regler zumindest 
einen Ferrit vorsehen. Bei der analogen Versorgung würde ich eher an 
eine Filterschaltung mit "ordentlichen" Spulen denken. Muss nix 
kompliziertes werden, CLC Glied und fertig.

Wenn du mehrere Layer zur Verfügung hast, würde ich zumindest die Massen 
großflächig ausführen.

ADC abdrehen wurde bereits erwähnt, ist auf jeden Fall empfehlenswert.

Kondensatoren im analogen Ausgangspfad würde auch Sinn machen.

Zuletzt wahrscheinlich das WICHTIGSTE: Verwende eine VS1003

Autor: Geppetto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallöchen,
dann werde ich mich wohl mal nachher daran machen mein platinchen zu 
zerflücken und was ordentliches daraus zu machen.
werde die von euch oben benannten tips beherzigen.

eine frage nur noch im datenblatt steht ADC-addresse ist 0xC01E und 
ausstellen ist 0x8000.
im thread vom albi sprach ein angestellter von VLSI von 0x0000 zum 
ausschalten, das ist doch falsch oder???

gruss

Autor: Geppetto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ohhhaaaa,
nach dem totalen zerpflügen der platine und unter berücksichtigung der 
tips von euch oben, habe ich schon mal ein besseres ergebnis erzielt.

das pfeiffen scheint fast gänzlich verschwunden zu sein, lediglich ein 
bissl rauschen ist noch da!!!

naja nachdem meine platine jetzt sowieso schon total zerpflügt ist und 
eher einem drahtgepflecht gleicht, werde ich weiter experementieren und 
euch meine ergebnisse darlegen, sobald ich auch das letzte rauschen im 
griff habe.

@albi: vielleicht schaffen wir es auch zusammen das rauschen zu 
kontrollieren.


NAJA auf jeden Fall kauft nie, Ich betone niemals die MP3-platine von 
FUTURELEC!!!!!!!!!!
da erspart ihr euch jede menge ärger!!!

gruss geppetto

Autor: albi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich habe das Digitale Pfeifen wegbekommen -fast - also ähnlich wie 
du.
Größten Problem macht bei mir das Händidiplay obendrüber - die 
LED-Beleuchtung hat auf der Adapterplatine eine Spule, die hässliche 
Geräusche macht. Sobald das Licht aus ist, ist aber nahezu ruhe...
naja und der Rest macht der Kopfhörerverstärker.

Ich bin mit meiner SoundQualität hochzufrieden. Nur wenn ich es richtig 
laut mache und grade das klied eine stille Stelle hat, höre ich etwas 
pfeifen - aber mal ehrlich - stören tut mich das nicht.
Beim Einschlafen hört man eh nicht volles Rohr. Und das war das einzige, 
wo mich die Nebengeräusche wirklich gestört haben.

Autor: Geppetto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
juhhuu,
da war reichelt aber schnell, habe den und nen paar spülchen bestellt 
für die versorgungen des VLSI. und nen paar andere bauteile ...........
mal schaun wie es über die sachen klingen tut.

@albi: falls ich es trotzdem schaffen sollte es gänzlich wegzukriegen, 
sage ich hier nochmal bescheid!!!

eigentlich sollte ich dann mein layout an FUTURELEC anbieten, damit die 
nit mehr so nen mist verkaufen. geht ja gar nit...........



THX und gruss an alle THREAD-beteiligten, geppetto.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.