www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bewegungsmelder (spinnt?)


Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe ich bin hier richtig, es geht eher um Gröberes:

An einen billigen pyro-Bewegungsmelder sind einige LEDs per kleinen 
Trafo (<0.5 VA) angeschlossen.
Der Bewegungsmelder ist aus seinem Gehäuse entfernt worden, die 
Fresnel-Linse wieder ähnlich montiert, das Gehäuse teils offen.
Es gibt eine zweite Linsenreihe, die jetzt in Höhe des LDRs ist 
(korrekt?).

Leider ist das Verhalten unvorhersehbar, allerdings scheint es mit dem 
Regler für die Helligkeit zusammenzuhängen. Jetzt ist er immer 
eingeschaltet, bei einer anderen Stellung hat er periodisch mit ca. 
30-60s gewechselt.

Auch im augeschalteten Zustand liegt anscheinend eine Spannung über dem 
Schaltausgang (Größenordnung 115V), es reicht, um die LEDs schwach zum 
Leuchten zu bringen.
Das finde ich allerdings sehr erstaunlich, da ja mit Relais geschaltet 
wird..aber anscheinend nur der Nulleiter. Das hieße, daß die Dinger ohne 
angeschlossene Last gar nicht funktionieren dürften.

Ich habe aber nichts davon gelesen, daß nur bestimmte Lastarten 
vorgesehen sind.

Kann man die Dinger eigentlich kaputtmachen, wenn man sie falschherum 
anschließt?

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Carl,

ich kann leider nur gefährliches Halbwissen
beisteuern:

ich hatte auch mal versucht, einen 12V - Sensor
ohne Gehäuse zu betreiben und der schaltete
dann auch, wie er lustig war.

Bei einem Baumarkt-Halogenstrahler mit Bewegungsmelder
war die Einstellung sowohl der Nachleuchtdauer
als auch des Helligkeitswertes ein Glücksspiel:

Die Zeit schwankte zwischen 1s an, 30s an und immer an...

Gruß Otto

Autor: Currywurst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In solchen Geräten sind normalerweise nur Kondensatornetzteile verbaut. 
Also dürfte die ganze Elektronik Netzspannung führen.  Pass also auf 
deine Finger auf.

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist richtig, die Elektronik ist auf Netzpotential.
Ich habe ein paar Hinweise auf 'Leckströme' gefunden, die durch den 
Verbraucher fließen. Mehr leider nicht.
Ich frage mich nur, was das für einen Sinn haben sollte, daß sich die 
Schaltung über den Verbraucher ernährt.

Der PIR ist übrigens an L & N angeschlossen, der Verbraucher an N und 
den Melder.

Leider ist das Relais etwas schwer zugänglich, sonst würde ich die 
Schaltung an der Stelle mal näher untersuchen.

Oder mal den Trafo ablöten und gucken was passiert.. Mhh.

Autor: Currywurst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du sicher das da ein Trafo drin ist?
Die Schaltung im Gerät ist analog und ziemlich hochohmig um wenig Strom 
zu verbrauchen. Da muss es einen nicht wundern wenn die ziemlich 
empfindlich für Störfelder ist.
Wenn du weißt wo kannst du die Schaltung über einen Vorwiderstand an 24 
Volt DC anschließen und in Ruhe untersuchen.
Ich kriege ständig defekte PIR Melder aus dem Bekannten- und 
Verwandten-kreis. Wobei ich immer zum Neukauf Rate und die Techno-Leiche 
fleddere. Keins von den untersuchten Geräten hatte einen Trafo zur 
Netztrennung. Deines wär das erste von dem ich erfahre.

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das Relais schaltet beim Einschalten der Versorgungsspannung an, 
auch ohne Verbraucher.

Jetzt schaltet er zwar auch wieder aus, einige Sekunden später aber 
wieder an.

Autor: Currywurst (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal ist es ja ganz normal wenn der Melder beim einschalten das 
Relais anziehen lässt. Das ist ja dazu gedacht den Melder in reihe mit 
einem normalen Schalter als einfachen Zeitautomat zu betreiben.
Hast du denn die Wärmesensoren sauber abgedeckt?
Wenn nicht reagiert die Schaltung ja auf die kleinste Änderung in der 
Umgebung. z.B. auf die Wärmewolke die du bei jedem Atem abgibst oder 
sonstwas.

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, Mistverständnis, ich meinte den Trafo der Last..

Ich hab's noch nicht geschafft, das Ding mit meiner Handwärme zum 
Schalten zu bewegen. Ist aber gerade auch immer an.
Ich dreh noch mal am Poti für die Helligkeit..

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich den PIR komplett abdecke, bleibt er größtenteils aus..aber der 
Verbraucher bekommt trotzdem Strom.

Dann muss ich nochmal nachmessen, was das Relais eigenlich schaltet..

Ist übrigends von Bahr:

http://www.lexing.com/instructions/LX39(E).htm

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es sieht so aus als ob parallel zum Relais (Phase->Last) eine R-C Serie 
geschaltet ist. Vielleicht 100 Ohm, könnte aber auch braun blau*3 braun 
sein also 166MOhm klingt wahrscheinlicher. C ist 0.022µF.

Ist das zum Schützen der Relaiskontakte?

Autor: Christoph Kessler (db1uq) (christoph_kessler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"snubber"-Schaltung heißt sowas, die 100 Ohm sind eher richtig

Autor: Christoph Kessler (db1uq) (christoph_kessler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Erklärung.
Also zusätzlich zum Verbrauch des Sensors fließt immer ein Strom durch 
die Last. Das ist ja nicht so schön.
In meinem Fall leuchten die LEDs dann die ganze Zeit, wenn auch mit 
kleinem Strom.

Kann man das auch anders lösen, oder bleibt nur die Möglichkeit, die 
Schutzschaltung speziell für die Last zu dimensionieren, und den 
Leckstrom dadurch zu minimieren?

Ich hatte auch mal daran gedacht, die LEDs direkt anstelle des 
24V-Relais zu betreiben, aber mangels Wissen kann ich nicht sagen ob die 
Stromversorgung des Sensors das schaffen würde (20mA, 16V).

Autor: Carl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://en.wikipedia.org/wiki/Snubber :

"A snubber is a simple electrical circuit used to suppress ("snub") 
electrical transients."

http://dict.leo.org/ende?lp=ende&search=snub

besser:

http://www.m-w.com/dictionary/snub

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.