www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Wieviel Strom bezieht ein Display um den Kontrast aufzubauen


Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
Folgendes Problem:

Display ( 2x 16 Zeichen Dotmatrix) ist an Port C des ATMega 16 
angeschloßen.
Spannung wollen wir vom AVR beziehen. Ein Pin liefert 40 mA.
Das Display benötigt für die Logik etwa 2 mA. Hintergrundbeleuchtung ist 
nicht angeschloßen. Kann ich nun die VCC Leitung an einen Port-Pin 
anschließen, oder  MUSS ich einen Transistor vorschalten? Ich weiß 
nämlich nicht, wie viel Strom für den Aufbau des Kontrast benötigt wird 
(steht nicht im Datenblatt). Dispay ist von Reichelt. Denn 
I_maxController = 40 mA - I_LogikDisplay ... da bleiben ja immernoch ca. 
38 mA. Reicht das für den Kontrast?

Autor: jemand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
38mA für den Kontrast? Wenn du nicht grad irgendwas beheizen willst...
Wobei ich sagor nur  max ca 5mA schätzen würde. Wieso misst dus nicht 
einfach mal nach? Dann weisst du danach, wieviel du brauchst, und ob 
dein µC das schafft.

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je nach LCD sind Spannungsteiler mit einigen 100Ohm, oder einigen kOhm 
verbaut.
Ich würde bei neueren LCDs etwa 1mA oder weniger schätzen.
Es sollte also funktionieren.

Autor: Timo (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm komisch. Habe ich eben gemacht. Dass denn wohl doch nicht mein 
Problem bei der Schaltung. Messe mittlerweile ganze 10V, bis das Display 
richtig initialisiert. Komisch. Ob dass am Festspannungsregler liegt. 
Benutze ein 7805. Als Eingangsspannung 16 V DC. Irgendwie sind die Werte 
sehr komisch. Kann ja mal den Schaltplan anhängen.

Autor: Hallo2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau da mal nach.
http://de.wikipedia.org/wiki/Spannungsregler
Bau deinen Regler mal richtig auf.
90% der Fehler sind Betriebsspg.Fehler.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was sind denn die restlichen 10% der fehler? Den Spannungsregler habe 
ich doch so wie bei wiki aufgebaut. Input 16 V rein (Im datenblatt 
steht, dass ich bis zu 38 V kann) und 5 V raus. Kondensator zur dämpfung 
fertig. Was denn der Fehler?

Autor: Hallo2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
100n + min. 100µ Elko am Eingang fehlen.
1µ am Ausgang fehlt.

Evtl. schwingt dein Regler.


Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das denke ich NICHT. Ich gebe zu Testzwecken 16 V Gleichspannung aus 
einem sehr guten Labornetzteil rein. (Also Input). Das muss ich doch 
nicht glätten.

Autor: Hallo2 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja dann lerne erst einmal Elektrotechnik bevor du sowas machst.
Lies dir mal ein Datenblatt zu einem Festspgregler durch was dort über 
den
Gebrauch von Eingangselkos steht, und dann melde dich wieder.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

du schreibst: Messe mittlerweile ganze 10V, bis das Display
richtig initialisiert.

Wo misst Du 10V?

Wo ist auf der Schaltung eigentlich das Display?

Außerdem erfordert es eine ziemliche umgewöhnung, daß bei Dir GND oben 
und Ub unten im Schaltpaln ist.

Das ist zumindest sehr ungebräuchlich.

Zum Regler wurde schon was geschrieben, zusätzlich noch: 16V in - 5V out 
sind 11V Spannungsdifferenz am Regler. Da ist schon bei 100mA (1,1W 
Verlustleistung am 7805) ein Kühlblech fällig.

Gruß aus Berlin
Michael

Autor: Null (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
100nF am Quartz ? Wow. Und der Triac wird mit einem Triac gesteuert ... 
Sehr interessant. Das kann noch dauern bis das laeuft.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Null: Falsches Thema?

Autor: Null (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, stimmt. Sorry, I haette nicht vorgreifen sollen. Diese Themen waeren 
auf Juni und Juli geplant gewesen. Zuerst brauchen wir den richtigen 
Schaltplan, mit dem Display drauf.

Autor: Null (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PortC sollte zwar gehen, aber einen GND ist sollte man auch nehmen 
fuer's Display.

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...und nicht vergessen, das JTAG abzuschalten. Sonst wird das nix mit 
Port C.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Schaltplan ist einfach nur um 180° verdreht. Dreht man Ihn, so liegt 
VCC oben und GND unten ;). Und die Schaltung mit dem Optokoppler ist 
korrekt. Der Triac wird durchgeschaltet. Das doch richtig. Die 100 nF 
sind ein Tipfehler. Sind 22 pF.
Das Display hängt an Port C.

Folgende Belegung:

PC0 - PC3:     DATA 0 - DATA 3 (4-Bit-Mode)
PC4      :     E(nable)
PC5      :     RS
PC6      :     VCC (also "High")

PD7      :     GND



R/W ist fest auf einen Pegel gesetzt, da nur geschrieben werden soll. 
Das mit dem Display sollte klappen. Der Port-Pin PC6 sollte genügend 
"Strom zur Verfügung stellen". ;)

Okay mit dem Spannungregler, dass sehe ich ein , dass ist "Bockmisst". 
Ich dachte jedoch immer, dass die Kondensatoren nur zur Glättung des 
Eingangs bzw. AUsgangssingnales da wären. Fehler kann jeder machen. Also 
liegt der Hauptfehler wohl echt bei der Spannungsversorgung. Werde den 
Regler einmal auslöten und dass ganze mit 5 V Gleichspannung von 
Netzteil bezogen versorgen.

Was habt ihr denn an der Schaltung rund um den Optokoppler auszusetzen? 
Schalte damit 230 V AC. Auf Abstände und dimensinierung ist geachtet.

Gruß Timo

Autor: Andreas K. (oldcoolman)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hätte da nix auszusetzen. Die Schaltung müßte so stimmen.
@ Null. Klar ist das interessant. der moc macht nur 100mA und wenn es 
mehr sein soll schlte man einen triac nach.
Ich vermute dein Regler ist futsch.
Die c s sind zur schwingneigungsdämpfung.

viel Erfolg.

Autor: Timo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke. Schaue es mir morgen ma auf dem Oska alles an. Also mit dem 
Regler ;)

Cu

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.