www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Probleme mit MOSFET Gate-Driver


Autor: René (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alle,

ich habe Probleme mit meiner MOSFET Endstufe. Ich will einfach nur einen 
DC-Motor antreiben und bremsen. Der Motor zieht maximal 5 A beim 
Anlaufen. Die Mosfets können ca. 60 A vertragen, daran liegt es schonmal 
nicht. Ich verwende einen standard Gate-Driver z.B. FAN7380 von 
Fairchild (www.fairchildsemi.com). Ich habe das Problem dass sich meine 
Endstufe selbst zerstört. Obwohl der Baustein eine 
"Shoot-Trough-Prevention" hat, kommt es irgendwie manchmal zu kurzen 
Stromdurchschüssen in den Endstufen-FETs. Woran kann das liegen? Hat 
Jemand eine Idee? Das ist auch schon einmal ohne eine Last passiert. Die 
hohe VB Spannung für den Gate-Driver erzeuge ich mir mit einem ICL7662. 
Der stellt mir dann ca. 24 V zur Verfügung. Der Fehler sieht dann immer 
wie folgt aus. Wenn die Endstufe nach wenigen Minuten den Geist 
aufgegeben hat, stellt man fest dass der ICL7662 sehr heiss ist. Wenn 
man dann mal nachmisst stellt man fest, dass es den Gate-Driver 
irgendwie zerrissen hat und er jetzt 100 mA aus dem ICL in sein VB Pin 
zieht. Scheinbar  gibt es einen Betreibszustand (negative 
Spannungsspitze) der meinem Gate-Driver den Gar ausmacht. Naja, 
vielleicht hat ja jemand von euch eine Idee.

Danke im Voraus

René

Autor: Ingo Elsen (ogni42)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du solltest den Motor entstören.

Autor: René (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Ingo,

die Motoren haben alle einen Entstörkondensator verbaut.

Danke

René

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist doch klar:
Wenn der untere Mosfet an war, liegen am Source vom oberen 0V an. Dann 
haust du 24V ins Gate. Ich wette der Mosfet verkraftet maximal +/-20V 
Gate-Source. Der schlägt durch, und dann fließen die 100mA.

Weiterhin ist es bei hohen Frequenzen sinnvoll, eine Diode parallel zu 
dem Gatewiderstand zu legen, damit die Gates schneller entladen werden.

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vergiß den ICL7662.
Nimm eine schnelle Diode von den +15V an den VB-Anschluß, den Du mit 
einem schnellen Kondensator (Tantal, 2uF 36V) gegen Masse entkoppelst.

Evtl. mußt Du mal das Datenblatt von dem MOSFET-Treiber lesen oder mal 
das vom IR2101 (IRF).

Am Eingang den Treibers gibt es auch einen ELKO, der etwas Ladung zum 
Schlaten hält ?

Autor: Jack Braun (jackbraun)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nimm eine schnelle Diode von den +15V an den VB-Anschluß, den Du mit
>einem schnellen Kondensator (Tantal, 2uF 36V) gegen Masse entkoppelst.

Schnelle Dioden kannte ich schon, aber schnelle Kondensatoren sind mir
neu ;-)

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Ich kenne jetzt deinen Treiber nicht, aber 24V Vcc & 15V VB sind 
zulässig?
VS darf welche max-Werte annehmen?
24V am Gate von K8 sind zwar recht hoch, sollten aber nicht unbedingt 
zum Tod des Treibers führen. Die Freilaufdioden sind intern oder extern?
Du kannst die Abschaltenergie auch in vollem Umfang zurückspeisen(dicker 
ELKO)?- nicht das VS höher als Vcc wird...

Wie auch immer, viel Erfolg, Uwe

Autor: Stephan (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
schließe mich Benedikt an. 24V Vgs ist zu heftig !!
Da wirds wohl den FET regelmäßig exen.
Nimm die 15V die eh schon da sind. Die reichen dicke aus.
Bei 12V Vgs ist so ziemlich jeder FET voll auf.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Habe gerade mal das Datenblatt studiert un da lese ich:
"High side floating supply voltage VB VS+10 - VS+20"
VS+20V ist dabei der Maxwert. wenn dein LowSide durchschaltet ist VS auf 
0V
und VB bei 24V! Hast du deinen ICL nicht von VB entkoppelt(Diode) 
bleiben auch für den HighSide nur 24-15V=9V. Das reicht zwar, aber VSmin 
ist mit VS+10 angegeben, also hart an der Grenze. Kurzum du hast das 
Ding einfach falsch beschaltet.
Die Lösung hat dir Bernd Rüter aber schon aufgezeigt, einen Tantal würde 
ich allerdings nicht nehmen.

Viel Erfolg, Uwe

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.