www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK 500 spinnt !


Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

bis vor 10 Minuten hat meine STK 500 noch funktioniert. Nun spinnt das 
Ding total rum. Ich hoffe ich kann den Fehler jetzt gut beschreiben.

Also:

Ich habe einen ATMEGA8 auf meinem Board. Hatte in den Fuse Bits den 
externen Taktquelle angegeben, weil ich an der zweiten RS-232 einen 
Empfänger dranhabe. Plötzlich wollte die STK 500 ein downgrade machen. 
Das habe ich ausgeführt. Seitdem geht nichts mehr. Soll heissen:

- ich verbinde zur STK 500
- Der STK 500 Oszillator liest plötzlich statt 3.86 MHz nur noch 58 kHz.
- In den Fuse Bits stellt er sich automatisch auf den Externen Cristal 
/osz (1111).
- Stell ich wieder auf 0000 kommt "Get Revisions...Failed"
- Signature kann auch nicht ausgelesen werden

Ich werd mit dem Ding noch wahnsinnig. Habe absolut nichts verstellt und 
warum er das Downgrade jetzt plötzlich wollte versteh ich auch nicht.

Kann ich irgendwie reseten oder weiss jemand wie ich aus dem Schlamassel 
wieder rauskomme ?

Grüsse
Matthias

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS:

Hatte die FuseBits gestern eingestellt und hat alles super geklappt. 
Also stummgelegt dürfte ich den uC nicht haben.

Grüsse
Matthias

Autor: STK500-Besitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ich habe einen ATMEGA8 auf meinem Board. Hatte in den Fuse Bits den
>externen Taktquelle angegeben, weil ich an der zweiten RS-232 einen
>Empfänger dranhabe.
Komische Begründung, aber egal... (vermutlich brauchst du die 
baudratenkompatible Taktfrequenz des STK500)

Hast du mal alles an Kabeln abgezogen, was man abziehen kann?
Dann noch mal ins Konfiguartionsmenu des STK500 gehen und nachgucken, ob 
du die Spannungen und Takte einstellen kannst (und diese auch 
eingestellt bleiben).
Sieht mir nämlich irgendwie nach einem Kurzschluß aus.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Firmwareupgrade des STK kann auch helfen: PROGRAM-Taste drücken und
danach einschalten.  Dann mit avrprog.exe die Firmware neu flashen
(die heißt stk500.ebn).

Autor: STK500-BEsitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>PROGRAM-Taste drücken und danach einschalten.
Gleichzeitiges Drücken und Einschalten...

Autor: Matthias (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was tät ich nur wenn Jörg nich wär. ;:-)
Hab das Update jetzt nochmal draufgespielt. Per avrprog.exe gehts bei 
mir nicht aber in dem STK 500 Ordner gibts ne upgrade.exe die das 
übernimmt. So wie es jetzt aussieht, geht es wieder. Wahrscheinlich 
kommt sowas öfters mal bei Updates vor, oder. Ich sag auf jeden Fall mal 
wieder herzlichen Dank.

Grüsse
Matthias

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.