www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ponyprog und co.


Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

Habe ein Atmel Evaluations-Board 2.0 mit einem Atmega8 drauf.
Nun habe ich folgendes Problem: "Wie finde ich mein board?"
Ponyprog erkennt es nicht...ich habe ein USB to Seriel Kabel benutzt,
da ich mit einem notebook arbeite.
Ich habe dann gelesen das es da zu komplikationen mit USB und Ponyprog 
geben
könnte.
Danch lud ich avr-studio, mit dem es auch gehen soll, dummerweise kann 
ich
es nicht insterlieren (es kommt immer ein fehler)...aber nicht nur 
avr-studio
bereitete Probleme. Viele meiner Programme funtionieren nicht mehr, 
hängen
sich nach ner gewissen zeit auf und es startet der debugger in vc++.

ich hab keine ahnung was ich machen soll, es frustriert alles doch ein 
bisschen...im internet konnte ich leider nichts finden was mir helfen 
würde.

Also hat jmd. ähnliches erlebt mit seinem board...wenn nicht woran könnt 
es liegen das Ponyprog mein board nicht erkennt und mit welchem Programm 
läßt sich das board noch erkennen?

Ich weiß, die Anfängerfragen nerven, doch ich bin echt scho am 
verzweifeln
zumal viele programme jetz beschädigt oder nicht funzn seitem ich das 
board
habe.
Und darum wäre ich sehr dankbar wenn jmd. paar tips geben könnt.

Autor: Hubert.G (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bist du dir sicher das du keinen Virus auf deinem Notebook hast? Oder 
sonst einen Systemfehler, denn wenn andere Programme auch spinnen deutet 
das doch auf so was hin.
Hubert

Autor: Alex (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die ganzen fehler sind erst mit dem einsatz des boards gekommen.
Habe jetz keine Ahnung ob nach der Instalation des USB to Seriel 
Treibers (denn da stand scho irgendwas von "Microsoft test nicht 
bestanden " oder "nicht kompatibel zu windows xp") oder nach 
intstalation von Ponyprog.
Habe das ganze beim Kollegen versucht übe seriel...also ganz normal.
Hab auf sein pc ponyprog geladen...ponyprog konnte das board nicht 
erkennen.
Habe dann avr-studio auf sein pc gezogen und das selbe problem wie bei 
mir... man konnte avr-studio nicht instalieren und zu dem ist uns 
aufgefallen das sein pc langsamer wurde.

Autor: Rema Andante (rema-andante)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Alex,

habe mein Pollin an einem XP-Rechner über ein ganz normales serielles 
Kabel an COM1 angeschlossen. Klappt.

Habe mir heute ein SP12 Programmer ala Rowalt gebaut und an die 
parallele Schnittstelle angeschlossen. Klappt.

Kann nun mit Bascom proggen.

MFG
rema

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die einfachen Bitwackel-Adapter (wie SP12) kannst du hinter einem
USB<->RS-232-Wandler vergessen.  Wenn sie denn überhaupt gehen,
brauchst du für ein Kilobyte an Code eine halbe Stunde.

Autor: Holger Krull (krulli) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schade, jede Woche das selbe Thema... ;)
[textbaustein]
1. Ist das Board nicht von Atmel sondern von Pollin
2. Funktioniert das Board nicht mit einem USB Adapter, sondern nur mit 
einer "echten" seriellen Schnittstelle
[/textbaustein]

Autor: Bitwackler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also auch mit Pony und USB2Seriell-Wandler hatte ich einen Mega8 in 
10-15 Sekunden programmiert. Evalboards habe ich nie verwendet - hier 
habe ich prima Erfahungen mit den Boards von Holger Klabunde gemacht.

Inzwischen habe ich mir den USBisp von www.matwei.de zusammengenagelt 
und der schaffts dann in 2-3 sekunden - einfach - einfach ein klasse 
Teil!

Autor: Markus L. (lucky79)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Habe dann avr-studio auf sein pc gezogen und das selbe problem wie bei
> mir... man konnte avr-studio nicht instalieren und zu dem ist uns
> aufgefallen das sein pc langsamer wurde.

Wie hat du das denn auf seinen PC gezogen ?
USB-Stick, LAN,...?

Woher hast du das AVR-Studio? direkt von Atmel oder von so einem P2P?

Also ich hatte mal einen USB-Serial Adapter von Belkin, dieser sch*** 
Treiber hat mir das komplette XP zusammengedroschen!
Arbeite mittlerweile auch mit dem USBisp von www.matwei.de am Laptop. Am 
StandPC arbeite ich mit PonyProg und einem stinknormalen Parport Adapter 
mit 3State Buffer (74HC125)... funktioniert alles einwandfrei und ohne 
Einbußen!

lg
Markus

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.