www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik 3.3V Spannungsversorgung


Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich benötige eine Stabile 3.3V Spannungsversorgung für einen PIC.

Die eingangspannung liegt bei max. 14,8 V KFZ Spannung.

Geplant war erstmal eine Schaltung mit 7805 auf 5V
und dann mit einem LT1584- CT3.3 auf die 3.3V.

Leider ist der erste versuch im Auto gescheitert und das ding hat 
geraucht.

Hat Jemmand eine bessere Lösung oder eine Idee wie das zu Lösen wäre.


Über einen funktionierenden Schaltplan würde ich mich mega freuen.

Ich Danke für eure mühe schon im voraus.

Autor: Quake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vorher das Datenblatt lesen. Lesen Bildet.

Autor: zero_gravity (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie wärs mit nem 7812 + den ganzen filterkram, den man im auto so haben 
muss, und hintenhinter hängste nen 12V/3,3V - dc/dc - konverter :)

lg
zero_gravity

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.23

@zero_gavity: 7812 benötigt Input >= 14V, das liefert das KFZ-Bordnetz 
nicht.

Autor: Michael U. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

@Mathias R.: wann hat wer geraucht?

Fehlerbeschreibungen sind doch was schönes...

Ohne zu hohe Last und mit stehendem Motor hat da erstmal nichts zu 
rauchen.
Wenn es bei laufendem Motor geraucht hat -> Beschaltung gegen 
Spannungsspitzen usw. vor dem 7805 hat gefehlt oder stimmte nicht.
Wenn es gleich geraucht hat -> Fehler in der Schaltung.

Schaltung und verständliche Fehlerbeschreibung könnten da durchaus 
weiterhelfen.

Gruß aus Berlin
Michael

Autor: Quake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum macht einer eigendlich sowas mit 2 Spannungsregler?

Autor: Quake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist ein 7A-Regler nit total oversized?

Autor: Mathias R. (neo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für eure schnellen Antworten.

Zu den Fragen:

Auto stand Motor aus Zündung an        = alles OK
Motor anlassen                         = Spannungsschwankung
Fahren (Lima voll Leistung ca 14,8 V   = Rauch (Defekt)

Hab mal die Schaltung als Bild angehängt.

Hat wer eine Idee. Ich verzweifel langsam.

Vielen Dank im voraus.

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was genau hat denn geraucht?
Eigentlich ist die Schaltung okay!
Die Frage ist natürlich wozu Du einen 7A-Regler hinter einen 
100mA-Regler schaltest? Braucht Deine Schaltung vielleicht mehr als 
100mA?

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also da das ganze in einem Alu Gehäuse steckt konnte ich das nicht genau 
sehen.
Ich vermute aber anhand der Platine das es der 7805 war da dort eine 
dunkle Färbung vorhanden ist.

Glück war anscheinend nur das der PIC nichts abbekommen hat.

Hab die Schaltung nun auch schon einigemale hin und her überlegt aber 
ich erkennen nicht was das verursacht haben könnte.

Sollten da vielleicht zwei kondis vor und nach den LT1584?

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alu-Gehäuse........gab es vielleicht einen Kurzschluss, das die Pins der 
Platine ans Gehäuse gekommen sind und der 78L05 die Hufe hochgemacht 
hat?
Man könnte dem LT1584 noch zwei Kondis am Ausgang spendieren, müsste 
aber auch ohne gehen. Auf keinen Fall kann das was mit der Zerstörung 
der Regler zu tun haben!

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh sorry noch falsches Bauteil im Eagle Plan.

Nein der Pic braucht soweit ich das aus dem Datenblatt entnehmen konnte
pro VCC ca 200mA bei 40Mips er hat 3 davon.

Ich habe darum einen 78S05 2A verbaut.
für die 3.3V hatte ich sonst leider nur einen 0,8A Regler gefunden und
das war mir etwas zu schwach.
Ich weiß 7A ist etwas viel.

aber im test lief der PIC gut. bis.....

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf der Lötseite der Platine ist zwischen Gehäuse und Platine extra eine
Iso Folie reingekommen.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine vermutung die ich noch habe ist das vielleicht die dioden oder 
kondis
am Eingang zu schwach sind für die im Bordnetzt eines PKW auftretenden 
Spannungsspitzen und Störungen.
Denn am Heimischen Labornetzteil lief alles ohne Störung.

Leider bin da nicht so bewandert mit der richtigen berechnung der 
größen.

Kann mir da wer helfen.

Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie lange lief die Schaltung bis sie in Rauch aufging?
Hast Du an den Reglern Kühlkörper oder kommen die Gehäuse beider Regler 
aneinander?

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nein der Pic braucht soweit ich das aus dem Datenblatt entnehmen
>konnte pro VCC ca 200mA bei 40Mips er hat 3 davon.

Sicher datt...0,6A...so ein PIC muß erst noch erfunden werden.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Gehäuse hat an der seite größzügig dimensionierte Kühlrippen.
Beide Regler sind am Gehäuse angeschraubt jedoch getrennt vom Gehäuse 
durch eine Iso Folie.

Ein Direkter Kontakt der beiden ist so Theoretisch nicht möglich.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der Pic ist ein dsPIC33FJ256GP506.

Und laut Datenblatt ist das so oder ich hab da was falsch verstanden.

Korrektur noch er hat 4x VCC

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Datenblatt Seite 313, Operating Current

74mA @ 25° @ 3,3V @ 40 MIPS

Du hast in den Absloute Maximum Ratings geguckt und die Werte dort geben 
nur wann, wann der Baustein gerade nicht kaputt geht (kurzfristig).

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mathias R. wrote:
> Nein der Pic braucht soweit ich das aus dem Datenblatt entnehmen konnte
> pro VCC ca 200mA bei 40Mips er hat 3 davon.
Das ist sicher der MAXIMAL-Strom pro VCC-Pin und NICHT die 
Stromaufnahme des µC!

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sorry war mein fehler.
Da ich ja eh neu Bauen muß zummindest die Spannungsversorgung kann das 
jetzt alles etwas kleiner Ausfallen 7805 1A für die 5V und LD-1117V 33 
für die 3.3V

Danke für die Info.

Leider erklärt das immer noch nicht die zestörung des reglers im Auto.

Autor: Quake (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wozu 2 Regler?

Autor: Dieter Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Nein der Pic braucht soweit ich das aus dem Datenblatt entnehmen
> konnte pro VCC ca 200mA bei 40Mips er hat 3 davon.

> Korrektur noch er hat 4x VCC

Das ist ein Missverständnis.
Diese Angaben beziehen sich auf die maximale Belastbarkeit, der dsPIC 
selbst benötigt bei 40 MIPS typisch 74mA (Parameter DC24 im dsPIC33F 
family data sheet DS70165D, Seite 311).

Der angegebene Strom ist übrigens die Summe von allen VCC Pins.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da ich bis jetzt für 3.3V keinen Regler gefunden habe der bis zu 15V 
eingangsspannung verträgt.
Und durch zwei Regler auch die Wärme entwicklung etwas im Rahmen bleibt.

Bin aber für jede verbesserung offen

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bau mal ne Diode vom Ausgang zum Eingang des Reglers, so wie im 
Datenblatt empfolen. Spannungsschwanken können dafür sorgen, dass die 
Eingangsspannung kleiner als die Ausgangsspannung wird und das ist für 
diese Standardregler fast immer tödlich.

Autor: Mathias R. (neo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Quassi so. siehe neues Bild

welchen werte müsste diese Diode haben.

welche andere Lösung gebe es fü diese Standart Regler

Autor: gast (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
da ich auch einiges  im auto baue ...


also gerade am eingang bau ich mir meist 1000µF hin ,
dann eine diode ( oder  spule) ,  dann nochmal einige > 100µF
in meiner letzten schaltung sind am eingang der 12V um die 8000µF drin 
...

uber sinn und unsinn sei mal dahingeredet

aber es reucht nix udn schwankt nix ...
trotz einiger endstufen und so

versuch es zumindest mit einer induktivität

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Quassi so. siehe neues Bild

Genau.

> welchen werte müsste diese Diode haben.

Ich nehme immer eine 1N400?, was halt grad da ist.




Autor: Msp 430_crew (msp430_crew)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Diode über dem 7805 ist verkehrt herum!!!

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nee sorry, die Diode natürlich andersrum. So ist sie ja permanent in 
Durchlass, das wäre schlecht :)

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also könnte ich da auch eine 1N5402 verbauen denn die hab ich gleich da.

Wäre es da besser wenn ich auch am zweiten Regler eine solche Diode 
verbaue.

Würde nämlich gern jeder weiteren räucherrunde aus dem weg gehen. Da die 
Plantinen nicht immer billig sind da ich denn PIC leider Löten lassen 
muß auf Grund seines Formates und nur den Rest selber bestücke.

Autor: EZ81__ (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Da ich bis jetzt für 3.3V keinen Regler gefunden habe der bis zu 15V
eingangsspannung verträgt.

LM317 + 2 Widerstände?

Im Autobordnetz passieren schlimme Dinge, in
http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.23 ist eine 
Beispielschutzschaltung erläutert.

Grüße

Autor: Mathias R. (neo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das sähe dann Quassi so aus.

Ich hoffe ich Nerve euch nicht.
Aber allein wird wohl sonst nie im Auto funktionieren.

Autor: hackklotz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gut, was vielleicht nervt sind die ewigen 1,4MB Bitmap für 5 Striche.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh sorry daran hab ich nicht gedacht

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also versteh ich das richtig mit einem LM317 könnte ich auf einen Regler 
verzichten und trotzdem eine stabile Spannung von 3.3V haben?

Wie ist das mit die Wiederstände gemeint?

Hast du zufällig ne Schaltung mit so nem Ding mal zum Anschauen.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wobei eine Suppressordiode mit Drossel vorweg den Zumutungen des 
Bordnetzes wohl länger standhalten wird als eine normale Z-Diode ohne 
Drossel.

Und es ist immer noch offen, wieviel Strom da eigentlich fliesst. Sowas 
kann man nicht nur aus Datasheets zusammenrechnen (fehlerträchtig) 
sondern auch messen (realistischer). Muss dabei ja nicht am Bordnetz 
hängen.

Und wenn dabei deutlich mehr als 30mA rauskommen, wird dem 78L05 gleich 
wieder so unangenehm warm ums Herz. Denn in seinem TO92-Kleid kann er 
nur ca. 0,3W ab. Ohne L als TO220 immerhin ~1W. Merke: Der in üblicher 
Schaltung maximale mögliche Strom eines Reglers steht nicht direkt im 
Datasheet, sondern ergibt sich aus der maximalen Verlustleistung.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider ist die Programmierung der PIC´s eher mein Ding wie das mit der 
Schaltung.
Gehört aber halt dazu und ich versuche alles darüber zu lernen.

Welche werte für die Suppressordiode und Drossel würdest du für´s 
Bordnetz empfehlen?

Hättest du vielleicht ein Schaltungs Beispiel für mich.

Autor: Dieter Werner (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bitte Grafiken NICHT als Bitmaps hochladen, ein png belegt bei gleichem 
Informationsgehalt höchstens 5% des Speicherplatzes und verursacht auch 
entsprechend weniger traffic.

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber lesen kannst du schon? Der Link zum FAQ wurde nun schon zweimal 
hier gepostet. Und da steht alles drin (nur die Verlustleistungsrechnung 
nicht, aber die braucht halt erstmal den Strom).

Autor: Spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Falls du ein altes Autoradio zum Ausschlachten liegen hast: In dem, 
meist schwarzen Block mit den Steckverbindern und der Sicherung sind die 
benötigten Teile (Diode,Drossel) drin.

MfG Spess

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich Danke euch allen und wert mal mein bestes versuchen.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ich nochmal.

HAb gerade mal die Schaltung neu aufgebaut und dazu nochmal das oben 
genannte FAQ benutzt.

Darin war von einem Varistor S10K20 die rede.
Nun habe ich bei Conrad einen Varistor direkt für KFZ Schaltungen 
gefunden
Q69X3859 wäre dieser empfehlenswert?

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Korrektur S10K14AU

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn jemmand zeit hat kann er ja mal schauen ob das so gehen könnte.
Bild ist nicht mehr so groß.

Autor: Mathias R. (neo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
achso Bild vergessen

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Transil (D4) und Varistor (R3) muss nun auch nicht sein. Eins davon 
reicht.

D2 ist hier dank D6 und C7 > C8 nicht erforderlich.

Autor: Mathias R. (neo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alles Klar.
Ich Danke euch allen für eure Hilfe und werd das jetzt mal so bauen und 
dann mal
berichten wie der erste Test verlaufen ist.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.