www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Brauche ATtiny26_Std.aio Datei aus AVR Studio3


Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da auf meinem Laptop nur das ältere AVR-Studio 3.56 läuft wollte ich mal 
ein Prog für den ATTiny26 simulieren, leider fehlt für das 
Ansichtfenster wo die Interruptflags die Ports usw drin sind die Datei 
für den ATTiny26 um das korrekt anzeigen zu können. In einem 
Verzeichniss liegen die Dateien rum nur für den ATTiny26 fehlt diese den 
ATTiny26 müsste es damals aber schon gegeben haben. Warscheinlich fehlt 
mir irgend ein Update auf der ATMEL Seite finde ich aber nichts AVR 3.56 
scheint das letzte der 3er Reihe zu sein. Könnte mir vielleicht jemand 
die Datei zuschicken die vermutlich ATtiny26_STD.aio heißt?

kosmos at mayn punkt de

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist denn das für ein Laptop? Ich habe hier einen Pentium-166 Toshiba 
Libretto, auf dem bereits XP und AVR_Studio4 läuft. Kannst Du Deinen 
nicht entsprechend updaten? Auch wegen der neueren Controller und 
Firmware-Unterstützung?

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hat zwar 600 MHz aber nur 128 MB RAM wovon sich die Grafikkarte nochmal 
was wegschnappt. Geld wollte ich in das Ding keins mehr reinstecken weil 
über kurz oder lang ein neuer herkommt.

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das reicht doch allemal! Der Toshiba hat nur 64MB Ram und es geht auch.

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das AVR Studi 4 stürzt bei mir ab wenn ich auf "Build an Run" gehen als 
zum simulieren.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AVR-Studio 4.11 läuft unter WIN98SE auf meinem ollen 233erMMX mit 256MB 
RAM, auf einem 500er Toshiba SP4270 (Lappi) mit 320MB RAM und lief auch 
auf einem 500er Toshiba SP4280 (Lappi) mit 64MB RAM.

Man hat aber (hier im Forum) gehört/gelesen, dass es Probleme mit der 
aktuell zum Download stehenden Version geben soll. Besuche doch mal 
ATMEL in Norwegen, da soll es eine unproblematische Version zum Download 
geben.

...

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:
> Das AVR Studi 4 stürzt bei mir ab wenn ich auf "Build an Run" gehen als
> zum simulieren.

Dann installiere mal den XML-Parser neu. Den findest Du bei M$ auf der 
Seite. Nennt sich glaube MS_DataAccess.

...

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe mal auf www.atmel.no gesucht aber keine Version 4.11 gefunden hast 
nicht zufällig die Setup Datei noch auf deinem Rechner die die mir mal 
schicken könntest oder bei rapidshare mal kurz hochladen könntest, wegen 
der Mailgröße.

Autor: Hannes Lux (hannes)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Thomas O. wrote:
> habe mal auf www.atmel.no gesucht aber keine Version 4.11 gefunden hast
> nicht zufällig die Setup Datei noch auf deinem Rechner die die mir mal
> schicken könntest oder bei rapidshare mal kurz hochladen könntest, wegen
> der Mailgröße.

Entschuldige bitte, ich habe mich vertan. Es ist die Version
4.12 Build 460 mit Service Pack 4 Build 498
Ist aber noch von atmel.com, noch vor der Registrierpflicht.

Ich war noch nicht auf der Norwegen-Seite, habe aber hier gelesen, dass 
es dort anmeldefrei eine gut funktionierende Beta-Version geben soll.

Wenn Du die Version 4.12b460 und SP4b498 trotzdem haben willst, dann 
melde Dich per Mail.

...

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke Hannes genau die Version mit dem zugehörigen SP hatte ich drauf 
habe vorhin mal die aktuelleste 4.13 (build 528) draufgemacht ist aber 
das gleiche wenn ich auf "Build an Run" gehe und der Balken unten links 
rechts ankommt stürzt das Ding ab.

Hasbe man nen XML-Parser runtergeladen, werde den später mal 
installieren ich jage gerade so nen aufwendigen DOS Memtest drüber 
vielleicht hat ja der Arbeitsspeicher ne Macke. Allerdings gibt ATMEL 
als Mindestanforderugn 128 MB RAM an meiner hat aber weger der 
Grafikkarte nur 112 MB.

Ich würde jetzt noch gerne die 4.11 testen leider finde ich die nirgends 
mehr auch AVR-Freaks haben die nicht drauf. Vielelicht stell ich nochmal 
ne Supportanfrage könnte sein das Sie mir das schicken, haben mir bei 
einen Downgrade für den AVRISP auch geholfen in dem Sie mir ne ältere 
Version zur Verfügung gestellt haben, da nach dem Update der AVRISP nur 
noch mit dem 2.0 Protokoll arbeiten und unter AVR-Studio 3 nicht mehr 
funktioniert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.