www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schwingungen an der SPI Leitung AVR


Autor: Nils (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe Probleme bei der Kommunikation über die SPI Schnittstelle mit 
einem ATMEGA16. Ich bin mir nicht sicher ob das Problem in der Software 
oder in der Übertragung liegt. Also habe ich schnell mal das Scope an 
SCK und MOSI (AVR als Master) gelegt und hab gemessen. Herausgekommen 
ist das Bild im Anhang. Jetzt stellt sich mir die Frage ob das ein 
Messfehler ist oder ob die Schwingungen wirklich so stark vorhanden sind 
und könnten diese Schwankungen Auswirkungen haben?

Vielen Dank für eure Hilfe!

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach die Masseklemme vom Tastkopf ab und geh mit dem Massering vom 
Tastkopf so kurz wie irgend möglich an GND. Wenn's dann immer noch 
schwingt, klingelt wohl die Leitung (wie sieht die aus, Länge?), wenn 
nicht dann schwingt bloss der Tastkopf.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Nils (Gast)

>Dateianhang: 2007_08_06_001.jpg (54,1 KB, 2 Downloads)

Bildformate

>einem ATMEGA16. Ich bin mir nicht sicher ob das Problem in der Software
>oder in der Übertragung liegt. Also habe ich schnell mal das Scope an
>SCK und MOSI (AVR als Master) gelegt und hab gemessen. Herausgekommen
>ist das Bild im Anhang. Jetzt stellt sich mir die Frage ob das ein
>Messfehler ist oder ob die Schwingungen wirklich so stark vorhanden sind
>und könnten diese Schwankungen Auswirkungen haben?

Sieht nach Messfehler aus. Wie hast du die Masseverbindung zwischen 
Tastkopf und Messobjekt hergestellt? Selbst die kurzen 10cm Kabel können 
solche Überschwinger aus dem Nichts auftauchen lassen. Wie ist die 
Masseführung auf deiner Platine?

MFG
Falk

Autor: Nils (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
An ein Masseproblem habe ich auch schon gedacht und die Masseleitung 
stark verkürzt. Das hatte zwar Auswirkungen auf die Länge(Dauer) der 
gemessenen Störungen aber nicht auf die Amplitude.

Ich habe beide Platinen mit ca. 10cm Fachbandkabel verbunden, könnte das 
soche Auswirkungen haben?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Nils (Gast)

>An ein Masseproblem habe ich auch schon gedacht und die Masseleitung
>stark verkürzt. Das hatte zwar Auswirkungen auf die Länge(Dauer) der

WIE sieh sie denn nun GENAU aus?

>Ich habe beide Platinen mit ca. 10cm Fachbandkabel verbunden, könnte das
>soche Auswirkungen haben?

Wenn die Masseführung Müll ist, dann ja.

MfG
Falk

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.