www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 & atmega8 - dauerleuchtende Leds


Autor: Kai Kuhlmann (kai2)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen!

ich bin dabei mir ein fnordlicht[1] zu bauen. Die Version 0.1 lief im 
STK500 bisher problemlos. Auch auf dem Steckbrett liegt der µC 
problemlos.

Jetzt habe ich die Version 0.2 einprogrammiert und nun leuchten die Leds 
0-5 dauerhaft, wenn sie an Port B angeschlossen sind. Mit einem andern 
atmega8 passiert das gleiche.

Beim Programmieren blinken nur die Leds an den SPI Pins. Da scheint also 
alles in Ordnung zu sein.

Auch mit einem einfachen Blinklicht-Programm bekomme ich nur das 
Dauerlicht?

Jemand eine Ahnung, was da nicht mehr richtig ist? Hab ich mir da was 
zerbrutzelt?

Gruß, Kai

[1] http://www.lochraster.org/fnordlicht/

Autor: Alexander (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Wie sieht deine Schaltung genau aus?  Im Original sind keine LEDs an den 
SPI-Pins angeschlossen, dafuer ist die Software auch nicht ausgelegt. 
Welche Firmware hast du genommen?   Die in Assembler, oder die in C?

Gruss,
- Alex

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.