www.mikrocontroller.net

Forum: Offtopic Hamachi Konfigurieren


Autor: Hamachi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab ne frage zu hamachi: ich hab mirs runtergeladen und will mit nem 
Kumpel ein bißchen zocken. Geht aber nicht. CoD 1 findet keine Spiele. 
Muss ich vorher noch was einstellen? Muss ich nen Port freigeben? Ich 
hab Windoof XP Home und ne Fritz Bocx WLAN 3050. Ne 16000er Leitung von 
T-Online.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Steven: du hast aber auch keine Ahnung, oder? Hauptsache ignorant 
daherreden.

Hamachi baut ein VPN auf, soweit ich weiß..

Das beschriebene Problem kann damit zusammenhängen, dass der 
Spiel-Server auf dem falschen Interface listened, oder der Spiel-Client 
auf dem falschen Interface nach Servern sucht. Eine Lösung gibts aber 
hierfür nicht wirklich.

Autor: Adler M. (madler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, solche Probleme hatte ich auch.
Ich weiss nicht ob man in Deinem Spiel einstellen kann welchen 
Netzwerkkarte es benutzen soll, aber das würde ich mal überprüfen.
Ansonsten ist auch die (Windows-)Firewall immer eine beliebte 
Fehlerursache.
Du solltest auch bei Hamachi checken, dass der Punkt neben Deinem Namen 
grün ist und nicht blau o.ä. Erst als ich das hinbekommen hatte 
(Firewall Einstellungen) ging es bei mir, unabhängig vom Spiel.

@Steven
Die ports von Hamachi sind unabhängig vom Spiel.

Autor: Steven Wetzel (steven)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Du solltest auch bei Hamachi checken, dass der Punkt neben Deinem Namen
> grün ist und nicht blau o.ä. Erst als ich das hinbekommen hatte
> (Firewall Einstellungen) ging es bei mir, unabhängig vom Spiel.
>
> @Steven
> Die ports von Hamachi sind unabhängig vom Spiel.

Nicht bei jedem Spiel. Die Fritzbox schließt alle Ports. Wenn das Spiel 
nicht gerade über Port 80 einen Verbindung aufmacht, blockt der Router 
alles ab. Bei mir war es in Starcraft oben genannter Port, wobei hier 
noch anzumerken ist, dass nur dieser einer Port und nicht der gesamte 
Range bis 19 aufgemacht werden darf, da Hamachi dann recht viel 
CPU-Power benötigt.

Mit der Option "Über NAT verbinden" hatte es bei mir nicht funktioniert.

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Steven

Kommst du zufällig aus Regensburg?

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steven Wetzel wrote:
> Nicht bei jedem Spiel. Die Fritzbox schließt alle Ports. Wenn das Spiel
> nicht gerade über Port 80 einen Verbindung aufmacht, blockt der Router
> alles ab. Bei mir war es in Starcraft oben genannter Port, wobei hier
> noch anzumerken ist, dass nur dieser einer Port und nicht der gesamte
> Range bis 19 aufgemacht werden darf, da Hamachi dann recht viel
> CPU-Power benötigt.
>
> Mit der Option "Über NAT verbinden" hatte es bei mir nicht funktioniert.

Doch, bei jedem Spiel. Hast du dir mal angeschaut wie ein VPN 
funktioniert? (Fast) alle Pakete werden eingepackt (encapsulated) und 
eventuell verschlüsselt und über einen Port (VPN Port) nach außen 
verschickt. Da braucht nur ein einziger Port frei zu sein, nämlich der, 
den Hamachi für das VPN benutzt.

>Was hast du anzubieten, als die ohnehin bekannte Anmerkung, dass Hamachi
>ein VPN aufbaut?

Ich habe wenigstens den Tipp gegeben, wo das Problem liegen könnte.

Autor: Hamachi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen dank. ICh bin sicher ihr könnt hier helfen.

Jetzt konkret: Welchen Port soll ich bei meiner fritzbox und der 
firewall freigeben? Bei dem Spiel kann ich nur aussuchen ob es über 
Internet oder Lokal läuft.

Danke

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh mann Steven, du schreibst Stuss! Lies dir dochmal was dazu durch:
http://de.wikipedia.org/wiki/Hamachi
Da steht wie das Programm funktioniert.

Angeblich muss man beim Hamachi garkein Port freigeben, da durch eine 
bestimmte Technik eine Verbindung von Innen aufgebaut wird (und somit 
der Port am Router geöffnet wird für andere Verbindungen). Also der 
Router bewusst "verwirrt" wird.

Du kannst aber, wenn du willst den Port, den Hamachi benutzt freigeben 
im Router. Welcher das ist, und wie das geht müsstest du auf der Hamachi 
Homepage, respektive in deinem Router Handbuch finden.

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hamachi:

bitte aufgarkeinenfall dem ratschlag von steven wetzel befolgen
und die windows firewall deaktivieren!

mfg
 Hansl

Autor: jonny (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich konnte bei meiner Hamachi Version immer einen Port angeben über 
den Hamachi eine Verbindung zu einem Netzwerk aufbaut.

Diesen habe ich in allen Firewalls für kommende und gehende Pakete 
freigegeben und schon klappt es mit ALLEN Spielen, da die Ports der 
Spiele scheiß egal sind.

Am Router den Port einfach auf deinen PC weiterleiten.
Stichwort: Virtuelle Server
Da hilft es die Lokale IP nicht vom DHCP-Server zu beziehen sondern die 
Fest einzutragen, damit auch in 3 Jahren noch alles klappt.

Die Lokale Firewall muss natürlich auch konfiguriert werden.
Ganz wichtig ist, das man kein Internet-Spiel eröffnet sondern ein 
LAN-Spiel

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steven wetzel:

ich habe einige gruende dafuer.

offensichtliches:
 der router unterstuetzt upnp.
 es ist ein wlan router.

nicht so sehr offensichtliches:
 die eingesetzte fireall besitzt keine moeglichkeit
 rechner im lan vor sich selbst zu schuetzen.

was fuer gruende sprechen denn deiner meinung nach fuers deaktivieren?

das eine anwendung nicht funktioniert sollte nicht dazu fuehren eine
so wichtige (gerade bei windows :P) sicherheitsvorkehrung zu 
deaktivieren.
die korrekte vorgehensweise ist das konfigurieren.

mfg
 hansl

p.s.:
deine kompetenz diesbezueglich hast du aber bereits anfangs mit
deiner aussage:
 >Du meinst sicherlich, dass du Windows XP Home hast. Überlasse diese
 >Kindergartensprache den Linuxusern, sonst nimmt dich keiner ernst.
klar hervorgestrichen.

no offense. sicherheit geht vor. ueber spam jammern ist ja nur
die eine seite ;) firewalls deaktivieren, die andre :)

Autor: Andreas Schwarz (andreas) (Admin) Benutzerseite Flattr this
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Windows-"Firewall" ist lästig und bringt, wenn man einen NAT-Router 
verwendet, keinen nennenswerten Sicherheitsgewinn. Das Ausnutzen der 
berühmten RPC/Netbios-Bugs aus dem LAN hätte sie z.B. nicht verhindern 
können. Besonders toll ist es auch, wenn im Vordergrund ein Spiel hängt 
weil im Hintergrund ein Dialog dieser "Firewall" aufgeklappt ist, an den 
man nicht rankommt.

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steven wtzel:

ach, komm schon, was soll die schlammschlacht. du wolltest wissen 
wasdagegen spricht, ich habs dir gesagt. du hast was von linuxuser 
erzaehl, auf der box laeuft soweit ich weiss linux somit ist er ein 
solcher.

wenn mit der fritzbox noch ne software-fw fuer windows ausgeliefert wird 
und
die dann anstelle der ms fw installiert und aktivieret ist ists fuer 
mich
auch ok.

was ich nicht ok finde ist die konstelation ungeschuetzter rechner
in nicht so sicherem netz hinter ner firewall.

mfg
 hansl

ich nehm mal schnell die steine und vergrab sie wo wo du sie nicht 
finden kanns damits nicht allzuviel glueck regnet.

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhm, kanns aber noch klarer formulieren:

rechner hinter firewall ohne sw firewall == potenzieller spambot.

gut konfigurierte hw firewall (upnp disabled, wlan geschuetzt)
wandernde rechner immer in sicheren haefen andocken + sw firewall
== so sicher wie enduser sich nur ans internet andocken kann.

ich selbst bevorzuge sw fw + vpn zu router(mit gut konfigurierter fw)


klar schuetzt ne sw firewall nicht sonderlich gut. aber bei +30
spammails in meiner box pro tag finde ich sollte jede noch so
kleine chance den schaden zu begrenzen genutzt werden.

mfg
 hansl

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steven wetzel:

tja, da bin ich dann wohl uebers ziel hinausgeschossen :)
naja, zumindest wissen nun auch nichtinsider was sache ist
und das sw-fw+hw-fw in zeiten wie diesen ein muss ist :)

mfg
 hansl

Autor: Jupp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich besitze selbige auch.

und

> Somit kann ich sicher sagen [...]

Warum kannst du das so sicher sagen? Kennst du die Interna sowohl der 
Windows FW als auch der Fritz! FW so gut?

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steven wetzel:

magst du mir bitte sagen welches fw produkt avm da mit dazupackt, reine 
neugier. hab beim kurz gogglen grad leider nix dazu gefunden und finds
aber sehr interessant, sollten mehr routerhersteller machen.

danke
 hansl

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
a ok, fritz dsl protect heisst die. guck ich mir gleich mal an :)

mfg
 hansl

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mhm, jepp. grad die firmware angeguckt. auf der fritzbox laeuft linux :)
darfst also ab nun auch windoof sagen wenn du moechtest steven ;)

fritz!dsl protect gibts leider nicht zum angucken.

jetzt aber wirklich
 ciao
  hansl

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
steven:

mhm, schade, aber vielelicht wirds ja doch noch. 4mb ram sind halt
echt wenig fuer ein linux+webinterface+upnpd,dhcpd&co. koennt mir
vorstellen das da ab einer gewissen anzahl geoeffneter ports der 
speicher ausgeht.

wenn du den kernel konfigurieren kannst(shell oder so) und er sysfs mit
drinne hat kannst du mal mit tcp_fin_timeout herumspielen.
(/proc/sys/net/ipv4/tcp_fin_timeout)
gibts aber noch etliche knoepfe zum testweisen drehen.

http://ipsysctl-tutorial.frozentux.net/chunkyhtml/...

ist aber ne reine vermutung, hatte ich mal bei nem zyxel geraet.
war leider nie behoben worden und es gab auch keinerlei doku zum
innenleben der box.

mfg
 hansl

Autor: Hansl (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
/proc/sys/net/ipv4/route/

ist wahrscheinlich fuer den fall interessanter. sind ja keine lokal 
initialisierten verbindungen.

Bitte melde dich an um einen Beitrag zu schreiben. Anmeldung ist kostenlos und dauert nur eine Minute.
Bestehender Account
Schon ein Account bei Google/GoogleMail, Yahoo oder Facebook? Keine Anmeldung erforderlich!
Mit Google-Account einloggen | Mit Yahoo-Account einloggen | Mit Facebook-Account einloggen
Noch kein Account? Hier anmelden.