www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik (Dieser Beitrag wurde geloescht)


Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Roman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Die gelben freut es.
2. weil sie wissen wie man den Aref berechnet
4. AVR <> Debug

Autor: Thomas B. (yahp) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Beitrag wird nominiert in der Kategorie "Zusammenhangloseste 
Antwort".

Autor: GRA (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Guido,
ich hatte bisher noch keine gefaelschten chips. Wo kaufst du die denn? 
ebay ?

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gefälschte AVR? Kaufst du die auf der Straße? Ich verbaue hier im Jahr 
vierstellige Stückzahlen und mir ist noch nix negativ aufgefallen. Ich 
kauf auch nur bei Distributoren ein.

Gibt es überhaupt gefälschte AVR? Oder hast du nur bei einem der großen 
Ramschelektroniker gekauft bei denen man auch schonmal gebrauchte Ware 
bekommt?

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: MisterT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schick ein Chip zu Atmel, dann gibt nen 8D Report dazu :-)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, ein Drittel der Quarzfrequenz klingt aber eher nach falscher
Quarzlast, oder?  Wie will man denn einen Oszillator so vergurken,
dass er mit genau 1/3 läuft?

Aber ich würde hier auch mit Atmel schnellstens Kontakt aufnehmen,
damit sich da ein FAE drum kümmert.

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht solltest du mal deinen Bestücker fragen wo er die Teile 
gekauft hat oder ob er sie vielleicht zu heiss "gebadet" hat

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Guido Fischer (guido)

>raus bzw. laufen kurz an und bleiben dann stehen. Wahlweise laufen sie
>mit einem drittel der Quarzfrequenz los. Hauptsächlich ließ sich der

Hat da vielleicht jemand Obertonquarze erwischt? Mit welcher 
Quarzfreqeunz laufen die denn?

>erst mal ein GAU und die Stimmung hängt entsprechend tief.

Mein Beileid.  :-(

MFG
Falk

Autor: Meister der Insel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Siehe auch:

Beitrag "Atmega8515 verlor plötzlich sein Programm?"

Sollte einem zu denken geben.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guido Fischer wrote:

> ich schrieb doch "Passiert sowohl bei Beschaltung mit externen Quarz
> als auch bei internen RC Oszillator."

Naja, das war widersprüchlich, weil du von *Quarz*frequenz schriebst.

Für den internen Oszillator ist 1/3 wirklich ein seltsamer Wert.  Kannst
du den am Taktausgang bei gesetztem CKOPT nachweisen?  Dann würde ich
es schon für einen Bug halten.

Autor: Meister der Insel (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Guido Fischer

Um welche AVR's handelt es sich denn?

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Mike (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich halte es für sehr unwahrscheinlich, dass ein Controller wie der 
ATMEL16L gefälscht wird. Schliesslich machen die Fälscher das nicht zum 
Spass, sondern wollen etwas dabei verdienen. Ein komplettes 
Nachentwickeln des Chips würde selbst in Ostasien so viel kosten, das 
nur mit einer sehr grossen Stückzahl ein Gewinn zu erzielen wäre. Bei 
einer "schlechten" Kopie wie Du sie meinst erwischt zu haben, würde das 
ja schnell auffallen.

Bekannte Chipfälschungen betrafen daher bisher hochpreisige 
Massenprodukte wie PC-Prozessoren, wo sich durch eine einfaches 
"Umlabeln" auf eine höhere Taktfrequenz mehrere hundert Dollar verdienen 
liessen. Es war hier nicht einmal nötig, den Chip nachzubauen. Bei einem 
2-Euro Chip wäre wohl für den Fälscher kaum was zu gewinnen. Da wäre es 
lukrativer, 2€ -Münzen zu fälschen.

Mike

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man müsste in solchem Fall die exakten Bezeichnungen von 
funktionsfähigen und defekten Chips sammeln, also inklusive Fabrik und 
Herstellungwoche. Vielleicht ergibt sich dann ein Bild.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
CHINA habe ich allerdings bislang noch auf keinem AVR auf der
Rückseite gesehen...  Ich habe den ATmega16 hier aber gerade nur
als DIP da, da ist die Beschriftung sowieso anders.  Zum Vergleich,
hier die Rückseite eines ATmega128:

4H6715
35567I
1-P
0452

...und die eines ATmega1281V:

6G0853
355B4A
1-P
0635 e3

Aber endgültig klären sollte dir das avr [at] atmel com.

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich hab hier bestimmt 30 verschiedene Typen rumliegen, von Mega8 AU 
bis Mega2560 AU, auch einen Mega16L. Bei keinem steht China drauf.

Ist es möglich das Atmel erst seit kurzem in China produzieren lässt und 
du eins der ersten Opfer der tollen Qualität bist?

Ich würde mich direkt an Atmel wenden und von denen eine Aussage 
fordern. Gut zu wissen das da jetzt anscheinend in china produziert 
wird. Werd ich bei zukünftigen Einkäufen mal drauf achten

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wenn ich per FUSE Int. RC Osc. 8MHz wähle und über einen Piezo im
> Sekundentakt einen 1KHz Beep ausgebe, dann sollte der seine Frequenz
> doch wohl halten wenn ich die Spannung ändere, oder? :-)

Die Betriebsspannung? Der RC-Oszillator?

Was sagt denn das Datenblatt zur Frequenzstabilität des RC-Oszillators 
in Abhängigkeit von der Betriebsspannung?

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Spannungsabhängigkeit vom RC-Oszillator steht im Datasheet.

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wenn ich per FUSE Int. RC Osc. 8MHz wähle und über einen Piezo im
> Sekundentakt einen 1KHz Beep ausgebe, dann sollte der seine Frequenz
> doch wohl halten wenn ich die Spannung ändere, oder? :-)

Das würde ich nur erwarten, wenn du den Int. RC Osc. konstant am laufen 
hast. D.h. z.B. kein Frequenzshift durch Erwärmung des µC bei steigender 
Betriebsspannung auftritt.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wir hatten mal einen ähnlichen Fall mit anderen µC. Das war in der Zeit 
der Umstellung auf bleifrei.
Der Bestücker muss die ICs "fast ausgeglüht" haben. Sie liefen danach 
auch nur noch sporadisch, und es gab unerklärliche Phänomene.

Fordere mal einen Plot der Reflow-Temperaturkurve.

Autor: Rolf Magnus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> wenn ich per FUSE Int. RC Osc. 8MHz wähle und über einen Piezo im
> Sekundentakt einen 1KHz Beep ausgebe, dann sollte der seine Frequenz
> doch wohl halten wenn ich die Spannung ändere, oder? :-)

Also er sollte immer noch einigermaßen in der Nähe von 1kHz sein, wenn 
du das meinst. Die Schwankungen sollten halt nicht größer als die im 
Datenblatt angegebenen sein, aber das ist ja eh klar.

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: MarkusS (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe zur Zeit ein ähnliches Problem mit den ATMEGA16L 8AU.

Ich habe zwei Serien von Leiterpalltten aufgelegt, die erste Serie der 
Leiterpaltten noch vor der Umstellung auf Bleifrei. Dort wurde noch der 
alte Atmega verwendet, bei 70 Leiterkarten war kein Fehler aufgetreten.

Bei der zweiten Serie sind etwa 10% der Prozessoren ausgefallen. Hier 
ist das Fehlerbild aber immer das gleiche, der Prozerssor lässt sich 
schon garnicht Programmieren.

Zur Zeit laufen die abklärungen mit dem Bestücker. Die Vermutung von uns 
geht dahin, dass die Prozessoren zu Heiß gelötet wurden (Bleifrei :-) 
halt).

Zuvor hatte ich noch nie Probleme mit den Atmegas.

Grus MarkusS

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guido Fischer wrote:

> die genannte EMail Adresse - ich schätze die möchten in English bespasst
> werden, gell?

Norwegisch geht wahrscheinlich auch. ;-)  Ja, Englisch ansonsten.
Oder du musst dir den für dich zuständigen FAE heranziehen, der
dürfte normalerweise auch der deutschen Sprache mächtig sein...

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Markus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hatte mit der ersten bleifreien SMD Lotpaste auch Probleme. Hab mir 
reihenweise Platinen gegrillt. Dann hab ich eine Lotpaste gefunden die 
einen Schmelzpunkt von etwa 140°C hat. Für meine Anforderungen völlig 
ausreichend und für mich ideal von der Verarbeitung.

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Andreas K. (a-k)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kurzschluss an den Pins?

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guido Fischer wrote:

> ... - ich
> glaub das reicht jetzt als eindeutiger Hinweis auf einen defekt.

Glaub' ich auch.

> Ergo: Chips aus China sind Mist :-)

Dann gib' mal deinem Bestücker die Farnell-Chips, magucken, ob er die
auch zerheizt. ;-)

Ich bin mir übrigens ziemlich sicher, dass wenn da wirklich was aus
China dran ist, es nur das Gehäuse ist.  Selbst das ist aber fraglich,
hier mal das, was auf
http://www.atmel.com/corporate/fact_sheet.asp
steht:

``Approximately 8000 people worldwide with manufacturing facilities in
USA and Europe with test and assembly facilities in the Philippines and
Malaysia''

Autor: mmerten (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In der Tat wird vieles in Asien in passende Gehäuse verpackt.
http://www.msc.de/download/pcn/atmel/sc061005.pdf

Autor: (geloescht) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Dieser Beitrag wurde geloescht)

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Guido Fischer: Installier dir mal das neuste Servicepack wäre dann 
4.13.555
http://www.atmel.no/beta_ware/as4/413sp1/AVRStudio...

Autor: Sergey (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt sie - AVR-Clones von INTEGRAL aus Belarus:
http://www.integral.by/?section_id=51

PIC-Clones aus China, Taiwan und Korea gibt es ebenfalls!

Autor: Marvin M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Segey: Das sind aber sämtlich abgekündigte AVRs, die da angeboten 
werden.

@Guido Fischer: Mehr als interessant, was da gerade bei Dir abläuft. Ich 
hoffe, es wendet sich für Dich alles zum Guten - halte uns bitte auf dem 
Laufenden!

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Sergey
Das sind doch bestimmt Weiterentwicklungen der Atmel-MCU´s. Über der
Tabelle steht ja, welcher Prototyp von Atmel dafür benutzt worden ist.

MfG Paul

Autor: Martin Hirnsperger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann mir nicht vorstellen, dass die Qualität nicht passt - das ist 
praktisch unmöglich.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anmerkung von mir zum Thread, falls hier jemand einen Teil der
Diskussion vermisst. ;-)  Dieser Teil wurde zunehmend (gegenüber
dem Ursprungsposting) off-topic und daher gelöscht.  Simon sei
geraten, mit seinem Thema einen separaten Thread aufzumachen.

Falls noch jemand was zu Guidos Problem hat (bzw. Guido neue
Erkenntnisse), ist hier nun der Platz, dies kund zu tun.

Autor: Volker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann nichts zur Problemlösung beitragen, es würde mich aber schon
interessieren, was aus den Tests mit den TQFP Nullsteckkraft Sockeln 
ergeben hat.
Ist immerhin schon fast eine Woche her.

Gruß Volker

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.