www.mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik PSpice und neue Bibliothek


Autor: Greenhorn (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe gerade PSpice Demo Version heruntergeladen und versuche nun 
eine neue Bibliothek hinzuzufügen (phil_bjt.olb bzw. phil_ bjt.lib). Die 
Bibliothek lade ich mir von der Cadence Homepage herunter. Wenn ich die 
Modell der Bibliothek in den Schaltplan einfüge, sagt er vor der 
Simulation: z.B. Model QBC337-16/PLP used by Q_Q1 is undefined

Kann mir jemand helfen. Danke

Autor: SNT-Opfer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann findet OrCad die nicht.
Also bei den Simu Einstellungen unter "Configuration Files" "Category" 
Library anklicken, bei Filename den Pfad bzw. die .olb Datei angeben und 
am Besten als "Add as Global" anklicken und somit hinzufügen.

Autor: H. W. (digger72)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du musst im Fenster für die Simulationseinstellungen
unter Libraries deine Bibliothek hinzufügen, am besten
als global.

Gruss
Digger

Autor: Atter See (attersee)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Möchte Einschaltverhalten eines Netzteils mit LM723 (obwohl alt) 
simulieren. PSpice Student, Demo Version 9.1, Web-Update 1.
Habe .SUBCKT Datei für LM723 und .MODEL Datei für 2N3055 im Internet 
gefunden und von beiden (im ersten Schritt) eine neue Modellbibliothek 
(.lib) angelegt und mit ‚PSpice Model Editor Student’ die zugehörigen 
Schaltzeichenbibliotheken erstellt.
Dann fertigte ich gleich eine relativ umfangreiche Schaltung an und 
scheiterte an so vielen Fehlermeldungen, dass ich wieder klein begann.
Erstens: Testschaltung für 2N3055. Die neu erstellte Bibliothek (mit 
PSpice  Edit Simulation Profile  Libraries / Browse) mit ‚Add to 
Global’ hinzugefügt. Auch ‚Add to Design’ getestet. Alles bestens, alles 
funktioniert.
Zweitens: Testschaltung für LM723 (Minimalbeschaltung) ......... Rest 
wie oben, - einziger Unterschied, -> Abbruch mit folgender Fehlermeldung 
im Output File (Leerzeilen entfernt).

**** 12/27/08 15:22:51 *********** Evaluation PSpice (Nov 1999) 
**************
** Profile: "SCHEMATIC1-LM723_Test"  [ 
D:\SIMULATION\Doppelnetzteil\LM723_Test\lm723_test-schematic1-lm723_test 
.sim  ]
 ****     CIRCUIT DESCRIPTION
************************************************************************ 
******
** Creating circuit file "lm723_test-schematic1-lm723_test.sim.cir"
** WARNING: THIS AUTOMATICALLY GENERATED FILE MAY BE OVERWRITTEN BY 
SUBSEQUENT SIMULATIONS
*Libraries:
* Local Libraries :
.LIB "C:\Program Files\OrCAD_Demo\Capture\Library\Pspice\LM723.lib"
* From [PSPICE NETLIST] section of pspiceev.ini file:
.lib "nom.lib"
*Analysis directives:
.TRAN  0 100ms 0
.PROBE
.INC "lm723_test-SCHEMATIC1.net"
**** INCLUDING lm723_test-SCHEMATIC1.net ****
* source LM723_TEST
X_U1         N00145 N00169 N00169 N00101 N00098 0 N00313 N00120 N00024 
N00024
+  N00087 LM723
V_V1         N00024 0 24Vdc
R_R1         0 N00101  3k
R_R2         N00101 N00098  1k
R_R3         0 N00145  5.6k
R_R4         N00145 N00120  2.7k
R_R5         N00169 N00120  30
R_R6         0 N00313  1k
C_C1         0 N00087  1n
**** RESUMING lm723_test-schematic1-lm723_test.sim.cir ****
.INC "lm723_test-SCHEMATIC1.als"
**** INCLUDING lm723_test-SCHEMATIC1.als ****
.ALIASES
X_U1            U1(2=N00145 3=N00169 4=N00169 5=N00101 6=N00098 7=0 
9=N00313
+  10=N00120 11=N00024 12=N00024 13PARbar=N00087 )
V_V1            V1(+=N00024 -=0 )
R_R1            R1(1=0 2=N00101 )
R_R2            R2(1=N00101 2=N00098 )
R_R3            R3(1=0 2=N00145 )
R_R4            R4(1=N00145 2=N00120 )
R_R5            R5(1=N00169 2=N00120 )
R_R6            R6(1=0 2=N00313 )
C_C1            C1(1=0 2=N00087 )
.ENDALIASES
**** RESUMING lm723_test-schematic1-lm723_test.sim.cir ****
.END
ERROR -- Subcircuit LM723 used by X_U1 is undefined

Zusatzinformation: Im Output Window steht nach obiger Fehlermeldung noch 
‘Circuit has Errors .... run aborted’. Nun weiß ich nicht, ob er mit 
Circuit den LM723 oder die Gesamtschaltung meint.
Ich verstehe einfach nicht, warum ich die bekannte 
Undefined-Fehlermeldung erhalte, obwohl ich die erstellte 
Bibliothekdatei ja eingebunden habe, - genau so, wie ich es beim 2N3055 
tat. Die Datei LM723.lib ist ja (s.o.) unter Local Libraries im Output 
File auch angeführt.
Auch mit Google bin ich bisher nicht klug geworden. Danke für Hinweise, 
die helfen, das Ding flott zu machen. Johann

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, grüß Dich Kauf Dir das Buch. (Ein Muss)

ISBM 978-3-446-42609-2

ca. 30 Euro.

Seite 344 bis 356.

MfG
Andy

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.