www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Frage zu Schrittmotor


Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gute Nacht allerseits,

ich habe eben meine Schrittmotor Steuerplatine (L297 u. 298 Combi) 
fertig gemacht und wollte fragen ob es "normal" ist das sich der Motor 
sehr erwärmt.... das er etwas warm wird ist ja normal (gehe ich mal 
davon aus), aber werden die eventuell sehr sehr warm ?
Der "brummt" auch beim drehen etwas...

Woran könnte das liegen ? Eventuell ein typischer Fehler ?

Danke !

Autor: Mario M. (mariom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Motor 1cm gross ist, dann wird er warm...

Ohne Daten kann man dir nur schlecht helfen.
Was für einen Strom pumpst du durch? Welche Spannung?

Autor: F. Kriewitz (freddy436)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je nach Motor Größe/Strom können die sehr schnell ziemlich warm werden.
Vor allem bei langsamen Schritt-Geschwindigkeiten. Wenn du vor hast den 
auch im Stillstand zu betreiben dann erst recht, da solltest du 
aufjedenfall den Strom runterregeln.

Betrieb den Motor einfach mal mit der höchst möglichen Geschwindigkeit, 
wenn er dann noch zu warm wird solltest du Spannung/Strom nochmal 
überprüfen.

Das ein Schrittmotor piepst/brummt ist ebenfalls "normal", ebenfalls 
vorallem bei langsamen Frequenzen.

Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, ich vergaß.. du hast natürlich recht Mario.

Was meinst du mit 1cm groß ? Ist ein Schrittmotor eines Epson Druckers.


Motor wird mit 12V eines PC Netzteiles versorgt.

Kann das eventuell am Source Code liegen ? Ansonsten poste ich den 
mal...
Bin noch relativ neu in C.


Danke !

Autor: Mario M. (mariom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nene, das mit der Hitze passt.
Das mit dem 1cm sollte eine Anspielung auf die mangelnden Daten sein.. 
;)

Ich betreibe auch gerade einen Schrittmotor eines Druckers, allerdings 
ohne Stromregelung und mit diskreter Ansteuerung. Eine Spule hat 7 Ohm 
Widerstand, da gehen bei mir über 1.5A durch, das Ding wird auch relativ 
heiss...
Bei dir gibt es aber die Möglichkeit, den Strom zu regeln... falls das 
Ding zu heiss wird, kannst du ja mit deiner Regler-Kombination den Strom 
runterdrehen. Allerdings sind diese Drucker-Stepper nicht gerade die 
stärksten... ==> Viel Spannung draufgeben und Strom runterregeln lassen, 
damit er nicht zerkocht.

Im Roboternetz-Wiki hats ein super Tutorial über Schrittmotoren! Dort 
sind auch die verschiedenen Ansteuerschemata tabellisiert, also wann 
welche Spule wo Saft braucht.

Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke ! werde ich mir anschauen und ansonsten poste ich wieder mal hier 
rein :D

danke !!

Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal !

Es wurde erwähnt das ich ein Stromregler brauch...
ist dieser Stromregler bei der L297 und L298 Combi nicht vorhanden ?
Ich habe das so verstanden [1] kann mich auch irren...


[1] http://www.roboternetz.de/wissen/index.php/Schrittmotoren


danke

Autor: Mario M. (mariom)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Doch, diese Combo kann eben den Strom regeln.

Autor: peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
d.h. dann muss ich mir darum ja keine sorgen machen :)

Autor: Johannes M. (johnny-m)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du musst den Stromregler aber auch entsprechend konfigurieren...

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, nachdem ich die erste Hirte geschafft habe und den Schaltplan ins 
PNG Format gekriegt habe, folgt gleich die nächste Frage:
Ich habe mir für ein Projekt eine typ. L297 / L298 Steuerung aufgebaut.
Nun habe ich mein Motor angeschlossen (Mitsumi M42SP-6NK).
Ich habe vollgendes Problem, der Motor läuft im Leerlauf wunderbar egal 
ob rechts oder links. ABER sobald ich den Motor belaste spinnt die 
Steuerung.
z.B. Der Motor läuft rechts (CCW auf +5V ) und bei der ersten Belastung 
beginnt der Motor links zu laufen und selbst wieder bei Leerlaufbetrieb 
und wenn ich dan wieder unter Last setzte läuft er wieder rechts. Nach 
längeren Lastbetrieb bleibt er auf der Stelle stehen. Wenn ich ihn kurz 
vom Netz nehme gehts wieder...

Total unlogisch...

Irgendwelche Ströme bringen die ganze Sache ins Wanken, ich vermute die 
Motorströme drücken bei Last zurück.

Was kann ich machen???

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Motor jetzt mal ne ganze Weile im Leerlauf drehen lassen, 
er lief ca. 50 Umdrehung rechts, dan drehte er auf einmal und lief links 
dan weiter nach 20 Undrehung blieb er auf der Stelle stehen nach kurze 
anschuppsen lief er wieder rechts...

Den L297 hab ich schon getauscht an dem liegt es nicht...

Autor: Bastler007 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sorry, Schaltplan vergessen...

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe die Sache in Griff gekriegt, es war Lötrotz der zwischen GND 
und 12 klebte. Das nächste Problem ist, das dem Motor die Kraft fehlt er 
sollte ca. 150 gr heben und schafft das nicht. Die Strombegrenzung hab 
ich schon von 600mA auf 1V angehoben. Der Motor ist aber eigendlich lt. 
Datenblatt in der Lage das zu bewältigen.
Woran kann es liegen?

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat denn keiner ne Idee? Ich bin echt mit meinen Latein am Ende...
Wäre für brauchbare Vorschläge echt dankbar.

Autor: ... (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Stepper hat 30 Nm, das kann nicht funktionieren glaub ich...

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmal, ich bin der Sache von... mal auf den Grund gegangen. Das 
stimmt der Motor macht 30 Nm. An der Motorwelle ist eine Winde befestigt 
die eine Schnur aufwickeln soll wo unten ca. ein Gewicht von 150 gr. 
dranhängt. Ich habe den Schrittmotor mal durch einen größeren getauscht 
mit bedeutend größeren Drehmoment. Das Resultat ist das selbe, im 
Leerlauf alles wunderbar aber unter Last fehlt die Kraft, das Gewicht zu 
heben. Kann es sein, auf Grund der langsamen Drehzahl (1 Umdrehung je 
Sekunde)die Sache ins wanken kommt?
Wäre für Ideen echt dankbar

Autor: Mensch_Z (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R1 ,R2  = 0,5 Ohm ? gemessen oder geschaetzt ?

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
0,5 Ohm eingebaut für R1,R2...
Die entscheidende Frage liegt im Moment beim Drehmoment.
30Nm sind bei einen Spulendurchmesser von 1 cm 300gr????

Autor: STK500-Besitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>30Nm sind bei einen Spulendurchmesser von 1 cm 300gr????
1 N entspricht der Gewichtskraft einer Tafel Schokolade...(100gr Masse)
30Nm bei einem Radius von 0,01m duerften ein paar Schokoladen mehr 
sein...

http://de.wikipedia.org/wiki/Newton_(Einheit)

Ich vermute, dass du irgendwo in deiner Schaltung den Strom verbraetst, 
wo er nicht verbraten werden sollte (Kabelquerschnitt?)...

Autor: STK500-Besitzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Der Motor läuft rechts (CCW auf +5V ) und bei der ersten Belastung
>beginnt der Motor links zu laufen und selbst wieder bei Leerlaufbetrieb
>und wenn ich dan wieder unter Last setzte läuft er wieder rechts. Nach
>längeren Lastbetrieb bleibt er auf der Stelle stehen. Wenn ich ihn kurz
>vom Netz nehme gehts wieder...

Klingt weiterhin nach einer zu hohen Schrittfrequenz, da sich der Motor 
zu verschlucken scheint.

Autor: Bastler007 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey, irgendwie hab ich Probleme das Datasheet zu verstehen, ich hab den 
Link mal gepostet 
http://www.mitsumi.co.jp/Catalog/pdf/motor_m42sp_6nk_e.pdf
Ich glaube nicht das der Strom verbraten wird, der Kabelquerschnitt zum 
Motor beträgt 0,14mm².
Ich vermute es liegt am Motor das dem die Kraft bei einer Drehzahl von 
1ner Umdrehung je Sekunde fehlt, im Datenblatt geht die Drehzahl erst 
bei 200 los aber was ist drunter?
Bin ich auf den Holzweg???

Autor: Sven L. (friemler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bastler007 wrote:
> Hey, irgendwie hab ich Probleme das Datasheet zu verstehen, ich hab den
> Link mal gepostet
> http://www.mitsumi.co.jp/Catalog/pdf/motor_m42sp_6nk_e.pdf
> Ich glaube nicht das der Strom verbraten wird, der Kabelquerschnitt zum
> Motor beträgt 0,14mm².

Warum denn nicht, wo soll er denn sonst hin? Durch 0.14'er Kupfer kann 
man locker 2A fließen lassen.

> Ich vermute es liegt am Motor das dem die Kraft bei einer Drehzahl von
> 1ner Umdrehung je Sekunde fehlt, im Datenblatt geht die Drehzahl erst
> bei 200 los aber was ist drunter?

Dann ist er halt langsamer. Ich verstehe die Frage auch nicht ganz, denn 
Schrittmotoren werden eh Strom geregelt betrieben.

Für eine Umdrehung pro Sekunde braucht man für diesen Typ 48 Schritte 
und die 200 geben nicht die Drehzahl, sondern die Anzahl der Schritte je 
Sekunde an bei der man dieses Drehmoment nutzen kann.

Autor: Axel (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich glaube mNm heist nicht Nm.

Das werden eher 0,3Nm sein.
Aber zum Heben von 150g muss das reichen. Auf der Welle des Motors im 
Anhang ist ein Zahnrad, dieses kann man mit der Hand bei langsamer 
Drehzahl nicht festhalten.


Axel

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.