www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega32L bei 5V mit 16 MHz Geht das?


Autor: Benedikt Sauter (Firma: embedded projects GmbH) (flopper)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

weiss jemand ob es Probleme gibt, wenn man den ATMega32L bei 5V mit 
einem externen Takt von 16 MHz versorgt?

Gruss Bene

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ne laut Datenblatt macht der max. 8MHz...

Autor: Benedikt Sauter (Firma: embedded projects GmbH) (flopper)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das hab ich gerade hier im Forum gefunden,
weiss da jemand mehr bescheid?


"...Ich hab hier auch schon mal dasselbe gefragt. Mir wurde das dann
ungefähr so erklärt; Die chips werden nach dem herstellen getestet, ob
sie mit 3.3 Volt@8mhz laufen, wenn ja, dann bekommen sie ein L und
sonst nicht. Das würde aber bedeuten, dass die ohne L sicher nicht
unter diesen Bedingungen laufen würden. Doch das tun einige doch...Wo
man darüber sonst etwas nachlesen kann, weis ich leider auch nicht...."

Autor: Thomas Otto (tarzanwiejane)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Benedikt
ich habe hier nen 16L auf 16MHz@5V laufen. Wenn man dem Datenblatt 
folgt, dann isses ausserhalb der Spec. Kann also gehen muss aber nich.

cu Tarzanwiejane

Autor: cguru (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke die einen werden auf ohne "L" getestet, die anderen auf "L".

Ich habe hier auch L-Varaianten auf 5V und non-L Varianten auf 3V. Ist 
nur nicht garantiert, dass es funktioniert.

Autor: cguru (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
achja @ 16MHz und funktioniert.

Autor: Michael G. (linuxgeek) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also prinzipiell geht da bestimmt so einiges, aber einen dauerhaft 
stabilen Betrieb und eine entsprechend hohe Lebensdauer braucht man dann 
von so nem Bauteil nicht mehr erwarten. Muss man jetzt Microcontroller 
auch schon uebertakten? Ich glaub der Kindergarten wird immer 
groesser... ;)

Michael

Autor: Benedikt Sauter (Firma: embedded projects GmbH) (flopper)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
lol ne geht nicht ums übertakten. Hab ein paar usbprog 3.0 Adapter 
machen lassen, und da sind nun ATMega32L drauf gekommen. Werd die jetzt 
billiger als B-Ware anbieten. Man kann die fest auf 8 MHz per Fuse 
stellen dann gehts einwandfrei. Normal wird der ATMega mit 16 MHz aus 
dem USB Baustein versorgt.

http://www.embedded-projects.net/usbprog

Hab hier genau das gleiche Phänomen wie ihr beschrieben habt. Einer geht 
super mit 16 MHz der andere macht nur Probleme. Dann habe ich den mal 
auf 8 MHz gestellt dann gehts super.

Drum hab ich gefragt!

Danke! Gruss Bene

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.