www.mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik VFD an Sartorius-Waage


Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ein Freund hat mir eine Waage von Satorius gebracht, welche ein Problem 
mit der Anzeige hat, nach dem das Ding neu über 5000€ kostet wäre er mir 
sehr dankbar wenn ich sie repariere:

Die Waage an sich funktioniert wie am ersten Tag, man kann die Anzeige 
allerdings nur mit sehr viel Mühe lesen, weil auch die inaktiven Felder 
des VFD etwas aufleuchten. Der Kontrast wird dadurch sehr schlecht und 
man kann nur mit Mühe den Messwert aus den 7 erscheinenden 8ern 
herauslesen.
Leider hab ich keine Digitalkamera da um das ganze Bildlich 
festzuhalten, ich hoffe man kann es sich vorstellen.
Das komische dran ist aber, dass die Segmente des angezeigten Messwerts 
zumindest vermeintlich kontinuierlich erscheinen, die anderen Segmente 
aber flackern (schätzungsweise Multiplex-Frequenz); das kann aber auch 
nur täuschen.

Vielleicht hat einer von euch so ein ähnliches Problem schon einmal 
gelöst oder etwas mehr Ahnung von VFD, die eindeutig vor meiner Zeit 
aktuell waren :) Eine neue Steuerplatine rein zu machen ist so lustig 
glaub ich auch nicht; die 19 Bit Auflösung der Waage wollen auch erst 
mal zum stehen gebracht werden.

Bin für jede Hilfe dankbar!
Georg

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Vielleicht hat einer von euch so ein ähnliches Problem schon einmal
> gelöst oder etwas mehr Ahnung von VFD, die eindeutig vor meiner Zeit
> aktuell waren :)

Hm..VFDs sind aber immer noch aktuell. Was sagt uns das ueber dich? :-)

Das sind im Prinzip Roehren. Die haben eine Heizung, meist mit 
Wechselspannung. Die wird aber bei dir noch in Ordnung sein.

Ich vermute mal das eins der ICs fuer das Multiplexing ausgefallen ist. 
Du wirst dir mit nem Ossi mal anschauen muessen was da so an den Pins 
anliegt.

Olaf

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Olaf,

mir ist durchaus bewußt, dass FVD auch heute noch ihre Berechtigung 
haben, wollte mit dem "aktuell" eher zum Ausdruck bringen, dass sie 
heute eher selten eingesetzt werden, höchstens man braucht wirklich das 
kontrastreiche Bild. Was das Alter angeht muss ich zugeben, dass die 
Waage mit ihrem Baujahr 3/83, wenn auch nur geringfügig, älter ist als 
ich.

Als Treiber für die einzelnen 7-Segmenter konnte ich einen DS8897 
ausmachen, nachdem der aber wohl nicht mehr zu bekommen ist (RS, 
Farnell, Digikey) hoff ich nicht, dass es an dem liegt. Ich muss es am 
Montag in der Arbeit mal in Ruhe nachmessen. Gibt es irgendwelche 
Quellen für solche Exoten?

Danke
Georg

PS: Wenn man sich den Aufbau ansieht weiß man, warum die Dinger ihr Geld 
kosten :) Sowas war noch wirklich "Made in Germany"

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was das Alter angeht muss ich zugeben, dass die
> Waage mit ihrem Baujahr 3/83, wenn auch nur geringfügig, älter ist als
> ich.

Ist doch gut. Dann wird da wenigstens kein Maskenprogrammierter 
Controller drin sein der ein VFD direkt treiben kann. Da waere ein 
defekter Ausgang dann das Ende.

> Gibt es irgendwelche Quellen für solche Exoten?

Falls du ein Datenblatt findest dann kannst du das Dingen vielleicht 
diskret auf einem Stueck Lochraster nachbauen. Normalerweise sind das 
nur Schieberegister mit Ausgangstreibern welche die hohen Spannungen 
abkoennen.

Olaf

Autor: Marius S. (lupin) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls es nicht klappen sollte mit den VFD würde ich da nicht zuviel 
energie rein stecken - ich würde mir eine stelle suchen an der der 
Messwert abgreifbar ist (z.B. Ansteuerung der 7 Segment anzeigen vor den 
HV Treibern) und dann einfach ein LED Display einbauen.

Autor: Georg (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
@ Olaf
Es sind noch nicht mal Schieberegister, sondern einfache Treiber mit 
zwei Transen drin (siehe Bild). Jetzt kommt es halt drauf an: Ist ein 
VFD ein strom- oder spannungsgesteuertes Bauteil? Wenn der Treiber 
nämlich auch noch strombegrenzend wirkt ist es so einfach dann auch 
nicht mehr.
Was den Controller angeht: Ein Intel 8051 mit sage und schreibe 11MHz 
Quarz, dass muss doch zu der Zeit HighEnd gewesen sein (intern 
schätzungsweise heruntergeteilt); laut Wikipedia dürfte der 
maskenprogrammisert sein.

@ Marius
An diese Option hab ich auch schon gedacht, sie mir aber bis zum Schluss 
aufgehoben. Der Grund ist einfach der, dass ich im Gehäuse keinen Platz 
finde ein neues Display unterzubringen und eine Lösung mit Kabel im 
rauhen Einsatz (Zählwaage im Lager) nicht das Beste ist.

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
VFD's sind beides.

Sie werden meist multigeplext und haben dafür "gitter".
Mit denen gittern kann man sozusagen ein "segment" auswählen, indem man 
das gitter des gewählten segments auf 0V zieht, und an die anderen eine 
negertive spannung.Das ganze funzt fast komplett stromlos.

Die einzelnen Anzeigelemente eines segments sind Anoden, d. h. sie 
brauchen strom, will man ein anzeigeelement leuchten lassen muss man an 
die entsprechende anode an irgendwas zwischen 15-30V ziehen.
Das braucht dann strom im µA oder mA bereich, also nicht ganz so viel

Gruß Jens

Autor: Jens (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups fehler, also sind vfd'S relativ spannungsgesteuert,
stromgesteuert ist natürlich quatsch

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens wrote:
> Mit denen gittern kann man sozusagen ein "segment" auswählen, indem man
> das gitter des gewählten segments auf 0V zieht, und an die anderen eine
> negertive spannung.Das ganze funzt fast komplett stromlos.

Nicht ganz:
Für die Gitter gilt:
Ausgewählt: Meist 10-30V
Nicht ausgewählt: Meist -5 bis 0V

Für die Segemente gilt:
Ausgewählt: Meist 20-80V (je nach Mux Rate)
Nicht ausgewählt: Meist -5 bis 0V

Autor: marvin m. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde mir die ganzen Signale mal mit dem Oszi anschauen, ich könnte 
wetten, dass da irgendwo eine parasitäre Spannung rumschwirrt. 
Vielleicht nur eine schlechte Lötstelle auf der Platine. Sind da ICs 
gesockelt? Falls ja, einmal rausnehmen und wieder reinstecken. Sämtliche 
Stecker mal raus und wieder rein, wenn das alles nichts hilft, mal alle 
relevanten Lötstellen einfach nachlöten. Mit dieser Methode hab ich 
schon so manches wieder hinbekommen, denn auch Goldkontakte und 
Präzisionsfassungen haben nach so einer langen Zeit schonmal 
Kontaktprobleme.

Autor: Olaf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Sind da ICs gesockelt? Falls ja, einmal rausnehmen und wieder
> reinstecken.

Da kann ich nur unterschreiben. Mein Tek465 hat gestern auch rumgezickt. 
Ursache war da ein Kontaktproblem eines ICs im Sockel und der ist auch 
von 1975.

BTW: Tektronik hat uebrigens damals eigene ICs fertigen lassen. Die 
haben alle Beine vergoldet. Die sehen auch heute noch aus wie neu.
Ausserdem haben sie normale ICs von TI verwenden. Da sind die Beine nur 
versilbert. Die sind alle schwarz angelaufen. Ich habe gestern erstmal 
einen Silberputztag eingelegt. :-)

Olaf

Autor: Georg (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo die Herren,

ich hab jetzt doch noch mein altes Oszi rausgeholt und konnte den Fehler 
zurückverfolgen:
Es hat der Elko für die negative Steuerspannung schlapp gemacht, von den 
ursprünglich wohl 100uF zeigt mein Multimeter noch 100nF an :)
Hab ihn ausgetauscht und siehe da, alles läuft wieder.

Jetzt tausch ich vorsorglich noch die anderen Elkos aus, löte alle 
Lötstellen nach und dann gehts zurück an den Eigenttümer (hoffentlich 
für die nächsten 25 Jahre :)

Nochmals danke an alle die mir geholfen haben!
Georg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.